-
Notifications
You must be signed in to change notification settings - Fork 9
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge branch 'main' of github.com:EESSI/gentoo-overlay into 2025.01_set
- Loading branch information
Showing
6 changed files
with
660 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,175 @@ | ||
# Copyright 1999-2025 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
PYTHON_COMPAT=( python3_{10..12} ) | ||
inherit autotools python-r1 s6 systemd tmpfiles multilib-minimal | ||
|
||
DESCRIPTION="NSS module for name lookups using LDAP" | ||
HOMEPAGE="https://arthurdejong.org/nss-pam-ldapd/" | ||
SRC_URI="https://arthurdejong.org/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv x86" | ||
IUSE="debug kerberos +nslcd pam pynslcd sasl test +utils" | ||
REQUIRED_USE=" | ||
${PYTHON_REQUIRED_USE} | ||
utils? ( ${PYTHON_REQUIRED_USE} ) | ||
kerberos? ( sasl ) | ||
test? ( ${PYTHON_REQUIRED_USE} pynslcd ) | ||
" | ||
RESTRICT="!test? ( test )" | ||
|
||
RDEPEND=" | ||
nslcd? ( acct-group/nslcd ) | ||
nslcd? ( acct-user/nslcd ) | ||
net-nds/openldap:=[${MULTILIB_USEDEP}] | ||
sasl? ( dev-libs/cyrus-sasl[${MULTILIB_USEDEP}] ) | ||
kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] ) | ||
pam? ( sys-libs/pam[${MULTILIB_USEDEP}] ) | ||
utils? ( ${PYTHON_DEPS} ) | ||
pynslcd? ( | ||
dev-python/python-ldap[${PYTHON_USEDEP}] | ||
dev-python/python-daemon[${PYTHON_USEDEP}] | ||
) | ||
elibc_musl? ( sys-libs/musl-nscd ) | ||
!sys-auth/nss_ldap | ||
!sys-auth/pam_ldap | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND=" | ||
${PYTHON_DEPS} | ||
test? ( dev-python/pylint[${PYTHON_USEDEP}] ) | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/nss-pam-ldapd-0.9.4-disable-py3-only-linters.patch | ||
"${FILESDIR}"/nss-pam-ldapd-0.9.11-use-mkstemp.patch | ||
"${FILESDIR}"/nss-pam-ldapd-0.9.11-relative-imports.patch | ||
"${FILESDIR}"/nss-pam-ldapd-0.9.11-tests.patch | ||
"${FILESDIR}"/nss-pam-ldapd-0.9.11-tests-py39.patch | ||
"${FILESDIR}"/nss-pam-ldapd-0.9.12-netdb-defines.patch | ||
"${FILESDIR}"/nss-pam-ldapd-0.9.12-configure-CFLAGS-decontamination.patch | ||
) | ||
|
||
pkg_setup() { | ||
[[ ${MERGE_TYPE} != binary ]] && python_setup | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
touch pynslcd/__init__.py || die "Could not create __init__.py for pynslcd" | ||
mv pynslcd/pynslcd.py pynslcd/main.py || die | ||
|
||
find "${S}" -name Makefile.am -exec \ | ||
sed -e '/^AM_CFLAGS/ s/$/ \$(DEBUG_CFLAGS) \$(EXTRA_CFLAGS)/g' \ | ||
-i {} \; || die | ||
|
||
eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
local myconf=( | ||
--disable-utils | ||
--enable-warnings | ||
--with-ldap-lib=openldap | ||
--with-ldap-conf-file="${EPREFIX}"/etc/nslcd.conf | ||
--with-nslcd-pidfile=$(usex nslcd "${EPREFIX}"/run/nslcd/nslcd.pid /run/nslcd/nslcd.pid) | ||
--with-nslcd-socket=$(usex nslcd "${EPREFIX}"/run/nslcd/socket /run/nslcd/socket) | ||
--with-nss-flavour=glibc | ||
$(use_enable nslcd) | ||
$(use_enable pynslcd) | ||
$(use_enable debug) | ||
$(use_enable kerberos) | ||
$(use_enable pam) | ||
$(use_enable sasl) | ||
|
||
# nss libraries always go in /lib on Gentoo | ||
--with-pam-seclib-dir="${EPREFIX}"/$(get_libdir)/security | ||
--libdir="${EPREFIX}"/$(get_libdir) | ||
) | ||
ECONF_SOURCE="${S}" econf "${myconf[@]}" | ||
} | ||
|
||
multilib_src_test() { | ||
python_test() { | ||
cp -l "${S}"/pynslcd/*.py pynslcd/ || die "Could not copy python files for tests" | ||
nonfatal emake check || die "tests failed with ${EPYTHON}" | ||
} | ||
|
||
pushd "${BUILD_DIR}" >/dev/null || die | ||
ln -s ../pynslcd/constants.py utils/constants.py || die | ||
python_foreach_impl python_test | ||
popd >/dev/null || die | ||
} | ||
|
||
multilib_src_install() { | ||
emake DESTDIR="${D}" install | ||
|
||
if use pynslcd; then | ||
python_moduleinto pynslcd | ||
python_foreach_impl python_domodule pynslcd/*.py | ||
fi | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
|
||
! use nslcd && return | ||
|
||
newinitd "${FILESDIR}"/nslcd.init nslcd | ||
s6_install_service nslcd "${FILESDIR}"/nslcd.s6 | ||
|
||
insinto /usr/share/nss-pam-ldapd | ||
doins "${WORKDIR}"/${P}/nslcd.conf | ||
|
||
fperms o-r /etc/nslcd.conf | ||
|
||
if use utils; then | ||
python_moduleinto nslcd | ||
python_foreach_impl python_domodule utils/*.py | ||
|
||
local script | ||
for script in chsh getent; do | ||
python_foreach_impl python_newscript utils/${script}.py ${script}.ldap | ||
done | ||
fi | ||
if use pynslcd; then | ||
rm -rf "${ED}"/usr/share/pynslcd || die | ||
python_moduleinto pynslcd | ||
python_foreach_impl python_domodule pynslcd/*.py | ||
python_scriptinto /usr/sbin | ||
python_foreach_impl python_newscript pynslcd/main.py pynslcd | ||
newinitd "${FILESDIR}"/pynslcd.init pynslcd | ||
fi | ||
|
||
newtmpfiles "${FILESDIR}"/nslcd-tmpfiles.conf nslcd.conf | ||
systemd_newunit "${FILESDIR}"/nslcd.service nslcd.service | ||
} | ||
|
||
pkg_postinst() { | ||
! use nslcd && return | ||
|
||
tmpfiles_process nslcd.conf | ||
|
||
elog "For this to work you must configure /etc/nslcd.conf" | ||
elog "This configuration is similar to pam_ldap's /etc/ldap.conf" | ||
elog | ||
elog "In order to use nss-pam-ldapd, nslcd needs to be running. You can" | ||
elog "start it like this:" | ||
elog " # /etc/init.d/nslcd start" | ||
elog | ||
elog "You can add it to the default runlevel like so:" | ||
elog " # rc-update add nslcd default" | ||
elog | ||
elog "If you have >=sys-apps/openrc-0.16.3, you can also use s6" | ||
elog "to supervise this service." | ||
elog "To do this, emerge sys-apps/s6 then add nslcd-s6" | ||
elog "default runlevel instead of nslcd." | ||
elog | ||
elog "If you are upgrading, keep in mind that /etc/nss-ldapd.conf" | ||
elog " is now named /etc/nslcd.conf" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,15 @@ | ||
AUX sssd 489 BLAKE2B 552ffc9c5053e6de3e4d59ae50cbd95ae44460f51d7f753d9792eefb10507225a32beb91c1a47adf0ddbffff339a245f09c260738a781d05a0a955b8bf283148 SHA512 eab8d42d0188e55a18803b738af77c1969bf7c4b59503ee99975d4739e3c532c300e394a393327b7b98254672c1c2b0b15f81c9c27479e7cbbfb4995ab12b43e | ||
AUX sssd-2.10.0_beta2-fix-systemd-systemconfdir.patch 920 BLAKE2B cda41cc9f381ad5040153eb6f5393bb7f568a08a036e37ee40a86e442ec8addfb459d01314518eb27e593682effb0186445048c899421d1d0bbe33d37666e8ed SHA512 a6009b99778505633fe2fc7b3f48ae1e87a4fa4ae123020049471d4b2e5e9814d848268ce3d969156d7aa2829c5f020bf669dedd466c7ac2eae0db63bf6e0ad0 | ||
AUX sssd-2.8.2-allow-client-build-without-pam.patch 3651 BLAKE2B c8a57ac2a6b46fdb52d874a90a78efd3fa3c7fc787b6e849b1b5736d30082840b001242f211be358a1668cb749bda0985e7872b757990e65e84d718f25ed353d SHA512 6e73f7a140188015dc54061542b5d7d1ef5c68546f3297dcd45cdda44ffcbb0c97e2b59c434715a8003f6912103a4870d8fe66fec551dde28cea244a8ad6a0d6 | ||
AUX sssd-2.8.2-conditional-python-install.patch 553 BLAKE2B 81d9866f2f16e8ce3a2d2bb71780a77227bfeca6d8ae81727c145b461d957ebac432f1c7e460eace1bbb270d21e862f4bfa63e4f2a662e4bca2c9d65e7747fb0 SHA512 06f7d8869e4dcb47c5946c94b41b8311c2c60817d983104f070ce97615c620ff1f8e0e942bc80237e37ade354b8fb06e0cfb245d279030e5ddbb7c0438c814cf | ||
AUX sssd-2.8.2-krb5_pw_locked.patch 453 BLAKE2B 7aed1dd32f0743381b704444ac36dcffa76535d58cd39d307d370290b9b5ad634ef9b90f4d076c7b91b41113792b0d24cf04b63bcd1e1220aa3e790f9c9a23c0 SHA512 e3c210032d6f65ebffa14aa7c398ca929b7bb17d9aa9ef30c2a1522311bc0bf278214d008d7dbac47e8565245b35e00f7143f5c7d0d24f99d64a92486ec50e45 | ||
AUX sssd-2.9.6-conditional-python-install.patch 484 BLAKE2B 7fce3041266d7479ea114ad823f3c63693d0a74547d1d172a67564e62db878f31600f39ff6070f8b6e91f12da5fbfe40e67e90b2f269e049fc3a56f68bf32b9e SHA512 2cb9bf21cdf453d149d5a770e63abbe6aef9c5cd22e805bb8dfa6d0e21f73679c91a1fce071805ae53c6f694d727b1533c0a7618785c00d21934056819a74f5d | ||
AUX sssd.conf 124 BLAKE2B b6f9c016a014510f97b036d23d5f50e1e13085220fe82b0e6ef7a3ceeb114e59af935f39e66e4ad60a46f43983930e5d381b16b0ed31ba4349abe38c4b509367 SHA512 f16908c44b213edbf6b0c6e8d49df92e8c06fc623279037074fe51e49b8aca7dc18f5ed83f71909fc8209df80dfc150583edb1687f88e61588bdf9d1fbf6ed5a | ||
AUX sssd.service 341 BLAKE2B 0cffcd43786633aa8e5bb42c54741cba676021c5a07554b08499504f8f630ff821ff334a21e2a4f9ae2d77d70d969018dd5a85d11b12bb31235a0ffcda4105c8 SHA512 99510d11f390722f56bc164059033fc40299dd4ea29f98cd5f08b2648f31b2e70afeb6b2d90f919bde595546c80b4e6941cf6f48130661ead09c0576043e4cf5 | ||
DIST sssd-2.10.1.tar.gz 9196848 BLAKE2B 9e0677972ee37c4156dcfa86459af97e25d14651ccded87866fd7f18a23d318b578cd98d072afaafa50ae9c68eaf361955aefba1f31de8cf8dac1ca404321146 SHA512 001ff9cd60aa510ead11e418a1b96714136cc270b29551027cb12c340744890b358da5900a10863d4df649ad073f14f6f26c28e3f973b1cd5c2ab61f2a2a045b | ||
DIST sssd-2.8.2.tar.gz 7842210 BLAKE2B e6fefbb74492b0ee840947655016e59b71fe8cd84a163e7a038ecf05fe8c5b46aa0c0f799b90e0a83c6ab79a2e08e75f7e448cf4f827be2cd359d5f21461d999 SHA512 10b7a641823aefb43e30bff9e5f309a1f48446ffff421a06f86496db24ba1fbd384733b5690864507ef9b2f04c91e563fe9820536031f83f1bd6e93edfedee55 | ||
DIST sssd-2.9.6.tar.gz 9136447 BLAKE2B 9ba4faa66d56150de58e86588bd0dedb02ff2f155fa118a35cd981885fed6cab5fdf13373f575a41691c87b4d18c586cba717b399e3826675eee1b0f8da967b7 SHA512 d9a35fc12022f0a2aa73be373b396411fc69b2fe5489ab93d17813a4c75b3ec30e598d5748ab202f7588039b465e11d616ce546cd5fe5439fa8edd9ac8cda69a | ||
EBUILD sssd-2.10.1.ebuild 11255 BLAKE2B e34fd0dd3821ef2f67c218d7fcbba12b0e07a4fdbb54434a59f1ea211369ef34925f7085124c23727fe187c95545df7e37b55edf85fd7be7c977b3099dad4df0 SHA512 52af2bf38a426f223960a55b196b4c06d877b38a31f3799f526f9dd248f915af72ef6f69e0da1f28227a7cabc8ed050b15c4d7f980e9d37aab1e232445d3bd5c | ||
EBUILD sssd-2.8.2.ebuild 8989 BLAKE2B f7c404f25025e22f99ad1c05fea6f5c25285ad2998b74c2e3f9a9a8223a69bf83e5c168b221e1232d5bc4403c71c3aee7bdc206b472a2604994c828c21dcdd39 SHA512 8069c407c4f15e4283d8b6e8bb11e96c7b542720153d36011b30a4528d670cb245065190fcb1085a463a2c4d683cd89d520a6dd26c3b9303649cc1094e116dc9 | ||
EBUILD sssd-2.9.6.ebuild 9761 BLAKE2B 6117c08c74bd61350fcddf1c5a3b456b09adfd1bf4f834774ea05419c6f6703b6975cf3cf946b874dfbc3a7f5d40a2aac8e4c6ec889a813a44376a823e9f9df7 SHA512 1b9d8c87c181de081ebe0863fd330489a1b1c0c5274a56f918fd190ac76e19fc4b03642154591dfa82669bd2c03be17582b71e59ad354f2d6b3433390cc268ae | ||
MISC metadata.xml 1070 BLAKE2B 81c63a79975a71461cca699bde6eb38315eb303f965f3b2786826bb2fe9e9a15e711849fe836e3b6cbaa94ecc715ee546e75e88df4b2c257997a8aed176461c1 SHA512 c3ee1b026993a7be0917574d2b1f0480ca91d72d292305d4a616c7c352803042f34b616464147e04eb28af64b42b4b83bec246a29b1b4d4c1412ab1fe71152fd |
22 changes: 22 additions & 0 deletions
22
sys-auth/sssd/files/sssd-2.10.0_beta2-fix-systemd-systemconfdir.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
diff --git a/src/conf_macros.m4 b/src/conf_macros.m4 | ||
index c0efc3ad1..07fef0c1a 100644 | ||
--- a/src/conf_macros.m4 | ||
+++ b/src/conf_macros.m4 | ||
@@ -227,14 +227,14 @@ AC_DEFUN([WITH_SYSTEMD_CONF_DIR], | ||
if test x"$with_systemdconfdir" != x; then | ||
systemdconfdir=$with_systemdconfdir | ||
else | ||
- pkgconfigdir=${prefix}$($PKG_CONFIG --variable=systemdsystemconfdir systemd) | ||
+ pkgconfigdir=$($PKG_CONFIG --variable=systemdsystemconfdir systemd) | ||
if test x"$pkgconfigdir" = x; then | ||
AC_MSG_ERROR([Could not detect systemd config directory]) | ||
fi | ||
- if test "${pkgconfigdir:0:${#prefix}}" = "${prefix}"; then | ||
+ if test "${pkgconfigdir:0:${#sysconfdir}}" = "${sysconfdir}"; then | ||
systemdconfdir=${pkgconfigdir} | ||
else | ||
- systemdconfdir=${prefix}${pkgconfigdir} | ||
+ systemdconfdir=${sysconfdir}${pkgconfigdir} | ||
fi | ||
fi | ||
AC_SUBST(systemdconfdir, [$systemdconfdir/sssd.service.d]) |
16 changes: 16 additions & 0 deletions
16
sys-auth/sssd/files/sssd-2.9.6-conditional-python-install.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
diff '--color=auto' -Naur a/Makefile.am b/Makefile.am | ||
--- a/Makefile.am 2024-12-05 12:16:16.000000000 +0000 | ||
+++ b/Makefile.am 2025-01-14 12:31:45.831435116 +0000 | ||
@@ -21,7 +21,11 @@ | ||
endif | ||
|
||
SUBDIRS += . src/tests/cwrap src/tests/intg src/tests/test_CA \ | ||
- src/tests/test_ECC_CA src/tools/analyzer | ||
+ src/tests/test_ECC_CA | ||
+ | ||
+if BUILD_PYTHON_BINDINGS | ||
+SUBDIRS += src/tools/analyzer | ||
+endif | ||
|
||
# Some old versions of automake don't define builddir | ||
builddir ?= . |
Oops, something went wrong.