Skip to content

Releases: IceTheCoder/Passwordsy

v0.1.0.1-alpha: Code Cleaning 7

06 Dec 17:43
Compare
Choose a tag to compare
Pre-release

Function names now start with lowercase letters (u/edvmreddit and u/mikeyj777 suggested this)

v0.1.0.0-alpha: More passwords are now outputted!

06 Dec 17:26
Compare
Choose a tag to compare
  • No longer printing possible password characters in the console when generating a password.
  • Implemented the suggestion of u/Intelligent-Wave-130, restructuring the code to output 4 passwords.
  • Error message replaces the first generated password when an invalid length is given.

v0.0.2.0-alpha: Passwords now include digits!

05 Dec 17:45
Compare
Choose a tag to compare
Made generated passwords to include digits.

v0.0.1.0-alpha: Bug Fixing 1

05 Dec 17:41
Compare
Choose a tag to compare
Pre-release
  • Done button is no longer clickable along the entire row.
  • Removed the sticky = 'nsew' parameter from the done button.

v0.0.0.7-alpha: Code Cleaning 6

05 Dec 17:31
226f898
Compare
Choose a tag to compare
Pre-release

Introduced line break in README before 'run main.py'.

v0.0.0.6-alpha: Code Cleaning 5

05 Dec 17:29
Compare
Choose a tag to compare
Pre-release

Implemented main() and if name == "main".

v0.0.0.5-alpha: Code Cleaning 5

05 Dec 12:48
Compare
Choose a tag to compare
Pre-release

Simplified lines 13 - 15 of logic.py

v0.0.0.4-alpha: Code Cleaning 4

05 Dec 12:45
Compare
Choose a tag to compare
Pre-release

Renamed variables to be clearer, along with a few changes.

  • Renamed root to window
  • Renamed welcome to title
  • Changed '(up to 100) Number of characters' to 'Number of characters (up to 100):'
  • Renamed input to input_box
  • Corrected typo in StartPasswordGeneration DOCSTRING ('display' became 'displays')
  • Renamed length to requested_length

v0.0.0.3-alpha: Code Cleaning 3

04 Dec 18:58
2ac0823
Compare
Choose a tag to compare
Pre-release

Separated logic and GUI into two files.

v0.0.0.2-alpha: Code Cleaning 2

04 Dec 16:07
Compare
Choose a tag to compare
Pre-release

Changed every variable to snake_case to make the code more readable.