Replies: 2 comments 4 replies
-
|
Beta Was this translation helpful? Give feedback.
1 reply
-
how about using named args (and a different name for the function, to keep compatibility): pd_add_external(
foo
SRC foo.c bar.c
)
pd_add_external(
foo~
TARGET foo_tilde
SRC foo~.c
) i think that
|
Beta Was this translation helpful? Give feedback.
3 replies
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
-
I would simplify the
add_pd_external
function by reducing the number of arguments from three to two: one for the binary output name and one for the source code. Currently, the function takes three arguments: the library name, the binary output name, and the source code.There's an issue with using the
~
character in theadd_library
function. We have two options to solve this:Not allows the
~
char:FATAL_ERROR
if the user set a output with the ~ character, something like: "You can't use the ~ character, replace it with _tilde."Automatic Replacement: Automatically replace the ~ character, but this approach introduces more problems (as seen in the the test implementation in my repo's dev branch).
Current:
add_pd_external(library_name, binary_output_name, source_code)
Suggested:
add_pd_external(binary_output_name, source_code)
What do you think?
Originally posted by @charlesneimog in #7 (comment)
Beta Was this translation helpful? Give feedback.
All reactions