Skip to content

Commit

Permalink
chore(master): Release 0.52.0 (#8289)
Browse files Browse the repository at this point in the history
🤖 I have created a release *beep* *boop*
---


<details><summary>aztec-package: 0.52.0</summary>

##
[0.52.0](aztec-package-v0.51.1...aztec-package-v0.52.0)
(2024-09-01)


### Miscellaneous

* **aztec-package:** Synchronize aztec-packages versions
</details>

<details><summary>barretenberg.js: 0.52.0</summary>

##
[0.52.0](barretenberg.js-v0.51.1...barretenberg.js-v0.52.0)
(2024-09-01)


### Miscellaneous

* **barretenberg.js:** Synchronize aztec-packages versions
</details>

<details><summary>aztec-packages: 0.52.0</summary>

##
[0.52.0](aztec-packages-v0.51.1...aztec-packages-v0.52.0)
(2024-09-01)


### ⚠ BREAKING CHANGES

* Check unused generics are bound
(noir-lang/noir#5840)

### Features

* Add `Expr::as_assert` (noir-lang/noir#5857)
([cf5b667](cf5b667))
* Add `Expr::resolve` and `TypedExpr::as_function_definition`
(noir-lang/noir#5859)
([cf5b667](cf5b667))
* Add `FunctionDef::body` (noir-lang/noir#5825)
([cf5b667](cf5b667))
* Add `FunctionDef::has_named_attribute`
(noir-lang/noir#5870)
([cf5b667](cf5b667))
* Add `Type::as_string` (noir-lang/noir#5871)
([cf5b667](cf5b667))
* Clarify state in Protogalaxy 3
([#8181](#8181))
([4a9bb9d](4a9bb9d))
* LSP signature help for assert and assert_eq
(noir-lang/noir#5862)
([cf5b667](cf5b667))
* **meta:** Comptime keccak
(noir-lang/noir#5854)
([cf5b667](cf5b667))
* **optimization:** Avoid merging identical (by ID) arrays
(noir-lang/noir#5853)
([cf5b667](cf5b667))
* **perf:** Simplify poseidon2 cache zero-pad
(noir-lang/noir#5869)
([cf5b667](cf5b667))
* Populate epoch 0 from initial validator set
([#8286](#8286))
([cbdec54](cbdec54))
* Remove unnecessary copying of vector size during reversal
(noir-lang/noir#5852)
([cf5b667](cf5b667))
* Removing `is_dev_net` flag
([#8275](#8275))
([fc1f307](fc1f307))
* Show backtrace on comptime assertion failures
(noir-lang/noir#5842)
([cf5b667](cf5b667))
* Simplify constant calls to `poseidon2_permutation`, `schnorr_verify`
and `embedded_curve_add` (noir-lang/noir#5140)
([cf5b667](cf5b667))
* Sync from aztec-packages (noir-lang/noir#5790)
([cf5b667](cf5b667))
* Warn on unused imports (noir-lang/noir#5847)
([cf5b667](cf5b667))


### Bug Fixes

* Check unused generics are bound
(noir-lang/noir#5840)
([cf5b667](cf5b667))
* Enforce parity of sequencer tx validation and node tx validation
([#7951](#7951))
([c7eaf92](c7eaf92))
* Make simulations validate resulting tx by default
([#8157](#8157))
([f5e388d](f5e388d))
* **nargo:** Resolve Brillig assertion payloads
(noir-lang/noir#5872)
([cf5b667](cf5b667))
* Prevent honk proof from getting stale inputs on syncs
([#8293](#8293))
([2598108](2598108))
* Remove fee juice mint public
([#8260](#8260))
([2395af3](2395af3))
* **sha256:** Add extra checks against message size when constructing
msg blocks (noir-lang/noir#5861)
([cf5b667](cf5b667))
* **sha256:** Fix upper bound when building msg block and delay final
block compression under certain cases
(noir-lang/noir#5838)
([cf5b667](cf5b667))
* **sha256:** Perform compression per block and utilize ROM instead of
RAM when setting up the message block
(noir-lang/noir#5760)
([cf5b667](cf5b667))


### Miscellaneous

* Add documentation to `to_be_bytes`, etc.
(noir-lang/noir#5843)
([cf5b667](cf5b667))
* Add missing cases to arithmetic generics
(noir-lang/noir#5841)
([cf5b667](cf5b667))
* Add test to reproduce
[#8306](#8306)
([41d418c](41d418c))
* Alert slack on Sepolia test
([#8263](#8263))
([6194b94](6194b94))
* **bb:** Make compile on stock mac clang
([#8278](#8278))
([7af80ff](7af80ff))
* **bb:** More graceful pippenger on non-powers-of-2
([#8279](#8279))
([104ea85](104ea85))
* Bump noir-bignum to 0.3.2
([#8276](#8276))
([4c6fe1a](4c6fe1a))
* **ci:** Try to debug 'command brotli not found'
([#8305](#8305))
([9ee8dd6](9ee8dd6))
* Don't require empty `Prover.toml` for programs with zero arguments but
a return value (noir-lang/noir#5845)
([cf5b667](cf5b667))
* Fix a bunch of generics issues in aztec-nr
([#8295](#8295))
([6e84970](6e84970))
* Fix more issues with generics
([#8302](#8302))
([4e2ce80](4e2ce80))
* Fix warnings in `avm-transpiler`
([#8307](#8307))
([359fe05](359fe05))
* Introduce the Visitor pattern
(noir-lang/noir#5868)
([cf5b667](cf5b667))
* **perf:** Simplify poseidon2 algorithm
(noir-lang/noir#5811)
([cf5b667](cf5b667))
* **perf:** Update to stdlib keccak for reduced Brillig code size
(noir-lang/noir#5827)
([cf5b667](cf5b667))
* Redo typo PR by nnsW3 (noir-lang/noir#5834)
([cf5b667](cf5b667))
* Renaming around Protogalaxy Prover
([#8272](#8272))
([be2169d](be2169d))
* Replace relative paths to noir-protocol-circuits
([56e3fbf](56e3fbf))
* Replace relative paths to noir-protocol-circuits
([1b245c4](1b245c4))
* Replace relative paths to noir-protocol-circuits
([9c3bc43](9c3bc43))
* **revert:** Earthfile accidental change
([#8309](#8309))
([2d3e0b6](2d3e0b6))
* Underconstrained check in parallel
(noir-lang/noir#5848)
([cf5b667](cf5b667))


### Documentation

* **bb:** Transcript spec
([#8301](#8301))
([18abf37](18abf37))
</details>

<details><summary>barretenberg: 0.52.0</summary>

##
[0.52.0](barretenberg-v0.51.1...barretenberg-v0.52.0)
(2024-09-01)


### Features

* Clarify state in Protogalaxy 3
([#8181](#8181))
([4a9bb9d](4a9bb9d))


### Bug Fixes

* Prevent honk proof from getting stale inputs on syncs
([#8293](#8293))
([2598108](2598108))


### Miscellaneous

* **bb:** Make compile on stock mac clang
([#8278](#8278))
([7af80ff](7af80ff))
* **bb:** More graceful pippenger on non-powers-of-2
([#8279](#8279))
([104ea85](104ea85))
* Renaming around Protogalaxy Prover
([#8272](#8272))
([be2169d](be2169d))
* **revert:** Earthfile accidental change
([#8309](#8309))
([2d3e0b6](2d3e0b6))


### Documentation

* **bb:** Transcript spec
([#8301](#8301))
([18abf37](18abf37))
</details>

---
This PR was generated with [Release
Please](https://github.com/googleapis/release-please). See
[documentation](https://github.com/googleapis/release-please#release-please).
  • Loading branch information
AztecBot authored Sep 2, 2024
1 parent cf5b667 commit 4dd51eb
Show file tree
Hide file tree
Showing 8 changed files with 117 additions and 7 deletions.
8 changes: 4 additions & 4 deletions .release-please-manifest.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
".": "0.51.1",
".": "0.52.0",
"yarn-project/cli": "0.35.1",
"yarn-project/aztec": "0.51.1",
"barretenberg": "0.51.1",
"barretenberg/ts": "0.51.1"
"yarn-project/aztec": "0.52.0",
"barretenberg": "0.52.0",
"barretenberg/ts": "0.52.0"
}
71 changes: 71 additions & 0 deletions CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,76 @@
# Changelog

## [0.52.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.51.1...aztec-packages-v0.52.0) (2024-09-01)


### ⚠ BREAKING CHANGES

* Check unused generics are bound (https://github.com/noir-lang/noir/pull/5840)

### Features

* Add `Expr::as_assert` (https://github.com/noir-lang/noir/pull/5857) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Add `Expr::resolve` and `TypedExpr::as_function_definition` (https://github.com/noir-lang/noir/pull/5859) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Add `FunctionDef::body` (https://github.com/noir-lang/noir/pull/5825) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Add `FunctionDef::has_named_attribute` (https://github.com/noir-lang/noir/pull/5870) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Add `Type::as_string` (https://github.com/noir-lang/noir/pull/5871) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Clarify state in Protogalaxy 3 ([#8181](https://github.com/AztecProtocol/aztec-packages/issues/8181)) ([4a9bb9d](https://github.com/AztecProtocol/aztec-packages/commit/4a9bb9d47e6b1838875c9ce16fa80a2133b05920))
* LSP signature help for assert and assert_eq (https://github.com/noir-lang/noir/pull/5862) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* **meta:** Comptime keccak (https://github.com/noir-lang/noir/pull/5854) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* **optimization:** Avoid merging identical (by ID) arrays (https://github.com/noir-lang/noir/pull/5853) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* **perf:** Simplify poseidon2 cache zero-pad (https://github.com/noir-lang/noir/pull/5869) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Populate epoch 0 from initial validator set ([#8286](https://github.com/AztecProtocol/aztec-packages/issues/8286)) ([cbdec54](https://github.com/AztecProtocol/aztec-packages/commit/cbdec5467f902388949bda0c5acc26dfbda26366))
* Remove unnecessary copying of vector size during reversal (https://github.com/noir-lang/noir/pull/5852) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Removing `is_dev_net` flag ([#8275](https://github.com/AztecProtocol/aztec-packages/issues/8275)) ([fc1f307](https://github.com/AztecProtocol/aztec-packages/commit/fc1f30787b83a0c9c2ca73e675ff666395d24d74))
* Show backtrace on comptime assertion failures (https://github.com/noir-lang/noir/pull/5842) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Simplify constant calls to `poseidon2_permutation`, `schnorr_verify` and `embedded_curve_add` (https://github.com/noir-lang/noir/pull/5140) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Sync from aztec-packages (https://github.com/noir-lang/noir/pull/5790) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Warn on unused imports (https://github.com/noir-lang/noir/pull/5847) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))


### Bug Fixes

* Check unused generics are bound (https://github.com/noir-lang/noir/pull/5840) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Enforce parity of sequencer tx validation and node tx validation ([#7951](https://github.com/AztecProtocol/aztec-packages/issues/7951)) ([c7eaf92](https://github.com/AztecProtocol/aztec-packages/commit/c7eaf925c26ae9199faaf21ed1b1a220db26cfc7))
* Make simulations validate resulting tx by default ([#8157](https://github.com/AztecProtocol/aztec-packages/issues/8157)) ([f5e388d](https://github.com/AztecProtocol/aztec-packages/commit/f5e388dd2d7c78d89da391603c50fda3a2309a76))
* **nargo:** Resolve Brillig assertion payloads (https://github.com/noir-lang/noir/pull/5872) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Prevent honk proof from getting stale inputs on syncs ([#8293](https://github.com/AztecProtocol/aztec-packages/issues/8293)) ([2598108](https://github.com/AztecProtocol/aztec-packages/commit/2598108e038a9fe791d3fc6e0c0ee064a1511a09))
* Remove fee juice mint public ([#8260](https://github.com/AztecProtocol/aztec-packages/issues/8260)) ([2395af3](https://github.com/AztecProtocol/aztec-packages/commit/2395af3014ff2c7c3148e2511350b92059c0325b))
* **sha256:** Add extra checks against message size when constructing msg blocks (https://github.com/noir-lang/noir/pull/5861) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* **sha256:** Fix upper bound when building msg block and delay final block compression under certain cases (https://github.com/noir-lang/noir/pull/5838) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* **sha256:** Perform compression per block and utilize ROM instead of RAM when setting up the message block (https://github.com/noir-lang/noir/pull/5760) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))


### Miscellaneous

* Add documentation to `to_be_bytes`, etc. (https://github.com/noir-lang/noir/pull/5843) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Add missing cases to arithmetic generics (https://github.com/noir-lang/noir/pull/5841) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Add test to reproduce [#8306](https://github.com/AztecProtocol/aztec-packages/issues/8306) ([41d418c](https://github.com/AztecProtocol/aztec-packages/commit/41d418cf6e04c8598d813d0bc39534954552f477))
* Alert slack on Sepolia test ([#8263](https://github.com/AztecProtocol/aztec-packages/issues/8263)) ([6194b94](https://github.com/AztecProtocol/aztec-packages/commit/6194b94f2b2874d032beaf8a04fa2c34e4f633fd))
* **bb:** Make compile on stock mac clang ([#8278](https://github.com/AztecProtocol/aztec-packages/issues/8278)) ([7af80ff](https://github.com/AztecProtocol/aztec-packages/commit/7af80ff98313a20ed18dc15fd5e4c22c82828a98))
* **bb:** More graceful pippenger on non-powers-of-2 ([#8279](https://github.com/AztecProtocol/aztec-packages/issues/8279)) ([104ea85](https://github.com/AztecProtocol/aztec-packages/commit/104ea85667b4be03dd52cd20812907e0b85bcdd8))
* Bump noir-bignum to 0.3.2 ([#8276](https://github.com/AztecProtocol/aztec-packages/issues/8276)) ([4c6fe1a](https://github.com/AztecProtocol/aztec-packages/commit/4c6fe1ace4831820304ec0962d897affde7df1e0))
* **ci:** Try to debug 'command brotli not found' ([#8305](https://github.com/AztecProtocol/aztec-packages/issues/8305)) ([9ee8dd6](https://github.com/AztecProtocol/aztec-packages/commit/9ee8dd60a25ef93aa0efaa43d9092292360c1f09))
* Don't require empty `Prover.toml` for programs with zero arguments but a return value (https://github.com/noir-lang/noir/pull/5845) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Fix a bunch of generics issues in aztec-nr ([#8295](https://github.com/AztecProtocol/aztec-packages/issues/8295)) ([6e84970](https://github.com/AztecProtocol/aztec-packages/commit/6e84970a4fc1a345dac03e2c9881bd5a8f353f50))
* Fix more issues with generics ([#8302](https://github.com/AztecProtocol/aztec-packages/issues/8302)) ([4e2ce80](https://github.com/AztecProtocol/aztec-packages/commit/4e2ce801a9f786290c34c93eb92b11fdeda4f88d))
* Fix warnings in `avm-transpiler` ([#8307](https://github.com/AztecProtocol/aztec-packages/issues/8307)) ([359fe05](https://github.com/AztecProtocol/aztec-packages/commit/359fe0513aa1e7105e15dc92fcc7fbcab5da45c6))
* Introduce the Visitor pattern (https://github.com/noir-lang/noir/pull/5868) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* **perf:** Simplify poseidon2 algorithm (https://github.com/noir-lang/noir/pull/5811) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* **perf:** Update to stdlib keccak for reduced Brillig code size (https://github.com/noir-lang/noir/pull/5827) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Redo typo PR by nnsW3 (https://github.com/noir-lang/noir/pull/5834) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))
* Renaming around Protogalaxy Prover ([#8272](https://github.com/AztecProtocol/aztec-packages/issues/8272)) ([be2169d](https://github.com/AztecProtocol/aztec-packages/commit/be2169da8057a06c0cc5c503ec523e62647775e1))
* Replace relative paths to noir-protocol-circuits ([56e3fbf](https://github.com/AztecProtocol/aztec-packages/commit/56e3fbf45b3e0a434678442c132115daf41316c6))
* Replace relative paths to noir-protocol-circuits ([1b245c4](https://github.com/AztecProtocol/aztec-packages/commit/1b245c43e9db54dc63c9536fbfc5a3a037f38a45))
* Replace relative paths to noir-protocol-circuits ([9c3bc43](https://github.com/AztecProtocol/aztec-packages/commit/9c3bc4393f6c80dc94cbbb79ddc91d5970fcc075))
* **revert:** Earthfile accidental change ([#8309](https://github.com/AztecProtocol/aztec-packages/issues/8309)) ([2d3e0b6](https://github.com/AztecProtocol/aztec-packages/commit/2d3e0b672c11eddf0e4e50f00a42a662bdd67c0c))
* Underconstrained check in parallel (https://github.com/noir-lang/noir/pull/5848) ([cf5b667](https://github.com/AztecProtocol/aztec-packages/commit/cf5b667c9566019853a5dc2a7f16ed024ab9182b))


### Documentation

* **bb:** Transcript spec ([#8301](https://github.com/AztecProtocol/aztec-packages/issues/8301)) ([18abf37](https://github.com/AztecProtocol/aztec-packages/commit/18abf3785e0826b81417b9f99ffe9776a0213fb1))

## [0.51.1](https://github.com/AztecProtocol/aztec-packages/compare/aztec-packages-v0.51.0...aztec-packages-v0.51.1) (2024-08-29)


Expand Down
25 changes: 25 additions & 0 deletions barretenberg/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,30 @@
# Changelog

## [0.52.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.51.1...barretenberg-v0.52.0) (2024-09-01)


### Features

* Clarify state in Protogalaxy 3 ([#8181](https://github.com/AztecProtocol/aztec-packages/issues/8181)) ([4a9bb9d](https://github.com/AztecProtocol/aztec-packages/commit/4a9bb9d47e6b1838875c9ce16fa80a2133b05920))


### Bug Fixes

* Prevent honk proof from getting stale inputs on syncs ([#8293](https://github.com/AztecProtocol/aztec-packages/issues/8293)) ([2598108](https://github.com/AztecProtocol/aztec-packages/commit/2598108e038a9fe791d3fc6e0c0ee064a1511a09))


### Miscellaneous

* **bb:** Make compile on stock mac clang ([#8278](https://github.com/AztecProtocol/aztec-packages/issues/8278)) ([7af80ff](https://github.com/AztecProtocol/aztec-packages/commit/7af80ff98313a20ed18dc15fd5e4c22c82828a98))
* **bb:** More graceful pippenger on non-powers-of-2 ([#8279](https://github.com/AztecProtocol/aztec-packages/issues/8279)) ([104ea85](https://github.com/AztecProtocol/aztec-packages/commit/104ea85667b4be03dd52cd20812907e0b85bcdd8))
* Renaming around Protogalaxy Prover ([#8272](https://github.com/AztecProtocol/aztec-packages/issues/8272)) ([be2169d](https://github.com/AztecProtocol/aztec-packages/commit/be2169da8057a06c0cc5c503ec523e62647775e1))
* **revert:** Earthfile accidental change ([#8309](https://github.com/AztecProtocol/aztec-packages/issues/8309)) ([2d3e0b6](https://github.com/AztecProtocol/aztec-packages/commit/2d3e0b672c11eddf0e4e50f00a42a662bdd67c0c))


### Documentation

* **bb:** Transcript spec ([#8301](https://github.com/AztecProtocol/aztec-packages/issues/8301)) ([18abf37](https://github.com/AztecProtocol/aztec-packages/commit/18abf3785e0826b81417b9f99ffe9776a0213fb1))

## [0.51.1](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg-v0.51.0...barretenberg-v0.51.1) (2024-08-29)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/cpp/CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 3.24 FATAL_ERROR)
project(
Barretenberg
DESCRIPTION "BN254 elliptic curve library, and PLONK SNARK prover"
VERSION 0.51.1 # x-release-please-version
VERSION 0.52.0 # x-release-please-version
LANGUAGES CXX C
)
# Insert version into `bb` config file
Expand Down
7 changes: 7 additions & 0 deletions barretenberg/ts/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,12 @@
# Changelog

## [0.52.0](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.51.1...barretenberg.js-v0.52.0) (2024-09-01)


### Miscellaneous

* **barretenberg.js:** Synchronize aztec-packages versions

## [0.51.1](https://github.com/AztecProtocol/aztec-packages/compare/barretenberg.js-v0.51.0...barretenberg.js-v0.51.1) (2024-08-29)


Expand Down
2 changes: 1 addition & 1 deletion barretenberg/ts/package.json
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
{
"name": "@aztec/bb.js",
"packageManager": "[email protected]",
"version": "0.51.1",
"version": "0.52.0",
"homepage": "https://github.com/AztecProtocol/aztec-packages/tree/master/barretenberg/ts",
"license": "MIT",
"type": "module",
Expand Down
7 changes: 7 additions & 0 deletions yarn-project/aztec/CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,12 @@
# Changelog

## [0.52.0](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.51.1...aztec-package-v0.52.0) (2024-09-01)


### Miscellaneous

* **aztec-package:** Synchronize aztec-packages versions

## [0.51.1](https://github.com/AztecProtocol/aztec-packages/compare/aztec-package-v0.51.0...aztec-package-v0.51.1) (2024-08-29)


Expand Down
2 changes: 1 addition & 1 deletion yarn-project/aztec/package.json
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
{
"name": "@aztec/aztec",
"version": "0.51.1",
"version": "0.52.0",
"type": "module",
"exports": {
".": "./dest/index.js"
Expand Down

0 comments on commit 4dd51eb

Please sign in to comment.