Skip to content

Commit

Permalink
feat: run prove_then_verify_goblin in CI
Browse files Browse the repository at this point in the history
  • Loading branch information
ludamad0 committed Dec 13, 2023
1 parent 5666efb commit f71424c
Show file tree
Hide file tree
Showing 3 changed files with 13 additions and 1 deletion.
2 changes: 2 additions & 0 deletions barretenberg/acir_tests/Dockerfile.bb
Original file line number Diff line number Diff line change
Expand Up @@ -10,5 +10,7 @@ COPY . .
# Run every acir test through native bb build prove_then_verify flow.
# This ensures we test independent pk construction through real/garbage witness data paths.
RUN FLOW=prove_then_verify ./run_acir_tests.sh
# Run goblin tests. This will eventually replace e.g. prove_then_verify, see (https://github.com/AztecProtocol/barretenberg/issues/811)
RUN FLOW=prove_and_verify_goblin ./run_acir_tests.sh
# Run 1_mul through native bb build, all_cmds flow, to test all cli args.
RUN VERBOSE=1 FLOW=all_cmds ./run_acir_tests.sh 1_mul
8 changes: 8 additions & 0 deletions barretenberg/acir_tests/flows/prove_and_verify_goblin.sh
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
#!/bin/sh
set -eu

VFLAG=${VERBOSE:+-v}

# This is the fastest flow, because it only generates pk/vk once, gate count once, etc.
# It may not catch all class of bugs.
$BIN prove_and_verify_goblin $VFLAG -c $CRS_PATH -b ./target/acir.gz
4 changes: 3 additions & 1 deletion barretenberg/cpp/src/barretenberg/bb/main.cpp
Original file line number Diff line number Diff line change
Expand Up @@ -453,8 +453,10 @@ int main(int argc, char* argv[])
acvm_info(output_path);
return 0;
}

if (command == "prove_and_verify") {
return proveAndVerify(bytecode_path, witness_path, recursive) ? 0 : 1;
}
if (command == "prove_and_verify_goblin") {
return proveAndVerifyGoblin(bytecode_path, witness_path, recursive) ? 0 : 1;
}
if (command == "prove") {
Expand Down

0 comments on commit f71424c

Please sign in to comment.