Skip to content

Commit

Permalink
rq: Update to 0.0.10
Browse files Browse the repository at this point in the history
Changes:
v0.0.10
* bump embedded OPA version from v0.63.0 to v0.69.0
* new builtins:
	* `rq.slug()`
* new input formats: jsonc

v0.0.9
* bump embedded OPA version from v0.58.0 to v0.63.0
* fixed a bug where a trailing newline would always be written to
  standard out, even when `-O` was asserted
* added `-c/--check` to make it easy to use rq from if statements in shell
* `-o null` now outputs 0 bytes, rather than a `\n`
* fixed a bug where incorrect TTY detection could cause piping the
  output of `rq` to another process to hang indefinitely

v0.0.8
* bump embedded OPA version from v0.56.0 to v0.58.0
* `--ugly` now implies `--no-color`
* add `rq capabilities` subcommand to generate an OPA-style `capabilities.json`
* ship an OPA-style `capabilities.json` file for easier integration
  with tools that consume it
* adopt go-isatty for TTY detection
* disable output colorization on Windows unless
  `RQ_SUPPRESS_WINDOWS_NO_COLOR` is defined
* `rq.error()` now only displays the error string provided by the user
* `rq.run()` now accepts an `env` option to pass environment
  variables to the subprocess (#11)

v0.0.7
* bump embedded OPA version from v0.54.0 to v0.56.0
* new builtins:
	* `rq.fake()`
	* `rq.sfake()`
	* `rq.quote()`
	* `rq.unquote()`
* new template functions:
	* `fake`
	* `sfake`
	* `quote`
	* `unquote`
* `text/template` is now used consistently throughout rq, which
  should fix template outputs sometimes containing URL-encoded
  characters
* added `-p/--in-place` option for modifying files in place
* new output formats: `null`
* refactored the `raw` output handler, added `raw.fl`, `raw.fs`,
  `raw.fr`, `raw.rl`, `raw.rs`, `raw.rr` options to bring it more
  inline with the `raw` input handler, and added support for tabular
  data
* `template` output handler now supports array shaped data by
  applying the template to each element, writing newlines (configurable
  by `template.sep`) in between
  • Loading branch information
iamleot committed Nov 23, 2024
1 parent 92f6a9d commit aa60576
Show file tree
Hide file tree
Showing 3 changed files with 418 additions and 322 deletions.
6 changes: 3 additions & 3 deletions rq/Makefile
Original file line number Diff line number Diff line change
@@ -1,15 +1,15 @@
# $NetBSD$

DISTNAME= rq-0.0.7rc1
DISTNAME= rq-0.0.10
CATEGORIES= devel
MASTER_SITES= -https://git.sr.ht/~charles/rq/archive/v${PKGVERSION_NOREV:S/rc/-RC/}.tar.gz
MASTER_SITES= -https://git.sr.ht/~charles/rq/archive/v${PKGVERSION_NOREV}.tar.gz

MAINTAINER= [email protected]
HOMEPAGE= https://git.sr.ht/~charles/rq
COMMENT= Rego Query
LICENSE= mit

WRKSRC= ${WRKDIR}/${DISTNAME:S/-/-v/:S/rc/-RC/}
WRKSRC= ${WRKDIR}/${PKGBASE}-v${PKGVERSION_NOREV}

GO_BUILD_PATTERN+= ./cmd/rq

Expand Down
Loading

0 comments on commit aa60576

Please sign in to comment.