Skip to content

Commit

Permalink
xidle: update to version 20220718.
Browse files Browse the repository at this point in the history
Sync xidle with current OpenBSD/xenocara sources using
self-hosted tarball.

ChangeLog:

- Use setsid() to close stdio before entering main loop
- Use the proper macros in the AUTHORS section
- Add an option to disable the active area
- Disable unneeded bzero(3) on already zero initialized global data
- Use strtonum(3)
- Remove obsolete linter hints.
- Consistently handle `-display' option together with others.
  • Loading branch information
Paolo Vincenzo Olivo committed Jul 18, 2022
1 parent bf7dd50 commit dbffee5
Show file tree
Hide file tree
Showing 3 changed files with 25 additions and 12 deletions.
8 changes: 4 additions & 4 deletions xidle/Makefile
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
# $NetBSD$

DISTNAME= xidle-26052015
DISTNAME= xidle-20220718
CATEGORIES= x11
MASTER_SITES= http://distcache.freebsd.org/local-distfiles/novel/
MASTER_SITES= https://sehnsucht.multics.org/pub/pkgsrc/distfiles/
DIST_SUBDIR= ${PKGNAME_NOREV}
EXTRACT_SUFX= .tar.bz2
EXTRACT_SUFX= .tar.xz

MAINTAINER= [email protected]
HOMEPAGE= http://distcache.freebsd.org/local-distfiles/novel/
HOMEPAGE= https://man.openbsd.org/xidle.1
COMMENT= Run a program on X inactivity
LICENSE= isc

Expand Down
8 changes: 4 additions & 4 deletions xidle/distinfo
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD$

BLAKE2s (xidle-26052015/xidle-26052015.tar.bz2) = 18d1b041f2a2cab14570af881a199e6486fb6ea0c0941f682aaf7ba1223cdcd7
SHA512 (xidle-26052015/xidle-26052015.tar.bz2) = bb132a431a5dd585be6a93519aa06a73eade63dde81bbe582a5dd966646c5eeaca65fa2573e6795b73bbfd08388390b4e92954929577051f13098ef8e38c2200
Size (xidle-26052015/xidle-26052015.tar.bz2) = 5897 bytes
BLAKE2s (xidle-20220718/xidle-20220718.tar.xz) = fb40e18d9bfe7b8379b57390e79e35a7df2f06223632f8c71da4c20244eaff92
SHA512 (xidle-20220718/xidle-20220718.tar.xz) = f72fdc91a2c9173ca26291d46ed3857624a1be7c44918bf7e985f0dae184eb8c0201c4e0fb0cda5f33e6f488835f7a68e888aebc180c1eca3c4396a67e659c86
Size (xidle-20220718/xidle-20220718.tar.xz) = 5640 bytes
SHA1 (patch-Makefile) = f93b2ffc31da13d143dd157d670e299f0568713a
SHA1 (patch-xidle.1) = dcb4906dd1ca4780925ffd96193afd3cdb3b6401
SHA1 (patch-xidle.c) = 7c1082bd3cc12fd26fec1ef58aebd0e6941420b5
SHA1 (patch-xidle.c) = bcdb287b5ea23407e916fe4b7b56c4a1da703d9d
21 changes: 17 additions & 4 deletions xidle/patches/patch-xidle.c
Original file line number Diff line number Diff line change
@@ -1,11 +1,14 @@
$NetBSD$

Define non-standard compiler attribute extension.
Do not hard-code xlock path.
Portability fixes:

--- xidle.c.orig 2015-05-26 05:22:15.000000000 +0000
- Define non-standard compiler attribute extension.
- Do not hard-code xlock path.
- Disable pledge.

--- xidle.c.orig 2022-07-18 06:17:31.000000000 +0000
+++ xidle.c
@@ -43,9 +43,12 @@
@@ -45,9 +45,12 @@
#endif

#ifndef PATH_PROG
Expand All @@ -19,3 +22,13 @@ Do not hard-code xlock path.

enum {
north = 0x01,
@@ -354,9 +357,6 @@ main(int argc, char **argv)
if (fd > 2)
close(fd);

- if (pledge("stdio proc exec", NULL) == -1)
- err(1, "pledge");
-
for (;;) {
XEvent ev;
u_long mask;

0 comments on commit dbffee5

Please sign in to comment.