Skip to content

Commit

Permalink
(textproc/R-openxlsx) Updated 4.2.4 to 4.2.7.1
Browse files Browse the repository at this point in the history
# openxlsx 4.2.7.1

* It's now possible to insert a hyperlinked image by passing a URL,
  relative or absolute file path, or mailto string to the new
  `address` parameter of `insertImage()`.

# openxlsx 4.2.7

* Fixed warning on `dataValidation(..., type = "list")`
  ([#342](ycphs/openxlsx#342))

* Added optional argument to `loadWorkbook` to decide if empty/blank
  cells should be converted to NA_character_ (the default) or left
  blank as is

* `saveWorkbook()` now succeeds when called after the user has set
  column widths for a range of columns (e.g. 1:2), saved the workbook,
  then set column widths for a new range that is inclusive of the
  previous one (e.g. 1:5)
  ([#493](ycphs/openxlsx#493)).

## Improvements

* Improve detectDates
  ([#288](ycphs/openxlsx#288))

* Preserve window size and position, also `getWindowSize()` and
  `setWindowSize()`
  ([466](ycphs/openxlsx#466))

# openxlsx 4.2.6

* Fix external links
  ([#410](ycphs/openxlsx#410))

* Do not add unneccessary sheetPr node
  ([#409](ycphs/openxlsx#409))

* Add support for `namedRegion`s having dots and other special
  characters ([#338](ycphs/openxlsx#338)).

* Add type blanks and not blanks to conditional formatting
  ([#311](ycphs/openxlsx#311))

# openxlsx 4.2.5

## Fixes

* `openxlsx_setOp()` now works with named list
  ([#215](ycphs/openxlsx#215))

* `loadWorkbook()` imports `inlineStr`. Values remain `inlineStr` when
  writing the workbook with `saveWorkbook()`. Similar `read.xlsx` and
  `readWorkbook` import `inlineStr`.

* `read.xlsx()` no longer changes random seed
  ([#183](ycphs/openxlsx#183))

* fixed a regression that caused fonts to be read in incorrectly
  ([#207](ycphs/openxlsx#207))

* add option to save as read only recommended
  ([#201](ycphs/openxlsx#201))

* fixed writing hyperlink formulas
  ([#200](ycphs/openxlsx#200))

* `write.xlsx()` now throws an error if it doesn't have write
  permissions ([#190](ycphs/openxlsx#190))

* `write.xlsx()` now again uses the default of `overwrite = TRUE` for
  saving files ([#249](ycphs/openxlsx#249))

* `as.character.formula()` exported to warn about potential conflicts
  with other packages
  ([#312](ycphs/openxlsx#312),
  [#315](ycphs/openxlsx#315))

## Improvements

* `options()` are more consistently set in functions (see:
  [#289](ycphs/openxlsx#262))

* `Workbook$show()` no longer fails when called in a 0 sheet
  workbook([#240](ycphs/openxlsx#240))

* `read.xlsx()` again accepts `.xlsm` files
([#205](ycphs/openxlsx#205),
[#209](ycphs/openxlsx#209))

* `makeHyperlinkString()` does no longer require a sheet argument
  ([#57](ycphs/openxlsx#57),
  [#58](ycphs/openxlsx#58))

* improvements in how `openxlsx` creates temporary directories (see
  [#262](ycphs/openxlsx#262))

* `writeData()` calls `force(x)` to evaluate the object before options
  are set ([#264](ycphs/openxlsx#264))

* `createComment()` now correctly handles `integers` in `width` and
  `height` ([#275](ycphs/openxlsx#275))

* `setStyles()` accepts `halign="justify"`
  ([#305](ycphs/openxlsx#305))
  • Loading branch information
mef committed Jan 3, 2025
1 parent 2a70e04 commit a91df5a
Show file tree
Hide file tree
Showing 2 changed files with 9 additions and 6 deletions.
7 changes: 5 additions & 2 deletions textproc/R-openxlsx/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.3 2021/09/08 13:38:35 mef Exp $
# $NetBSD: Makefile,v 1.4 2025/01/03 08:09:58 mef Exp $

R_PKGNAME= openxlsx
R_PKGVER= 4.2.4
R_PKGVER= 4.2.7.1
CATEGORIES= textproc

MAINTAINER= [email protected]
Expand All @@ -11,6 +11,9 @@ LICENSE= mit
DEPENDS+= R-zip>=2.0.3:../../archivers/R-zip
DEPENDS+= R-stringi-[0-9]*:../../textproc/R-stringi

# Packages suggested but not available: 'formula.tools'

TEST_DEPENDS+= R-curl-[0-9]*:../../www/R-curl
TEST_DEPENDS+= R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+= R-testthat-[0-9]*:../../devel/R-testthat
TEST_DEPENDS+= R-roxygen2-[0-9]*:../../devel/R-roxygen2
Expand Down
8 changes: 4 additions & 4 deletions textproc/R-openxlsx/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 11:21:31 nia Exp $
$NetBSD: distinfo,v 1.5 2025/01/03 08:09:58 mef Exp $

BLAKE2s (R/openxlsx_4.2.4.tar.gz) = d5f59cae8fab2276b3f03c2962d38c812d3c13f4aa3707ca7ef11f4e0edc54ce
SHA512 (R/openxlsx_4.2.4.tar.gz) = 72832cc23c4dd920298078715d337e1b950ca6dd85a96f607fe11dc5a1b01092415cb118106fe441f63deb68b35d6f4c541f5ecefa2ee2e604cbe02a23673f67
Size (R/openxlsx_4.2.4.tar.gz) = 1322279 bytes
BLAKE2s (R/openxlsx_4.2.7.1.tar.gz) = 1e1b6ebbeaed5977dd17d670097b6d234426dbbe49f174aa69571c5b7edaaf9f
SHA512 (R/openxlsx_4.2.7.1.tar.gz) = b4a87b2f9f1b2ef26c873dfadf3e2ce5f291010233782ba4501101b0ac61c3d4bde2e4107ea9a0f71c1deeef6b055821fe1f8c83945ddc182da160bbd7fbfdfb
Size (R/openxlsx_4.2.7.1.tar.gz) = 1389194 bytes

0 comments on commit a91df5a

Please sign in to comment.