Skip to content

Commit

Permalink
misc/ruby-bundler: update to 2.0.2
Browse files Browse the repository at this point in the history
## 2.0.2 (2019-05-13)

Changes:

  - Fixes for Bundler integration with ruby-src ([#6941](rubygems/bundler#6941), [#6973](rubygems/bundler#6973), [#6977](rubygems/bundler#6977), [#6315](rubygems/bundler#6315), [#7061](rubygems/bundler#7061))
  - Use `__dir__` instead of `__FILE__` when generating a gem with `bundle gem` ([#6503](rubygems/bundler#6503))
  - Use `https` on externals links in the Bundler gemspec ([#6721](rubygems/bundler#6721))
  - Removed duplicate gem names from the suggested `did you mean` list for gem typos ([#6739](rubygems/bundler#6739))
  - Removed Ruby 1.x compatibility code ([#6764](rubygems/bundler#6764), [#6806](rubygems/bundler#6806))
  - Fixed an issue where `bundle remove` would crash with certain Gemfiles ([#6768](rubygems/bundler#6769))
  - Fixed indentation in the Bundler executable template ([#6773](rubygems/bundler#6773))
  - Fixed an issue where plugins could register for the same Bundler hook multiple times ([#6775](rubygems/bundler#6775))
  - Changed the "multiple sources" message in `bundle install` to be a warning instead of an error ([#6790](rubygems/bundler#6790))
  - Fixed a bug where path gems would break when using `only_update_to_newer_versions` ([#6774](rubygems/bundler#6774))
  - Fixed a bug where installing plugins with the `--delpoyment` setting would fail ([#6805](rubygems/bundler#6805))
  - Fixed an issue where `bundle update` couldn't update & install a gem when `no_install` was set (a `bundle package` config) ([#7078](rubygems/bundler#7078))
  - Fixed an issue where users could not run `bundle exec` on default gems ([#6963](rubygems/bundler#6963))
  - Updated vendor libraries to their latest version ([#7076](rubygems/bundler#7067), [#7068](rubygems/bundler#7068))
  - Fixed an issue where the `github` source was not using `https` by default that we mentioned in the 2.0 release ([#7182](rubygems/bundler#7182))
  - Fixed an issue where `rake release` was not outputting the message to users asking for a 2fa token ([#7199](rubygems/bundler#7199))

Documentation:

  - Fix incorrect documented `BUNDLE_PATH_RELATIVE_TO_CWD` env var ([#6751](rubygems/bundler#6751))
  - Update URLs in Bundler's documentation to use `https` ([#6935](rubygems/bundler#6935))

## 2.0.1 (2019-01-04)

Changes:

  - Relaxed RubyGems requirement to `>= 2.5.0` ([#6867](rubygems/bundler#6867))

## 2.0.0 (2019-01-03)

No new changes

## 2.0.0.pre.3 (2018-12-30)

Breaking Changes:

  - Bundler 2 now requires RubyGems 3.0.0 at minimum

Changes:

  - Ruby 2.6 compatibility fixes (@segiddins)
  - Import changes from Bundler 1.17.3 release

Note: To upgrade your Gemfile to Bundler 2 you will need to run `bundle update --bundler`

## 2.0.0.pre.2 (2018-11-27)

Breaking Changes:

  - `:github` source in the Gemfile now defaults to using HTTPS

Changes

  - Add compatibility for Bundler merge into ruby-src

Note: To upgrade your Gemfile to Bundler 2 you will need to run `bundle update --bundler`

## 2.0.0.pre.1 (2018-11-09)

Breaking Changes:

  - Dropped support for versions of Ruby < 2.3
  - Dropped support for version of RubyGems < 2.5
  - Moved error messages from STDOUT to STDERR

Note: To upgrade your Gemfile to Bundler 2 you will need to run `bundle update --bundler`
  • Loading branch information
taca committed Sep 18, 2019
1 parent 2bee83e commit e53ff40
Show file tree
Hide file tree
Showing 4 changed files with 21 additions and 17 deletions.
4 changes: 2 additions & 2 deletions misc/ruby-bundler/ALTERNATIVES
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
bin/bundle @PREFIX@/bin/bundle@RUBY_SUFFIX@
bin/bundler @PREFIX@/bin/bundler@RUBY_SUFFIX@
bin/bundle @PREFIX@/bin/bundle2-@RUBY_SUFFIX@
bin/bundler @PREFIX@/bin/bundler2-@RUBY_SUFFIX@
17 changes: 10 additions & 7 deletions misc/ruby-bundler/Makefile
Original file line number Diff line number Diff line change
@@ -1,19 +1,22 @@
# $NetBSD: Makefile,v 1.34 2019/04/15 06:11:32 wiz Exp $
# $NetBSD: Makefile,v 1.35 2019/09/18 14:30:43 taca Exp $

DISTNAME= bundler-1.17.3
DISTNAME= bundler-2.0.2
CATEGORIES= misc

MAINTAINER= [email protected]
HOMEPAGE= https://bundler.io/
COMMENT= Manage your application's dependencies
LICENSE= mit

#
# Currently, ruby26-base has the same version of bundler.
#
RUBY_VERSIONS_ACCEPTED= 24 25

RUBYGEM_OPTIONS+= --format-executable
COMMANDS= bundle bundler

post-install:
cd ${DESTDIR}${PREFIX}/bin && \
for f in ${COMMANDS}; do \
${TEST} -f $${f}2-${RUBY_SUFFIX} || \
${MV} $${f}${RUBY_SUFFIX} $${f}2-${RUBY_SUFFIX}; \
done

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"
7 changes: 4 additions & 3 deletions misc/ruby-bundler/PLIST
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
@comment $NetBSD: PLIST,v 1.25 2018/12/17 15:00:41 taca Exp $
bin/bundle${RUBY_SUFFIX}
bin/bundler${RUBY_SUFFIX}
@comment $NetBSD: PLIST,v 1.26 2019/09/18 14:30:43 taca Exp $
bin/bundle2-${RUBY_SUFFIX}
bin/bundler2-${RUBY_SUFFIX}
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/CHANGELOG.md
${GEM_LIBDIR}/LICENSE.md
Expand Down Expand Up @@ -161,6 +161,7 @@ ${GEM_LIBDIR}/lib/bundler/ui/shell.rb
${GEM_LIBDIR}/lib/bundler/ui/silent.rb
${GEM_LIBDIR}/lib/bundler/uri_credentials_filter.rb
${GEM_LIBDIR}/lib/bundler/vendor/fileutils/lib/fileutils.rb
${GEM_LIBDIR}/lib/bundler/vendor/fileutils/lib/fileutils/version.rb
${GEM_LIBDIR}/lib/bundler/vendor/molinillo/lib/molinillo.rb
${GEM_LIBDIR}/lib/bundler/vendor/molinillo/lib/molinillo/compatibility.rb
${GEM_LIBDIR}/lib/bundler/vendor/molinillo/lib/molinillo/delegates/resolution_state.rb
Expand Down
10 changes: 5 additions & 5 deletions misc/ruby-bundler/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.31 2019/01/20 14:15:00 taca Exp $
$NetBSD: distinfo,v 1.32 2019/09/18 14:30:43 taca Exp $

SHA1 (bundler-1.17.3.gem) = b5f0a9bffd4ff9b983b536704973fbe1cf49f015
RMD160 (bundler-1.17.3.gem) = dc0597bea59ff9f7f1feeec140898363e3747cac
SHA512 (bundler-1.17.3.gem) = 658de4228bc12fa5ca6ce335f76fff773f64da9f3d12f5097b4fd28d4c4f4d2a5bf12dce761b3d95432c5ea6a5aafae895df87c26660a4567db8b682aff48c02
Size (bundler-1.17.3.gem) = 364032 bytes
SHA1 (bundler-2.0.2.gem) = fe373c106bdb98fa9ef93e2a15e59c3fc081abbb
RMD160 (bundler-2.0.2.gem) = cb8ce17de3862658560094f6f4df0b2fff765faf
SHA512 (bundler-2.0.2.gem) = f41fe9e385fbf42859f3514b71abdaa1fd787f4ff4b1169b8ee40ea7778c114657c60ca3d6d6d72fbe972af0558f0cccd9c9f28cad7fc712ada27f037dce8a6a
Size (bundler-2.0.2.gem) = 366592 bytes

0 comments on commit e53ff40

Please sign in to comment.