Skip to content

Commit

Permalink
Update go116 to 1.16.5.
Browse files Browse the repository at this point in the history
go1.16.5 (released 2021-06-03) includes security fixes to the archive/zip, math
/big, net, and net/http/httputil packages, as well as bug fixes to the linker,
the go command, and the net/http package. See the Go 1.16.5 milestone on our
issue tracker for details.

The SetString and UnmarshalText methods of math/big.Rat
<https://pkg.go.dev/math/big#Rat> may cause a panic or an unrecoverable
fatal error if passed inputs with very large exponents.
This is issue <golang/go#44910> and
CVE-2021-33198.

Thanks to the OSS-Fuzz project for discovering this issue and to Emmanuel
Odeke for reporting it.

ReverseProxy in net/http/httputil <https://pkg.go.dev/net/http/httputil> could
be made to forward certain hop-by-hop headers, including Connection. In
case the target of the ReverseProxy was itself a reverse proxy, this would
let an attacker drop arbitrary headers, including those set by the
ReverseProxy.Director.
This is issue <golang/go#46313> and
CVE-2021-33197.

Thanks to Mattias Grenfeldt (https://grenfeldt.dev) and Asta Olofsson for
reporting this issue.

The LookupCNAME, LookupSRV, LookupMX, LookupNS, and LookupAddr functions in
net <https://pkg.go.dev/net>, and their respective methods on the Resolver
<https://pkg.go.dev/net#Resolver> type may return arbitrary values
retrieved from DNS which do not follow the established RFC 1035
<https://datatracker.ietf.org/doc/html/rfc1035>rules for domain names. If
these names are used without further sanitization, for instance unsafely
included in HTML, they may allow for injection of unexpected content. Note
that LookupTXT may still return arbitrary values that could require
sanitization before further use.
This is issue <golang/go#46241> and
CVE-2021-33195.

Thanks to Philipp Jeitner and Haya Shulman from Fraunhofer SIT for
reporting this issue.

The NewReader and OpenReader functions in archive/zip
<https://pkg.go.dev/archive/zip> can cause a panic or an unrecoverable
fatal error when reading an archive that claims to contain a large number
of files, regardless of its actual size.
This is issue <https://github.com/golang/go/issues/46242>and
CVE-2021-33196.

Thanks to the OSS-Fuzz project for discovering this issue and to Emmanuel
Odeke for reporting it.
  • Loading branch information
bsiegert committed Jun 5, 2021
1 parent d9f6c63 commit f32db56
Show file tree
Hide file tree
Showing 3 changed files with 9 additions and 8 deletions.
4 changes: 2 additions & 2 deletions lang/go/version.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: version.mk,v 1.119 2021/06/04 16:43:20 bsiegert Exp $
# $NetBSD: version.mk,v 1.120 2021/06/05 12:40:07 bsiegert Exp $

#
# If bsd.prefs.mk is included before go-package.mk in a package, then this
# file must be included directly in the package prior to bsd.prefs.mk.
#
.include "go-vars.mk"

GO116_VERSION= 1.16.4
GO116_VERSION= 1.16.5
GO115_VERSION= 1.15.13
GO110_VERSION= 1.10.8
GO19_VERSION= 1.9.7
Expand Down
3 changes: 2 additions & 1 deletion lang/go116/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.5 2021/05/07 18:29:14 bsiegert Exp $
@comment $NetBSD: PLIST,v 1.6 2021/06/05 12:40:07 bsiegert Exp $
bin/go${GOVERSSUFFIX}
bin/gofmt${GOVERSSUFFIX}
go116/AUTHORS
Expand Down Expand Up @@ -2271,6 +2271,7 @@ go116/src/cmd/go/testdata/script/mod_tidy_old.txt
go116/src/cmd/go/testdata/script/mod_tidy_quote.txt
go116/src/cmd/go/testdata/script/mod_tidy_replace.txt
go116/src/cmd/go/testdata/script/mod_tidy_sum.txt
go116/src/cmd/go/testdata/script/mod_tidy_too_new.txt
go116/src/cmd/go/testdata/script/mod_upgrade_patch.txt
go116/src/cmd/go/testdata/script/mod_vcs_missing.txt
go116/src/cmd/go/testdata/script/mod_vendor.txt
Expand Down
10 changes: 5 additions & 5 deletions lang/go116/distinfo
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.7 2021/05/07 18:29:14 bsiegert Exp $
$NetBSD: distinfo,v 1.8 2021/06/05 12:40:07 bsiegert Exp $

SHA1 (go1.16.4.src.tar.gz) = b1d5f9a63f0cda6580f6a31419af78dc0723536a
RMD160 (go1.16.4.src.tar.gz) = ae3a07321fea0f4ee8442d02f285e68b9f361e5c
SHA512 (go1.16.4.src.tar.gz) = e1b64610e22e657d9c65094e679cec50f59ff338c0ef102e54debcced1bc032390122456451fffb2d26d45c6db2f55bb9ef7f56ce479f6f1c2c2e6cc49442d86
Size (go1.16.4.src.tar.gz) = 20917203 bytes
SHA1 (go1.16.5.src.tar.gz) = b3d00525ea5af180149fafca8da730c6f988f29f
RMD160 (go1.16.5.src.tar.gz) = dfbe9538c56f60215d699b611aac1db182751e5c
SHA512 (go1.16.5.src.tar.gz) = ba90ce1f3faa39519eb5437009c4b710b493e42764a14b0821292a8a17b714fe5985ef20e6e3c340f71cb521ff63d45a23570d38fd752526a1262448c641d544
Size (go1.16.5.src.tar.gz) = 20921372 bytes
SHA1 (patch-misc_ios_clangwrap.sh) = 0a06403609cb7bce2e6f65444fd322f486761afe
SHA1 (patch-src_cmd_dist_util.go) = 24e6f1b6ded842a8ce322a40e8766f7d344bc47e
SHA1 (patch-src_crypto_x509_root__bsd.go) = 27636e0d8c121ccec6c46a3a82cd0e0469473a6e
Expand Down

0 comments on commit f32db56

Please sign in to comment.