Skip to content

Commit

Permalink
Update to 2.7.1. Packaging-tested only, but 2.6.1 didn't package
Browse files Browse the repository at this point in the history
any longer. Change LICENSE to modified-bsd per upstream.

Changes:

2.7.1 (2013-09-07)

Improved OFX parsing. (#369)
Fixed rounding error when changing split amounts. (#367)
Fixed Qt import window glitch. (#371)
Improved currency rates fetching reliability.
Fixed occasional hard crashes on accounts drag & drop. [Mac] (#354)

2.7.0 (2013-05-26)

Added support for custom currencies. (#33)
Fixed amount parsing bug with currencies with many decimals.
Fixed cache folder bug causing cached files to be misplaced. [Linux, Windows]
Dropped 32-bit support on Mac OS X.

2.6.3 (2013-03-23)

Fixed a selection glitch on New Account. (#358)
Fixed a schedule spawning bug. (#362)
Removed the fairware dialog (More Info).
Added a 64-bit build for Windows.
Added Spanish localization by Enrique G. Paredes.

2.6.2 (2013-01-06)

Fixed a bug causing transaction imbalance after import. (#351)
Fixed glitch in bar graph drawing. (#352)
Fixed a bug in QIF exports. (#353)
Fixed a crash on print. [Linux, Windows] (#349)
  • Loading branch information
wiz committed Jan 25, 2014
1 parent 7ae401f commit 0793712
Show file tree
Hide file tree
Showing 3 changed files with 955 additions and 317 deletions.
37 changes: 22 additions & 15 deletions finance/moneyguru/Makefile
Original file line number Diff line number Diff line change
@@ -1,43 +1,50 @@
# $NetBSD: Makefile,v 1.3 2014/01/25 10:30:07 wiz Exp $
# $NetBSD: Makefile,v 1.4 2014/01/25 11:11:20 wiz Exp $
#
# any of ~* is fine, they are the same and just there for Ubuntu
# so moneyguru's built for all releases
DISTNAME= moneyguru_2.6.1~quantal
PKGNAME= ${DISTNAME:S/_/-/:S/~quantal//}
DISTNAME= 2.7.1
PKGNAME= moneyguru-${DISTNAME}
CATEGORIES= finance
MASTER_SITES= https://launchpad.net/~hsoft/+archive/ppa/+files/
MASTER_SITES= https://github.com/hsoft/moneyguru/archive/

MAINTAINER= [email protected]
HOMEPAGE= http://www.hardcoded.net/moneyguru/
COMMENT= Personal finance management application
LICENSE= fairware-license
LICENSE= modified-bsd

DEPENDS+= ${PYPKGPREFIX}-polib-[0-9]*:../../devel/py-polib
DEPENDS+= ${PYPKGPREFIX}-qt4-[0-9]*:../../x11/py-qt4
DEPENDS+= ${PYPKGPREFIX}-sphinx-[0-9]*:../../textproc/py-sphinx
DEPENDS+= ${PYPKGPREFIX}-sqlite3-[0-9]*:../../databases/py-sqlite3
DEPENDS+= ${PYPKGPREFIX}-cElementTree-[0-9]*:../../textproc/py-cElementTree

FETCH_USING= curl
DIST_SUBDIR= moneyguru
EXTRACT_USING= bsdtar

WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
USE_LANGUAGES= c
USE_TOOLS= pax

PY_PATCHPLIST= yes
REPLACE_PYTHON= src/run.py
PYTHON_VERSIONS_INCOMPATIBLE= 26 27 # 3.x only
PY_PATCHPLIST= yes
REPLACE_PYTHON+= cocoa/waf
REPLACE_PYTHON+= cocoa/wscript
REPLACE_PYTHON+= psmtabbarcontrol/waf
REPLACE_PYTHON+= psmtabbarcontrol/wscript
REPLACE_PYTHON+= run_template_cocoa.py
REPLACE_PYTHON+= run_template_qt.py

INSTALLATION_DIRS= bin share/applications share/moneyguru

# remove pre-compiled file for wrong architecture
post-extract:
${RM} ${WRKSRC}/src/core/model/_amount.cpython-32mu.so
do-configure:
cd ${WRKSRC} && ${PYTHONBIN} configure.py

do-build:
cd ${WRKSRC} && ${PYTHONBIN} build_modules.py
${CHMOD} +x ${WRKSRC}/src/run.py
cd ${WRKSRC} && ${PYTHONBIN} build.py
${CHMOD} +x ${WRKSRC}/run.py

do-install:
cd ${WRKSRC}/src && pax -pe -rw * ${DESTDIR}${PREFIX}/share/moneyguru
cd ${WRKSRC} && pax -pe -rw ambuttonbar build cocoa cocoalib core data help hscommon images locale plugin_examples psmtabbarcontrol qt qtlib run.py ${DESTDIR}${PREFIX}/share/moneyguru
${INSTALL_DATA} ${WRKSRC}/debian/moneyguru.desktop ${DESTDIR}${PREFIX}/share/applications
${LN} -s ${DESTDIR}${PREFIX}/share/moneyguru/run.py ${DESTDIR}${PREFIX}/bin/moneyguru

Expand Down
Loading

0 comments on commit 0793712

Please sign in to comment.