Skip to content

Commit

Permalink
Updated devel/pkgconf 1.0.1 to 1.3.5
Browse files Browse the repository at this point in the history
------------------------------------
Changes from 1.3.4 to 1.3.5:
----------------------------
* Bug fixes:
  - fix --variable output for compatibility some broken configure scripts when they
    request the same variable from multiple packages

Changes from 1.3.3 to 1.3.4:
----------------------------
* Bug fixes:
  - fix a quoting issue exposed by the Go testsuite

Changes from 1.3.2 to 1.3.3:
----------------------------
* Bug fixes:
  - back out disabling the dependency resolver for single-package queries, it caused
    too many regressions.

* Enhancements:
  - allow explicitly disabling the dependency resolver via new environment variable,
    PKG_CONFIG_MINIMUM_TRAVERSE_DEPTH=1.  while pkgconf could already do this using
    --minimum-traverse-depth=1, other pkg-config implementations do not have this
    option, so adding an environment variable allows to make better use of this
    feature (other implementations won't error due to unknown option this way)

Changes from 1.3.1 to 1.3.2:
----------------------------
* Bug fixes:
  - rewrite handling of --modversion, --print-variables and --variable to not require
    the dependency resolver
  - ensure we disable the dependency resolver in all cases where it is a single-package
    query (1.3.1 did not go far enough)

Changes from 1.3.0 to 1.3.1:
----------------------------
* Features:
  - implement --short-errors

* Bug fixes:
  - only consider a single package at a time with --print-requires, --print-requires-private,
    --print-provides, --modversion, --print-variable and --print-variables

* Enhancements:
  - synchronized latest freedesktop.org changes to pkg.m4
  - improve error reporting with legacy --atleast-version and similar flags.

Changes from 1.2.0 to 1.3.0:
----------------------------
* Features:
  - pkgconf --debug now provides a facility for tracing most relevant libpkgconf operations
  - libpkgconf: add warn and trace handlers for warnings
  - replace realpath() with faster, lighter weight path normalization function (#112)
  - pkgconf CLI now emulates pkg-config quoting rules precisely, while allowing direct access
    to the actual fragments via libpkgconf

* Bug fixes:
  - pkg: properly separate static and virtual packages so they are not inappropriately
    optimized out of the dependency graph (#108)
  - argvsplit: do not consider ' and " to have similar rules to escape sequences (#111)
  - pkg: strip trailing whitespace when parsing .pc files

* Enhancements:
  - argvsplit basically rewritten from scratch
  - many code fixes spotted by coverity
  - add PKG_CONFIG_DONT_RELOCATE_PATHS and --dont-relocate-paths environment variables to
    disable path relocation feature if needed
  - remove extra whitespace that was present for compatibility with older pkg-config releases (#113)

Changes from 1.1.0 to 1.2.0:
----------------------------
* Features:
  - new --path option lists the .pc files which provided the requested dependencies
  - new path relocation API: pkgconf_path_relocate(), which wraps functions such as
    realpath() and cygwin_conv_path().
  - new --with-path option adds a path to the search list
  - new --define-prefix and --dont-define-prefix features enable automatic prefix
    detection for relocatable SDKs.  this is mostly useful on windows.

* Bug fixes:
  - fragments: fix even more edge cases involving token concatenation
  - path lists: don't attempt to collect path inodes if the filter is disabled
  - path lists: explicitly avoid uninitialised data for the path inode cache
  - client: properly handle --keep-system-cflags and --keep-system-libs

* Enhancements:
  - windows: build libpkgconf as a DLL
  - fragments: only munge fragments if sysroot_dir is actually set
  - overall API: resolver flags have been moved to being a client-object setting
    instead of used for every function invocation

Changes from 1.0.1 to 1.1.0:
----------------------------
* Features:
  - new Provides system allows alternate .pc files to provide a dependency
  - stable library API (with documentation): http://pkgconf.readthedocs.io/

* Enhancements:
  - make it possible to programmatically declare dependencies instead of just using the parser
  - testsuite migrated to run under kyua
  - provide a libpkgconf.pc file for consumers to use
  - pkgconf client: new --pure flag to enable dependency graph optimization in --static mode
  - significant .pc parser speedups using bsearch(3).
  - handle -idirafter in the same way as -isystem CFLAGS
  - learn toolchain "system" paths from GCC environment variables, if present
  - filter duplicate PKG_CONFIG_PATH (and other) entries by inode

* Bug fixes:
  - fragments: fix another edge case involving empty tokens being concatenated onto previous tokens (#99)
  - libpkgconf: remove dependencies on config.h in public headers
  • Loading branch information
mef committed May 5, 2017
1 parent dbb673e commit 0c592af
Show file tree
Hide file tree
Showing 3 changed files with 14 additions and 14 deletions.
7 changes: 3 additions & 4 deletions devel/pkgconf/Makefile
Original file line number Diff line number Diff line change
@@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.9 2016/08/31 06:11:25 wiz Exp $
# $NetBSD: Makefile,v 1.10 2017/05/05 01:55:56 mef Exp $

DISTNAME= pkgconf-1.0.1
DISTNAME= pkgconf-1.3.5
CATEGORIES= devel
MASTER_SITES= http://rabbit.dereferenced.org/~nenolod/distfiles/
#EXTRACT_SUFX= .tar.bz2

MAINTAINER= [email protected]
HOMEPAGE= https://github.com/pkgconf/pkgconf
Expand All @@ -30,6 +29,6 @@ PKGCONFIG_PATHS+= ${X11BASE}/lib/pkgconfig
CONFIGURE_ARGS+= --with-pkg-config-dir='${PKGCONFIG_PATHS:ts::Q}'

post-install:
${LN} -s ${PREFIX}/bin/pkgconf ${DESTDIR}${PREFIX}/bin/pkg-config
${LN} -s ${DESTDIR}${PREFIX}/bin/pkgconf ${DESTDIR}${PREFIX}/bin/pkg-config

.include "../../mk/bsd.pkg.mk"
11 changes: 6 additions & 5 deletions devel/pkgconf/PLIST
Original file line number Diff line number Diff line change
@@ -1,11 +1,12 @@
@comment $NetBSD: PLIST,v 1.2 2015/12/08 13:15:28 wiz Exp $
@comment $NetBSD: PLIST,v 1.3 2017/05/05 01:55:56 mef Exp $
bin/pkg-config
bin/pkgconf
include/pkgconf/bsdstubs.h
include/pkgconf/iter.h
include/pkgconf/libpkgconf.h
include/pkgconf/stdinc.h
include/pkgconf/libpkgconf/bsdstubs.h
include/pkgconf/libpkgconf/iter.h
include/pkgconf/libpkgconf/libpkgconf.h
include/pkgconf/libpkgconf/stdinc.h
lib/libpkgconf.la
lib/pkgconfig/libpkgconf.pc
man/man1/pkgconf.1
share/aclocal/pkg.m4
share/doc/pkgconf/AUTHORS
Expand Down
10 changes: 5 additions & 5 deletions devel/pkgconf/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.6 2016/08/31 06:11:25 wiz Exp $
$NetBSD: distinfo,v 1.7 2017/05/05 01:55:56 mef Exp $

SHA1 (pkgconf-1.0.1.tar.gz) = 784b131102b4a0a344e9532656c1f5c4789c6ea8
RMD160 (pkgconf-1.0.1.tar.gz) = a7f0e3479a52efa111d33351347612b1ab3292d3
SHA512 (pkgconf-1.0.1.tar.gz) = b379ed366327eb4de3a7ed732be58a3757fdcd231637f0fbc2f9b762fda08173244d05fd853d683cfa6bdad90f1d8ee663b3eae9aee024456ef46e8a021e7122
Size (pkgconf-1.0.1.tar.gz) = 362653 bytes
SHA1 (pkgconf-1.3.5.tar.gz) = 3b246f2d7e110d19eef407378953f6537c6bf33f
RMD160 (pkgconf-1.3.5.tar.gz) = 1d07e39bc0cfd91e695148cd231c035905b368d6
SHA512 (pkgconf-1.3.5.tar.gz) = 8503ce86512dd4f53156a604ec993510d1f58f29e7265b04f48222a32cd3b9482fd94d3f66ff6ab0410de0e50223eaa1dc41c4f662414984548af18c1ede9f64
Size (pkgconf-1.3.5.tar.gz) = 397591 bytes

0 comments on commit 0c592af

Please sign in to comment.