Skip to content

Commit

Permalink
Updated to py-irclib 12.0
Browse files Browse the repository at this point in the history
12.0

    Remove dependency on jaraco.util. Instead depend on surgical packages.
    Deprecated irc.logging in favor of jaraco.logging.
    Dropped support for Python 3.2.

11.1.1

    Issue #55: Correct import error on Python 2.7.

11.1

    Decoding errors now log a warning giving a reference to the Decoding Input
section of the readme.

11.0

    Renamed irc.client.Manifold to irc.client.Reactor. Reactor better reflects
the implementation as a reactor pattern <. This name makes it’s function much
more clear and inline with standard terminology.
    Removed deprecated manifold and irclibobj properties from Connection. Use
reactor instead.
    Removed deprecated ircobj from SimpleIRCClient. Use reactor instead.

10.1

    Added ServerConnection.as_nick, a context manager to set a nick for the
duration of the context.

10.0

    Dropped support for Python 2.6.
    Dropped irc.client.LineBuffer and irc.client.DecodingBuffer (available in
irc.client.buffer).
    Renamed irc.client.IRC to irc.client.Manifold to provide a clearer name for
that object. Clients supporting 8.6 and later can use the Manifold name. Latest
clients must use the Manifold name.
    Renamed irc.client.Connection.irclibobj property to manifold. The property
is still exposed as irclibobj for compatibility but will be removed in a future
version.
    Removed unused irc.client.mask_matches function.
    Removed unused irc.client.nick_characters.
    Added extra numerics for ‘whoisaccount’ and ‘cannotknock’.

9.0

    Issue #46: The whois command now accepts a single string or iterable for the
target.
    NickMask now returns None when user, host, or userhost are not present.
Previously, an IndexError was raised. See Pull Request #26 for details.
  • Loading branch information
imil committed Mar 2, 2015

Verified

This commit was created on GitHub.com and signed with GitHub’s verified signature. The key has expired.
1 parent 6629d96 commit 1d67768
Showing 3 changed files with 11 additions and 11 deletions.
6 changes: 3 additions & 3 deletions net/py-irclib/Makefile
Original file line number Diff line number Diff line change
@@ -1,15 +1,15 @@
# $NetBSD: Makefile,v 1.9 2014/05/09 21:37:03 imil Exp $
# $NetBSD: Makefile,v 1.10 2015/03/02 09:44:05 imil Exp $
#

IRCVERS= 8.9
IRCVERS= 12.1
DISTNAME= irc-${IRCVERS}
PKGNAME= ${PYPKGPREFIX}-irclib-${IRCVERS}
CATEGORIES= net python
MASTER_SITES= http://pypi.python.org/packages/source/i/irc/
EXTRACT_SUFX= .zip

MAINTAINER= [email protected]
HOMEPAGE= https://bitbucket.org/jaraco/irc
HOMEPAGE= http://python-irclib.sourceforge.net/
COMMENT= Internet Relay Chat (IRC) protocol client library
LICENSE= gnu-gpl-v2

8 changes: 4 additions & 4 deletions net/py-irclib/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2014/04/20 12:44:01 imil Exp $
@comment $NetBSD: PLIST,v 1.5 2015/03/02 09:44:05 imil Exp $
${PYSITELIB}/${EGG_FILE}/PKG-INFO
${PYSITELIB}/${EGG_FILE}/SOURCES.txt
${PYSITELIB}/${EGG_FILE}/dependency_links.txt
@@ -15,6 +15,8 @@ ${PYSITELIB}/irc/client.pyc
${PYSITELIB}/irc/client.pyo
${PYSITELIB}/irc/connection.pyc
${PYSITELIB}/irc/connection.pyo
${PYSITELIB}/irc/ctcp.pyc
${PYSITELIB}/irc/ctcp.pyo
${PYSITELIB}/irc/dict.pyc
${PYSITELIB}/irc/dict.pyo
${PYSITELIB}/irc/events.pyc
@@ -35,12 +37,11 @@ ${PYSITELIB}/irc/server.pyc
${PYSITELIB}/irc/server.pyo
${PYSITELIB}/irc/strings.pyc
${PYSITELIB}/irc/strings.pyo
${PYSITELIB}/irc/util.pyc
${PYSITELIB}/irc/util.pyo
${PYSITELIB}/irc/bot.py
${PYSITELIB}/irc/buffer.py
${PYSITELIB}/irc/client.py
${PYSITELIB}/irc/connection.py
${PYSITELIB}/irc/ctcp.py
${PYSITELIB}/irc/dict.py
${PYSITELIB}/irc/events.py
${PYSITELIB}/irc/features.py
@@ -63,4 +64,3 @@ ${PYSITELIB}/irc/tests/test_schedule.pyo
${PYSITELIB}/irc/tests/test_bot.py
${PYSITELIB}/irc/tests/test_client.py
${PYSITELIB}/irc/tests/test_schedule.py
${PYSITELIB}/irc/util.py
8 changes: 4 additions & 4 deletions net/py-irclib/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2014/05/09 21:37:03 imil Exp $
$NetBSD: distinfo,v 1.5 2015/03/02 09:44:05 imil Exp $

SHA1 (irc-8.9.zip) = cb640d08f5353b9544f927192742580584d7e792
RMD160 (irc-8.9.zip) = d5cd68409194b75fcff5a391c63b7bb08a8b1dc7
Size (irc-8.9.zip) = 119554 bytes
SHA1 (irc-12.1.zip) = bce61050b786dca3d02ebe2b01e4d60943da55a8
RMD160 (irc-12.1.zip) = dfe8e2d1e80c7fac65845a32e1946d083e980b08
Size (irc-12.1.zip) = 109721 bytes

0 comments on commit 1d67768

Please sign in to comment.