Skip to content

Commit

Permalink
Update mxml to version 2.9.
Browse files Browse the repository at this point in the history
Changelog:

CHANGES IN Mini-XML 2.9

	- mxmlLoad* did not correctly load value nodes with MXML_NO_CALLBACK
	  or MXML_TEXT_CALLBACK (Bug #502)


CHANGES IN Mini-XML 2.8

	- Now call docsetutil using xcrun on OS X (Bug #458)
	- mxmldoc did not escape special HTML characters inside @code foo@
	  comments.
	- Fixed a memory leak in mxmlElementDeleteAttr (Bug #452)
	- Added MXML_MAJOR/MINOR_VERSION definitions to mxml.h (Bug $461)
	- Fixed a bug reading UTF-16 characters from a file (Bug #454)
	- Fixed a memory leak when loading invalid XML (Bug #496)
	- Fixed an XML fragment loading problem (Bug #494)


CHANGES IN Mini-XML 2.7

	- Added 64-bit configurations to the VC++ project files (STR #129)
	- Fixed conformance of mxmldoc's HTML and CSS output.
	- Added data accessor ("get") functions and made the mxml_node_t and
	  mxml_index_t structures private but still available in the Mini-XML
	  header to preserve source compatibility (STR #118)
	- Updated the source headers to reference the Mini-XML license and its
	  exceptions to the LGPL2 (STR #108)
	- Fixed a memory leak when loading a badly-formed XML file (STR #121)
      	- Added a new mxmlFindPath() function to find the value node of a
	  named element (STR #110)
	- Building a static version of the library did not work on Windows
	  (STR #112)
	- The shared library did not include a destructor for the thread-
	  specific data key on UNIX-based operating systems (STR #103)
	- mxmlLoad* did not error out on XML with multiple root nodes (STR #101)
	- Fixed an issue with the _mxml_vstrdupf function (STR #107)
	- mxmlSave* no longer write all siblings of the passed node, just that
	  node and its children (STR #109)
  • Loading branch information
nros committed Mar 8, 2016
1 parent 6ac546b commit 4554d76
Show file tree
Hide file tree
Showing 4 changed files with 48 additions and 37 deletions.
13 changes: 8 additions & 5 deletions textproc/mxml/Makefile
Original file line number Diff line number Diff line change
@@ -1,20 +1,23 @@
# $NetBSD: Makefile,v 1.4 2012/10/25 06:56:08 asau Exp $
#
# $NetBSD: Makefile,v 1.5 2016/03/08 13:50:46 nros Exp $

DISTNAME= mxml-2.6
DISTNAME= mxml-2.9
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.easysw.com/pub/mxml/2.6/
MASTER_SITES= http://www.msweet.org/files/project3/

MAINTAINER= [email protected]
HOMEPAGE= http://www.minixml.org/
COMMENT= Small XML parsing library
LICENSE= gnu-lgpl-v2

GNU_CONFIGURE= yes
USE_LANGUAGES= c c++
USE_LIBTOOL= yes

PKGCONFIG_OVERRIDE+= mxml.pc.in
PKGCONFIG_OVERRIDE+= mxml.pc
PKGCONFIG_OVERRIDE_STAGE=post-configure

INSTALL_MAKE_FLAGS+= BUILDROOT=${DESTDIR}

.include "options.mk"

.include "../../mk/bsd.pkg.mk"
3 changes: 2 additions & 1 deletion textproc/mxml/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,11 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.2 2009/03/20 19:25:31 joerg Exp $
# $NetBSD: buildlink3.mk,v 1.3 2016/03/08 13:50:46 nros Exp $

BUILDLINK_TREE+= mxml

.if !defined(MXML_BUILDLINK3_MK)
MXML_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.mxml+= mxml>=2.3
BUILDLINK_ABI_DEPENDS.mxml+= mxml>=2.9
BUILDLINK_PKGSRCDIR.mxml?= ../../textproc/mxml
.endif # MXML_BUILDLINK3_MK

Expand Down
14 changes: 7 additions & 7 deletions textproc/mxml/distinfo
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.4 2015/11/04 01:59:41 agc Exp $
$NetBSD: distinfo,v 1.5 2016/03/08 13:50:46 nros Exp $

SHA1 (mxml-2.6.tar.gz) = df180bd2e3890c97fa8a05dd131f9285468cffe1
RMD160 (mxml-2.6.tar.gz) = 6b1d1503880841431014b54d86430ed78201b6f2
SHA512 (mxml-2.6.tar.gz) = ca66a18a44ad8b6a204ed2130107c73c746fafd7925fd229fed9ba56f4c1654c5d289c08954eb102941d1b2a0c164c1174e169d472b7867c0cb3d0822616219b
Size (mxml-2.6.tar.gz) = 254455 bytes
SHA1 (patch-aa) = 9997c738df144c0825942c113d40988078cdea47
SHA1 (patch-ab) = 5518b4ac561a2ca26da5666caead9745729475b3
SHA1 (mxml-2.9.tar.gz) = a3d9c1f8cf8c7f85d76bb6954af1888d55f926f0
RMD160 (mxml-2.9.tar.gz) = 41cda23eb32e7883109be3cdeaa968ab787e32f1
SHA512 (mxml-2.9.tar.gz) = 819c506ea43198de07a90d7473f29c9edc7f638638b5a1b215d88ac635b4f4f37441d8a760ce356f7d4bfb14a4f504c304d0e33345f69ecd145db50350e50ad7
Size (mxml-2.9.tar.gz) = 264379 bytes
SHA1 (patch-aa) = c728536a8813e455579a8aa816adcdb575063079
SHA1 (patch-configure) = 250eb883c8c6c44e223e31f55e669e74d3269888
55 changes: 31 additions & 24 deletions textproc/mxml/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
$NetBSD: patch-aa,v 1.3 2009/11/25 23:31:58 joerg Exp $

--- Makefile.in.orig 2008-12-06 05:20:38.000000000 +0100
$NetBSD: patch-aa,v 1.4 2016/03/08 13:50:46 nros Exp $
* use BSD_INSTALL*
* use libtool for everything
--- Makefile.in.orig 2014-10-19 17:21:48.000000000 +0000
+++ Makefile.in
@@ -30,7 +30,7 @@ DSO = @DSO@
@@ -28,7 +28,7 @@ DSO = @DSO@
DSOFLAGS = @DSOFLAGS@
LDFLAGS = $(OPTIM) $(ARCHFLAGS) @LDFLAGS@
INSTALL = @INSTALL@
Expand All @@ -11,7 +12,7 @@ $NetBSD: patch-aa,v 1.3 2009/11/25 23:31:58 joerg Exp $
LIBS = @LIBS@ @PTHREAD_LIBS@
LN = @LN@ -s
MKDIR = @MKDIR@
@@ -59,10 +59,10 @@ BUILDROOT = $(DSTROOT)
@@ -57,10 +57,10 @@ BUILDROOT = $(DSTROOT)
# Install commands...
#

Expand All @@ -24,84 +25,90 @@ $NetBSD: patch-aa,v 1.3 2009/11/25 23:31:58 joerg Exp $
INSTALL_MAN = $(INSTALL) -m 644
INSTALL_SCRIPT = $(INSTALL) -m 755

@@ -133,7 +133,7 @@ clang:
@@ -139,7 +139,7 @@ clang-changes:
# Install everything...
#

-install: $(TARGETS) install-$(LIBMXML) install-libmxml.a
+install: $(TARGETS) install-$(LIBMXML)
+install: $(TARGETS) install-$(LIBMXML)
echo Installing mxmldoc in $(BUILDROOT)$(bindir)...
$(INSTALL_DIR) $(BUILDROOT)$(bindir)
$(INSTALL_BIN) mxmldoc $(BUILDROOT)$(bindir)
$(INSTALL_DIR) $(BUILDROOT)$(docdir)
@@ -149,10 +149,9 @@ install: $(TARGETS) install-$(LIBMXML) i
$(INSTALL_BIN) mxmldoc $(BUILDROOT)$(bindir)
@@ -160,11 +160,10 @@ install: $(TARGETS) install-$(LIBMXML) i
$(INSTALL_DIR) $(BUILDROOT)$(mandir)/man3
$(INSTALL_MAN) doc/mxml.man $(BUILDROOT)$(mandir)/man3/mxml.3

-install-libmxml.a:
- echo Installing libmxml.a to $(BUILDROOT)$(libdir)...
+install-libmxml.la:
+ echo Installing libmxml.la to $(BUILDROOT)$(libdir)...
$(INSTALL_DIR) $(BUILDROOT)$(libdir)
- $(INSTALL_LIB) libmxml.a $(BUILDROOT)$(libdir)
- $(RANLIB) $(BUILDROOT)$(libdir)/libmxml.a
+ $(INSTALL_LIB) libmxml.la $(BUILDROOT)$(libdir)

install-libmxml.so.1.4:
$(INSTALL_DIR) $(BUILDROOT)$(libdir)
@@ -242,10 +241,13 @@ config.h: configure config.h.in
install-libmxml.so.1.5:
echo Installing libmxml.so to $(BUILDROOT)$(libdir)...
@@ -281,11 +280,14 @@ sloc:
# libmxml.a
#

-libmxml.a: $(LIBOBJS)
+libmxml.la: $(LIBOBJS:.o=.lo)
echo Creating $@...
- $(RM) $@
- $(AR) $(ARFLAGS) $@ $(LIBOBJS)
- $(RANLIB) $@
+libmxml.la: $(LIBOBJS:.o=.lo)
+ ${LIBTOOL} --mode=link ${CC} ${LDFLAGS} ${LIBOBJS:.o=.lo} \
+ -o libmxml.la -rpath ${PREFIX}/lib -version-info 1:4
+ -o libmxml.la -rpath ${PREFIX}/lib -version-info 1:5
+
+.SUFFIXES: .lo
+.c.lo:
+ ${LIBTOOL} --mode=compile ${CC} ${CFLAGS} -c ${.IMPSRC} -o ${.TARGET}

$(LIBOBJS): mxml.h
mxml-entity.o mxml-file.o mxml-private.o: mxml-private.h
@@ -291,7 +293,7 @@ libmxml.1.dylib: $(LIBOBJS)
#
@@ -335,7 +337,7 @@ libmxml.1.dylib: $(LIBOBJS)

mxmldoc: $(LIBMXML) mxmldoc.o
echo Linking $@...
- $(CC) -L. $(LDFLAGS) -o $@ mxmldoc.o -lmxml $(LIBS)
+ ${LIBTOOL} --mode=link $(CC) -L. $(LDFLAGS) -o $@ mxmldoc.o libmxml.la $(LIBS)

mxmldoc-static: libmxml.a mxmldoc.o
$(CC) $(LDFLAGS) -o $@ mxmldoc.o libmxml.a $(LIBS)
@@ -303,8 +305,8 @@ mxmldoc.o: mxml.h
echo Linking $@...
@@ -348,9 +350,9 @@ mxmldoc.o: mxml.h
# testmxml
#

-testmxml: libmxml.a testmxml.o
- $(CC) $(LDFLAGS) -o $@ testmxml.o libmxml.a $(LIBS)
+testmxml: libmxml.la testmxml.o
echo Linking $@...
- $(CC) $(LDFLAGS) -o $@ testmxml.o libmxml.a $(LIBS)
+ ${LIBTOOL} --mode=link $(CC) $(LDFLAGS) -o $@ testmxml.o libmxml.la $(LIBS)
@echo Testing library...
./testmxml test.xml >temp1.xml 2>temp1s.xml
./testmxml temp1.xml >temp2.xml 2>temp2s.xml
@@ -334,9 +336,9 @@ testmxml.o: mxml.h
./testmxml test.xml temp1s.xml >temp1.xml
./testmxml temp1.xml temp2s.xml >temp2.xml
@@ -384,10 +386,10 @@ testmxml.o: mxml.h
# mxml.xml
#

-mxml.xml: mxmldoc-static mxml.h $(PUBLIBOBJS:.o=.c)
+mxml.xml: mxmldoc mxml.h $(PUBLIBOBJS:.o=.c)
echo Generating API documentation...
$(RM) mxml.xml
- ./mxmldoc-static --header doc/reference.heading mxml.xml mxml.h $(PUBLIBOBJS:.o=.c) >doc/reference.html
+ ./mxmldoc --header doc/reference.heading mxml.xml mxml.h $(PUBLIBOBJS:.o=.c) >doc/reference.html
if test "x`uname`" = xDarwin; then \
./mxmldoc-static --docset org.minixml.docset \
--docversion @VERSION@ --feedname minixml.org \
@@ -361,9 +363,9 @@ valgrind: mxmldoc-static
@@ -414,10 +416,10 @@ valgrind: mxmldoc-static
# doc/mxml.man
#

-doc/mxml.man: mxmldoc-static mxml.xml
+doc/mxml.man: mxmldoc mxml.xml
echo "Generating mxml(3) man page..."
$(RM) doc/mxml.man
- ./mxmldoc-static --man mxml --title "Mini-XML API" \
+ ./mxmldoc --man mxml --title "Mini-XML API" \
Expand Down

0 comments on commit 4554d76

Please sign in to comment.