Skip to content

Commit

Permalink
Update to 0.9.34:
Browse files Browse the repository at this point in the history
Overview of changes leading to 0.9.34
Saturday, August 2, 2014
=====================================

- hb_feature_from_string() now accepts CSS font-feature-settings format.
- As a result, hb-shape / hb-view --features also accept CSS-style strings.
  Eg, "'liga' off" is accepted now.
- Add old-spec Myanmar shaper:
  https://bugs.freedesktop.org/show_bug.cgi?id=81775
- Don't apply 'calt' in Hangul shaper.
- Fix mark advance zeroing for Hebrew shaper:
  https://bugs.freedesktop.org/show_bug.cgi?id=76767
- Implement Windows-1256 custom Arabic shaping.  Only built on Windows,
  and requires help from get_glyph().  Used by Firefox.
  https://bugzilla.mozilla.org/show_bug.cgi?id=1045139
- Disable 'liga' in vertical text.
- Build fixes.
- API changes:

  * Make HB_BUFFER_FLAG_BOT/EOT easier to use.

    Previously, we expected users to provide BOT/EOT flags when the
    text *segment* was at paragraph boundaries.  This meant that for
    clients that provide full paragraph to HarfBuzz (eg. Pango), they
    had code like this:

      hb_buffer_set_flags (hb_buffer,
                           (item_offset == 0 ? HB_BUFFER_FLAG_BOT : 0) |
                           (item_offset + item_length == paragraph_length ?
                            HB_BUFFER_FLAG_EOT : 0));

      hb_buffer_add_utf8 (hb_buffer,
                          paragraph_text, paragraph_length,
                          item_offset, item_length);

    After this change such clients can simply say:

      hb_buffer_set_flags (hb_buffer,
                           HB_BUFFER_FLAG_BOT | HB_BUFFER_FLAG_EOT);

      hb_buffer_add_utf8 (hb_buffer,
                          paragraph_text, paragraph_length,
                          item_offset, item_length);

    Ie, HarfBuzz itself checks whether the segment is at the beginning/end
    of the paragraph.  Clients that only pass item-at-a-time to HarfBuzz
    continue not setting any flags whatsoever.

    Another way to put it is: if there's pre-context text in the buffer,
    HarfBuzz ignores the BOT flag.  If there's post-context, it ignores
    EOT flag.
  • Loading branch information
wiz committed Aug 5, 2014
1 parent a0e7956 commit 8969420
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions fonts/harfbuzz/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.37 2014/07/29 11:45:10 wiz Exp $
# $NetBSD: Makefile,v 1.38 2014/08/05 19:21:47 wiz Exp $

DISTNAME= harfbuzz-0.9.33
DISTNAME= harfbuzz-0.9.34
CATEGORIES= fonts
MASTER_SITES= http://www.freedesktop.org/software/harfbuzz/release/
EXTRACT_SUFX= .tar.bz2
Expand Down
8 changes: 4 additions & 4 deletions fonts/harfbuzz/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.27 2014/07/29 11:45:10 wiz Exp $
$NetBSD: distinfo,v 1.28 2014/08/05 19:21:47 wiz Exp $

SHA1 (harfbuzz-0.9.33.tar.bz2) = 4d935607f528a039efe632a5de7b729d60406df1
RMD160 (harfbuzz-0.9.33.tar.bz2) = 189151e8a00b1c4ba2dd21d9fc182055d9d1b2cd
Size (harfbuzz-0.9.33.tar.bz2) = 1139621 bytes
SHA1 (harfbuzz-0.9.34.tar.bz2) = 8a8cdbeaf1622459864180fbf453e3ab7343f338
RMD160 (harfbuzz-0.9.34.tar.bz2) = 3b493ca9757112882d1693d95c40afef57b021b6
Size (harfbuzz-0.9.34.tar.bz2) = 1157221 bytes

0 comments on commit 8969420

Please sign in to comment.