Skip to content

Commit

Permalink
Update to 0.3.1
Browse files Browse the repository at this point in the history
Upstream changes:
# Version 0.3.1

* Actually export `dbIsValid()` :/

* `dbGetQuery()` uses `dbFetch()` in the default implementation.

# Version 0.3.0

## New and enhanced generics

* `dbIsValid()` returns a logical value describing whether a connection or
  result set (or other object) is still valid. (#12).

* `dbQuoteString()` and `dbQuoteIdentifier()` to implement database specific
  quoting mechanisms.

* `dbFetch()` added as alias to `fetch()` to provide consistent name.
  Implementers should define methods for both `fetch()` and `dbFetch()` until
  `fetch()` is deprecated in 2015. For now, the default method for `dbFetch()`
  calls `fetch()`.

* `dbBegin()` begins a transaction (#17). If not supported, DB specific
  methods should throw an error (as should `dbCommit()` and `dbRollback()`).

## New default methods

* `dbGetStatement()`, `dbGetRowsAffected()`, `dbHasCompleted()`, and
  `dbGetRowCount()` gain default methods that extract the appropriate elements
  from `dbGetInfo()`. This means that most drivers should no longer need to
  implement these methods (#13).

* `dbGetQuery()` gains a default method for `DBIConnection` which uses
  `dbSendQuery()`, `fetch()` and `dbClearResult()`.

## Deprecated features

* The following functions are soft-deprecated. They are going away,
  and developers who use the DBI should begin preparing. The formal deprecation
  process will begin in July 2015, where these function will emit warnings
  on use.

    * `fetch()` is replaced by `dbFetch()`.

    * `make.db.names()`, `isSQLKeyword()` and `SQLKeywords()`: a black list
      based approach is fundamentally flawed; instead quote strings and
      identifiers with `dbQuoteIdentifier()` and `dbQuoteString()`.

* `dbGetDBIVersion()` is deprecated since it's now just a thin wrapper
  around `packageVersion("DBI")`.

* `dbSetDataMappings()` (#9) and `dbCallProc()` (#7) are deprecated as no
  implementations were ever provided.

## Other improvements

* `dbiCheckCompliance()` makes it easier for implementors to check that their
  package is in compliance with the DBI specification.

* All examples now use the RSQLite package so that you can easily try out
  the code samples (#4).

* `dbDriver()` gains a more effective search mechanism that doesn't rely on
  packages being loaded (#1).

* DBI has been converted to use roxygen2 for documentation, and now most
  functions have their own documentation files. I would love your feedback
  on how we could make the documentation better!
  • Loading branch information
wen committed Aug 7, 2015
1 parent c1f9ea2 commit b0dfeec
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions math/R-DBI/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2013/08/15 02:22:18 wen Exp $
# $NetBSD: Makefile,v 1.3 2015/08/07 01:41:38 wen Exp $

CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_R_CRAN:=contrib/}
Expand All @@ -9,7 +9,7 @@ COMMENT= R Database Interface
LICENSE= gnu-lgpl-v2

R_PKGNAME= DBI
R_PKGVER= 0.2-7
R_PKGVER= 0.3.1

.include "../../math/R/Makefile.extension"
.include "../../mk/bsd.pkg.mk"
8 changes: 4 additions & 4 deletions math/R-DBI/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.2 2013/08/15 02:22:18 wen Exp $
$NetBSD: distinfo,v 1.3 2015/08/07 01:41:38 wen Exp $

SHA1 (R/DBI_0.2-7.tar.gz) = 2f76382681ea40d1617079ee11977cb13486821a
RMD160 (R/DBI_0.2-7.tar.gz) = 7bf41d8290c8a1b24c9a81d0ef74efd423df2f88
Size (R/DBI_0.2-7.tar.gz) = 194699 bytes
SHA1 (R/DBI_0.3.1.tar.gz) = 380bbcda870269d3850bcbb01ef25aba92888cad
RMD160 (R/DBI_0.3.1.tar.gz) = 8f2016b8eb5222efbf7cb49e690c9a31c6b79525
Size (R/DBI_0.3.1.tar.gz) = 30106 bytes

0 comments on commit b0dfeec

Please sign in to comment.