Skip to content

Commit

Permalink
Updated to latest release, 3.0.14. From ChangeLog:
Browse files Browse the repository at this point in the history
- **MongoDB**: Now endures a connection failover (Issue #123).
- **MongoDB**: Fixed ``KeyError`` when a replica set member is removed.
    Also fixes celery#971 and celery/#898.
- **MongoDB**: Fixed MongoDB broadcast cursor re-initialization bug.
- **Async**: Fixed bug in lax semaphore implementation where in
  some usage patterns the limit was not honored correctly.
- **Redis**: Fixed problem with fanout when using Python 3 (Issue #324).
- **Redis**: Fixed ``AttributeError`` from attempting to close a non-existing
  connection (Issue #320).
- Redis: Fixed serious race condition that could lead to data loss.

    The delivery tags were accidentally set to be an incremental number
    local to the channel, but the delivery tags need to be globally
    unique so that a message can not overwrite an older message
    in the backup store.

    This change is not backwards incompatible and you are encouraged
    to update all your system using a previous version as soon as possible.

- Now depends on :mod:`amqp` 1.4.4.
- Pidbox: Now makes sure message encoding errors are handled by default,
  so that a custom error handler does not need to be specified.
- Redis: The fanout exchange can now use AMQP patterns to route and filter
  messages.
    This change is backwards incompatible and must be enabled with
    the ``fanout_patterns`` transport option::

        >>> conn = kombu.Connection('redis://', transport_options={
        ...     'fanout_patterns': True,
        ... })

    When enabled the exchange will work like an amqp topic exchange
    if the binding key is a pattern.

    This is planned to be default behavior in the future.

- Redis: Fixed ``cycle`` no such attribute error.
  • Loading branch information
rodent committed Apr 7, 2014
1 parent 39f1a22 commit f42e93f
Show file tree
Hide file tree
Showing 3 changed files with 11 additions and 8 deletions.
6 changes: 3 additions & 3 deletions net/py-kombu/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.6 2014/02/16 21:44:22 rodent Exp $
# $NetBSD: Makefile,v 1.7 2014/04/07 03:46:37 rodent Exp $

DISTNAME= kombu-3.0.12
DISTNAME= kombu-3.0.14
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= net
MASTER_SITES= https://pypi.python.org/packages/source/k/kombu/
Expand All @@ -10,7 +10,7 @@ HOMEPAGE= http://kombu.readthedocs.org/
COMMENT= Messaging framework for Python
LICENSE= modified-bsd

DEPENDS+= ${PYPKGPREFIX}-amqp>=1.4.3:../../net/py-amqp
DEPENDS+= ${PYPKGPREFIX}-amqp>=1.4.4:../../net/py-amqp

USE_LANGUAGES= # none

Expand Down
5 changes: 4 additions & 1 deletion net/py-kombu/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2014/02/16 21:44:22 rodent Exp $
@comment $NetBSD: PLIST,v 1.4 2014/04/07 03:46:37 rodent Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
Expand Down Expand Up @@ -86,6 +86,9 @@ ${PYSITELIB}/kombu/tests/async/__init__.pyo
${PYSITELIB}/kombu/tests/async/test_hub.py
${PYSITELIB}/kombu/tests/async/test_hub.pyc
${PYSITELIB}/kombu/tests/async/test_hub.pyo
${PYSITELIB}/kombu/tests/async/test_semaphore.py
${PYSITELIB}/kombu/tests/async/test_semaphore.pyc
${PYSITELIB}/kombu/tests/async/test_semaphore.pyo
${PYSITELIB}/kombu/tests/case.py
${PYSITELIB}/kombu/tests/case.pyc
${PYSITELIB}/kombu/tests/case.pyo
Expand Down
8 changes: 4 additions & 4 deletions net/py-kombu/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2014/02/16 21:44:22 rodent Exp $
$NetBSD: distinfo,v 1.5 2014/04/07 03:46:37 rodent Exp $

SHA1 (kombu-3.0.12.tar.gz) = aa98e422fdd3c12e3736e2e8f31e4e4367f8736d
RMD160 (kombu-3.0.12.tar.gz) = 09ef9c71baeec718d2443f17d5e174461858774b
Size (kombu-3.0.12.tar.gz) = 337963 bytes
SHA1 (kombu-3.0.14.tar.gz) = c86413793bd295228cc3bdc1af0fb8f616a34285
RMD160 (kombu-3.0.14.tar.gz) = 35c710d861b9097a9e4bb507223d33d543108c39
Size (kombu-3.0.14.tar.gz) = 340310 bytes

0 comments on commit f42e93f

Please sign in to comment.