Skip to content

Commit

Permalink
Updated py-hypothesis to 3.5.3.
Browse files Browse the repository at this point in the history
3.5.3 - 2016-10-05

This is a bug fix release.

Bugs fixed:

    If the same test was running concurrently in two processes and there were examples already in the test database which no longer failed, Hypothesis would sometimes fail with a FileNotFoundError (IOError on Python 2) because an example it was trying to read was deleted before it was read. (Issue #372).
    Drawing from an integers() strategy with both a min_value and a max_value would reject too many examples needlessly. Now it repeatedly redraws until satisfied. (Pull request #366. Thanks to Calen Pennington for the contribution).

3.5.2 - 2016-09-24

This is a bug fix release.

    The Hypothesis pytest plugin broke pytest support for doctests. Now it doesn’t.

3.5.1 - 2016-09-23

This is a bug fix release.

    Hypothesis now runs cleanly in -B and -BB modes, avoiding mixing bytes and unicode.
    unittest.TestCase tests would now have shown up in the new statistics mode. Now they do.
    Similarly, stateful tests would not have shown up in statistics and now they do.
    Statistics now print with pytest node IDs (the names you’d get in pytest verbose mode).

3.5.0 - 2016-09-22

This is a feature release.

    fractions() and decimals() strategies now support min_value and max_value parameters. Thanks go to Anne Mulhern for the development of this feature.
    The Hypothesis pytest plugin now supports a –hypothesis-show-statistics parameter that gives detailed statistics about the tests that were run. Huge thanks to Jean-Louis Fuchs and Adfinis-SyGroup for funding the development of this feature.
    There is a new event() function that can be used to add custom statistics.

Additionally there have been some minor bug fixes:

    In some cases Hypothesis should produce fewer duplicate examples (this will mostly only affect cases with a single parameter).
    py.test command line parameters are now under an option group for Hypothesis (thanks to David Keijser for fixing this)
    Hypothesis would previously error if you used function annotations on your tests under Python 3.4.
    The repr of many strategies using lambdas has been improved to include the lambda body (this was previously supported in many but not all cases).
  • Loading branch information
wiz committed Oct 19, 2016
1 parent 060e6f9 commit feb81d9
Show file tree
Hide file tree
Showing 3 changed files with 17 additions and 8 deletions.
4 changes: 2 additions & 2 deletions devel/py-hypothesis/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.4 2016/08/24 10:20:35 wiz Exp $
# $NetBSD: Makefile,v 1.5 2016/10/19 12:42:56 wiz Exp $

DISTNAME= hypothesis-3.4.2
DISTNAME= hypothesis-3.5.3
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_PYPI:=h/hypothesis/}
Expand Down
11 changes: 10 additions & 1 deletion devel/py-hypothesis/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2016/08/24 10:20:35 wiz Exp $
@comment $NetBSD: PLIST,v 1.3 2016/10/19 12:42:56 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
Expand Down Expand Up @@ -81,6 +81,12 @@ ${PYSITELIB}/hypothesis/internal/conjecture/utils.pyo
${PYSITELIB}/hypothesis/internal/debug.py
${PYSITELIB}/hypothesis/internal/debug.pyc
${PYSITELIB}/hypothesis/internal/debug.pyo
${PYSITELIB}/hypothesis/internal/deferredformat.py
${PYSITELIB}/hypothesis/internal/deferredformat.pyc
${PYSITELIB}/hypothesis/internal/deferredformat.pyo
${PYSITELIB}/hypothesis/internal/detection.py
${PYSITELIB}/hypothesis/internal/detection.pyc
${PYSITELIB}/hypothesis/internal/detection.pyo
${PYSITELIB}/hypothesis/internal/floats.py
${PYSITELIB}/hypothesis/internal/floats.pyc
${PYSITELIB}/hypothesis/internal/floats.pyo
Expand Down Expand Up @@ -138,6 +144,9 @@ ${PYSITELIB}/hypothesis/searchstrategy/wrappers.pyo
${PYSITELIB}/hypothesis/stateful.py
${PYSITELIB}/hypothesis/stateful.pyc
${PYSITELIB}/hypothesis/stateful.pyo
${PYSITELIB}/hypothesis/statistics.py
${PYSITELIB}/hypothesis/statistics.pyc
${PYSITELIB}/hypothesis/statistics.pyo
${PYSITELIB}/hypothesis/strategies.py
${PYSITELIB}/hypothesis/strategies.pyc
${PYSITELIB}/hypothesis/strategies.pyo
Expand Down
10 changes: 5 additions & 5 deletions devel/py-hypothesis/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2016/08/24 10:20:35 wiz Exp $
$NetBSD: distinfo,v 1.3 2016/10/19 12:42:56 wiz Exp $

SHA1 (hypothesis-3.4.2.tar.gz) = b551adf458dc389fd7735aa98dfecab299893060
RMD160 (hypothesis-3.4.2.tar.gz) = 40d5974b58ea7671adb3c1e8d3aea9f5e934852c
SHA512 (hypothesis-3.4.2.tar.gz) = 355815a11c57448a175a984d1ad6e87dcd9cc954acf312bfeff4ec499678166be6b9751173307748ff8b2d325b502cd31151e883e2a52f2d51a0395436bdb039
Size (hypothesis-3.4.2.tar.gz) = 71270 bytes
SHA1 (hypothesis-3.5.3.tar.gz) = 47a403ac3ff5b56c1332fc9df8c53e12c44bb043
RMD160 (hypothesis-3.5.3.tar.gz) = 1faedc1af8deec39c977121b50dc45e26867a0e0
SHA512 (hypothesis-3.5.3.tar.gz) = 1b22715e3ead84075d58c3e6ddfc074f542b2bce077e4e63fadd5910266bad81b3393b8a5c8d3b77e6f73e6987428fc92bd38a2d02003b5f490dd4ce08bca34c
Size (hypothesis-3.5.3.tar.gz) = 73052 bytes

0 comments on commit feb81d9

Please sign in to comment.