Skip to content

Commit

Permalink
zeal: update to 0.7.2.
Browse files Browse the repository at this point in the history
0.7.2

Features

    browser: apply dark mode without restart with Qt 6.7+ (2df0378)
    registry,ui: show docset search keywords/prefixes (07a357c)
    ui: add shortcut (Ctrl+B) to toggle sidebar visibility (a4fc8c1)

Bug Fixes

    ui: use correct QWebEngineProfile when applying font settings (cae1ea7)
    browser: use default QWebEngineProfile for Qt 6 (3d40ec7)
    core: use archive_entry_pathname_utf8 (5081898)
    browser: use button release for forward/back navigation (76187dc)
    ui: fix Unix build when X11 is not available (1eb6548)
    app: do not register protocol handlers on startup (a0fdca7)

Build System

    cpack/wix: fix protocol handler registration (b9a25f2)
    cmake: silence unset variable warning on Linux (4260a45)
    cmake: build against Qt 6 by default (04c525b)
    cmake: fix build if Qt 6 is not present (dff598c)
    cmake: use installed cpp-httplib if available (92faa65)

CI/CD

    github: update vcpkg to 2024.05.24 (418fc3b)
    github: build with Qt 6.7.2 (9b288c0)
    github: package source archives on Linux (92fa74f)
    github: use git-cliff to draft changelog (eedf6d0)

0.7.1

Fixes

    browser: send key events to web view's focus proxy (f2212eb), closes #703
    registry: save non-zero docset revision in meta.json (2cefcd4), closes #1532 #1559
    ui: add tool tip when global shortcuts are not supported (1d92d3c)
    ui: use async selection in search edit (d5ce8a0), closes #1033 #703

Build System

    cmake: find libarchive from brew on macos (#1621) (1ff2d6a)

CI/CD

    github: build with Qt 6.6.3 (cbd3208)
    github: use appstreamcli to validate Linux metadata file (de213a7)
    github: validate AppStream metadata (46e18c2)

0.7.0

Finally, a new release! Only several days short of the 5 year anniversary since v0.6.1.

Thanks to everyone who was reporting issues, suggesting improvements, contributing changes, testing development builds, or just patiently waiting.
Outline

The most significant changes are listed below.

    Web view has been migrated to Qt WebEngine (Chromium). This solves a lot of rendering issues and crashes caused by the unmaintained Qt WebKit.
    Docset pages are now served over built-in HTTP server, which addresses a number of docset specific issues.
    Emulated tabs have been replaced with real widgets, so each tab contains its own web view. Tab bar has been relocated to the top of the application window.
    Significantly improved dark mode support, including both user interface and web view (now uses native Chromium dark mode).
    Keyboard shortcuts are now more browser-like, with many new shorcuts added.
    Qt 6 support.
    CI has been migrated to GitHub Actions with Windows and Linux (AppImage) binaries provided for each build.

Features

    add Qt 6 support (#1420) (990be92)
    app,core,ui: remove ads (fixes #779) (680a1ba)
    app,registry: improve index page detection, add 404 page (c16945b)
    browser,sidebar,ui: implement real tabs (#1081) (0b45d6e)
    browser,ui: port to Qt WebEngine (#1125) (5360da3), closes #658 #776 #868 #959 #1119 #1131 #1155 #1195
    browser: add Ctrl+Enter shortcut for Highlight All option (#1476) (80d45f7), closes #1467
    browser: improve local file detection (096dcbf)
    browser: introduce centralized web settings management (e477c4a)
    browser: log blocked requests (0c47b3b)
    browser: make zoom scaling DPI aware (#1080) (b106938)
    browser: use native Chromium dark mode (#1494) (b5ca9e7)
    core,ui: add support for SOCKS5 proxies (fixes #893) (4d019ff)
    core: add option to ignore SSL errors (#1521) (9eb6169)
    core: enable smooth scrolling by default (09aa69e)
    registry,ui: respect per docset JavaScript enablement (fixes #999) (#1003) (8bfacd7)
    registry: add struct mapping for the Rust docset (0e3e427)
    registry: check JS enablement in metadata (fixes #1024) (f3bdf52)
    registry: report docset version in Qt::ToolTipRole (a8e4147), closes #1096
    registry: serve docset pages over HTTP (6dc7531), closes #1160
    ui: add shortcuts for zooming webview content (fixes #767) (#1012) (241b695)
    ui: add tree view navigation with directional keys and Alt (03e0e1e), closes #1007
    ui: allow tree view keyboard navigation if query is empty (6968e8e)
    ui: implement smart selection in the search box (closes #1033) (5ef5111)
    ui: load search results on selection (3118649), closes #749 #749
    ui: provide more information for download errors (4415920), closes #1088
    ui: use Fusion style on Windows 10 & 11 (#1495) (a524735), closes #811

Fixes

    app: fix missing app icon on Wayland (#1130) (57908f9)
    app: properly set desktop file name (cee4e50)
    assets: prevent duplicating application icons in GNOME dock (#1286) (043952f)
    assets: update AppStream ID to org.zealdocs.zeal (d4d7d35)
    browser: always use off-the-record profile (384d94a)
    browser: handle blob URL scheme for Qt older than 5.12 (9d376c2), closes #1376
    browser: prevent WebEngine taking away focus from searchbox (#1322) (763edca)
    core,ui: fix Qt 5.11 deprecation warnings (#1137) (99d2cee)
    core: bind local HTTP server to 127.0.0.1 (753ce5b), closes #995
    core: create root directory before extracting files (803db6a)
    core: enable support for HTTP redirects (407e416)
    core: fix docset storage not created in portable build (d34d7b5)
    core: ignore fixed font size setting when migrating from 0.6.0 (5362fc0), closes #903 #1054
    core: use relative storage path in portable build by default (b7d7e0a)
    registry,ui,util: order docsets case-insensitively (fixes #244) (0a33df2)
    registry,ui: restore docset icons on tabs (c2acb42), closes #1202
    registry: do not truncate feed name if there is no extension (84bf54c), closes [#1240](https://github.c...
  • Loading branch information
0-wiz-0 committed Nov 13, 2024
1 parent a9a4f92 commit 091d676
Show file tree
Hide file tree
Showing 4 changed files with 15 additions and 29 deletions.
15 changes: 8 additions & 7 deletions devel/zeal/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.21 2024/11/01 12:52:22 wiz Exp $
# $NetBSD: Makefile,v 1.22 2024/11/13 12:43:14 wiz Exp $

DISTNAME= zeal-0.6.1
PKGREVISION= 19
DISTNAME= zeal-0.7.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=zealdocs/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand All @@ -11,25 +10,27 @@ HOMEPAGE= https://zealdocs.org/
COMMENT= Offline documentation browser inspired by Dash
LICENSE= gnu-gpl-v3

USE_CMAKE= yes
TOOL_DEPENDS+= extra-cmake-modules>=5.10.0:../../devel/extra-cmake-modules

USE_LANGUAGES= c c++
USE_TOOLS+= gmake

TOOL_DEPENDS+= extra-cmake-modules>=5.10.0:../../devel/extra-cmake-modules

INSTALLATION_DIRS= bin share/applications share/metainfo
INSTALLATION_DIRS+= share/icons/hicolor/16x16/apps
INSTALLATION_DIRS+= share/icons/hicolor/24x24/apps
INSTALLATION_DIRS+= share/icons/hicolor/32x32/apps
INSTALLATION_DIRS+= share/icons/hicolor/64x64/apps
INSTALLATION_DIRS+= share/icons/hicolor/128x128/apps

.include "../../devel/cmake/build.mk"
.include "../../archivers/libarchive/buildlink3.mk"
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/qt5-qtbase/buildlink3.mk"
.include "../../x11/qt5-qtwebkit/buildlink3.mk"
.include "../../x11/qt5-qtlocation/buildlink3.mk"
.include "../../x11/qt5-qtwebchannel/buildlink3.mk"
.include "../../x11/qt5-qtwebengine/buildlink3.mk"
.include "../../x11/qt5-qtx11extras/buildlink3.mk"
.include "../../x11/xcb-util-keysyms/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
6 changes: 3 additions & 3 deletions devel/zeal/PLIST
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
@comment $NetBSD: PLIST,v 1.1 2020/07/26 00:51:00 scole Exp $
@comment $NetBSD: PLIST,v 1.2 2024/11/13 12:43:14 wiz Exp $
bin/zeal
share/applications/org.zealdocs.Zeal.desktop
share/applications/org.zealdocs.zeal.desktop
share/icons/hicolor/128x128/apps/zeal.png
share/icons/hicolor/16x16/apps/zeal.png
share/icons/hicolor/24x24/apps/zeal.png
share/icons/hicolor/32x32/apps/zeal.png
share/icons/hicolor/64x64/apps/zeal.png
share/metainfo/org.zealdocs.Zeal.appdata.xml
share/metainfo/org.zealdocs.zeal.appdata.xml
9 changes: 4 additions & 5 deletions devel/zeal/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.3 2021/10/26 10:20:10 nia Exp $
$NetBSD: distinfo,v 1.4 2024/11/13 12:43:14 wiz Exp $

BLAKE2s (zeal-0.6.1.tar.gz) = 81b9df4e7086e6c0e0c0d5a359c9a8aa62a44059bb33338b89d932acc9b60eb4
SHA512 (zeal-0.6.1.tar.gz) = 5b1a129980000c0fc8516e2c7d6c4a8de4adde7054ff8d9635e3be35441ad3ef0539746bbe1ca8abce7e6fb3d20c825b57661c3f8cd059ef1480db65ff81f3d9
Size (zeal-0.6.1.tar.gz) = 1063963 bytes
SHA1 (patch-src_libs_ui_searchitemdelegate.cpp) = ecd4ee285c79e2181d051e4588f50ce74eca753a
BLAKE2s (zeal-0.7.2.tar.gz) = dd7ab4a895a1ecc5dd85880f4fd79a03ae65129379a85be3c318666b22501128
SHA512 (zeal-0.7.2.tar.gz) = 46a0a15a5dd8f1ee18c6b02f2b9c6fbc7cc2f2ddc24d668932d6cbd4bab39228c1f49b58cb6838ba37e92e5fa8f8ab353f5f2ac7083007843940ad075be71919
Size (zeal-0.7.2.tar.gz) = 1200503 bytes
14 changes: 0 additions & 14 deletions devel/zeal/patches/patch-src_libs_ui_searchitemdelegate.cpp

This file was deleted.

0 comments on commit 091d676

Please sign in to comment.