Skip to content

Commit

Permalink
graphics/rabbit: update to 3.0.1
Browse files Browse the repository at this point in the history
pkgsrc change: switch to use rubygem.

3.0.1: 2021-09-25

Ruby 3.0 support release.

Improvements

rabbit
* Suppressed warnings. [GitHub#132][Patch by kojix2]
* image: Added support for Ruby 3.0. [GitHub#133][Patch by kojix2]
* image: Reused downloaded images.
* image: Removed support for normalized_width and normalized_height.
* image: Added support for clipping by clip_x, clip_y, clip_width and
  clip_height.
* info-window: Moved timer position to bottom on note mode.
* info-window: Added support for wait.
* Removed duplicated requires. [GitHub#134][Patch by kojix2]
* Added support for Charty.
* Added support for embedding terminal.
* Dropped support for Ustream.
* Added support for pushing gem with MFA enabled account. [GitHub#141][Patch
  by Yusuke Nakamura]

rabbit-slide
* Added support for specifying slide size.

Theme
* clear-blue: Added support for disabling vertical centering.
* tag: margin-*: Added support for negative and float values.
* tag: Added support for wrapping by wrap-char, wrap-word and wrap-word-char.
* tag: Added support for justifying by justify and no-justify.
* edge-info-toolkit: Added support for center text.
* slide-footer-info: Added support for center text.

Document
* Added note about theme and here + tortoise. [GitHub#139][Patch by Asaf Bartov]

Fixes

Theme
* image-slide-number: Fixed wrong width calculation. [GitHub#130][Patch by
  HASUMI Hitoshi]

Document
* Fixed English. [GitHub#128][Patch by Zero King]
* Fixed typos. [GitHub#140][Patch by Yusuke Nakamura]

Thanks
* Zero King
* HASUMI Hitoshi
* kojix2
* Asaf Bartov
* Yusuke Nakamura

3.0.2: 2023-06-25

Image drawing support release.

Improvements

rabbit
* image: Added support for drawing on image.
* image: Added support for align=right.
* Added support for Mermaid.
* blockdiag: Added support for blockdiag3 command.

rabbit-slide
* config: Added source_code_uri. GH-144 [Patch by Yusuke Nakamura]
* Dropped support for uploading to SlideShare. Because SlideShare API
  dropped support for uploading a slideshow.

Theme
* image-slide-number: Changed to render images back to the main content. It
  prevents hiding the main content.
* image-timer: Changed to render images back to the main content. It
  prevents hiding the main content.
* background-image-toolkit: Added support for caption.
* clear-blue: Changed to replace \n with a space character instead of just
  removing it in footer.
* pdf: Changed to use ./theme.rb instead of canvas.title theme by default.

Document
* macos Homebrew: Updated how to install document. GH-150 [Patch by Yusuke
  Nakamura]

Fixes

rabbit
* formatter HTML: Fixed a bug that weight configuration is missing. GH-146
  [Patch by HASUMI Hitoshi]

Theme
* image-timer: Fixed a bug that images aren't showed with PDF.
* image-slide-number: Fixed a bug that images aren't showed with PDF.

Thanks
* Yusuke Nakamura
* HASUMI Hitoshi

3.0.3: 2023-07-02

Minor bug fix release.

Fixes

rabbit
* image mermaid: Fixed an error when npx mmdc ... doesn't work. GH-153
  [Patch by Mamoru TASAKA]

Thanks
* Mamoru TASAKA
  • Loading branch information
taca committed Aug 5, 2023
1 parent a691274 commit 0d414df
Show file tree
Hide file tree
Showing 3 changed files with 800 additions and 510 deletions.
23 changes: 7 additions & 16 deletions graphics/rabbit/Makefile
Original file line number Diff line number Diff line change
@@ -1,18 +1,16 @@
# $NetBSD: Makefile,v 1.65 2023/04/07 21:22:45 tsutsui Exp $
# $NetBSD: Makefile,v 1.66 2023/08/05 12:38:28 taca Exp $
#

DISTNAME= rabbit-3.0.0
PKGREVISION= 1
CATEGORIES= graphics ruby
MASTER_SITES= http://rabbit-shocker.org/download/
DISTNAME= rabbit-3.0.3
CATEGORIES= graphics

MAINTAINER= [email protected]
HOMEPAGE= https://rabbit-shocker.org/
COMMENT= RD-document-based presentation application
LICENSE= gnu-gpl-v2 # or later

DEPENDS+= ${RUBY_PKGPREFIX}-gdk_pixbuf2>=3.0.9:../../graphics/ruby-gdk_pixbuf2
DEPENDS+= ${RUBY_PKGPREFIX}-gtk3>=3.3.8:../../x11/ruby-gtk3
#DEPENDS+= ${RUBY_PKGPREFIX}-gtk3>=3.3.8:../../x11/ruby-gtk3
DEPENDS+= ${RUBY_PKGPREFIX}-rsvg2>=3.3.8:../../graphics/ruby-rsvg2
DEPENDS+= ${RUBY_PKGPREFIX}-poppler>=3.3.8:../../print/ruby-poppler
DEPENDS+= ${RUBY_PKGPREFIX}-hikidoc-[0-9]*:../../textproc/ruby-hikidoc
Expand All @@ -22,21 +20,14 @@ DEPENDS+= ${RUBY_PKGPREFIX}-rttool-[0-9]*:../../textproc/ruby-rttool
DEPENDS+= ${RUBY_PKGPREFIX}-coderay>=1.0.0:../../textproc/ruby-coderay
DEPENDS+= ${RUBY_PKGPREFIX}-kramdown-parser-gfm-[0-9]*:../../textproc/ruby-kramdown-parser-gfm
DEPENDS+= ${RUBY_PKGPREFIX}-gettext>=3.0.1:../../devel/ruby-gettext
DEPENDS+= ${RUBY_PKGPREFIX}-faraday1-[0-9]*:../../www/ruby-faraday1
DEPENDS+= ${RUBY_PKGPREFIX}-rouge-[0-9]*:../../www/ruby-rouge

USE_RUBY_SETUP= yes
USE_RUBY_SETUP_PKG= yes
RUBYGEM_OPTIONS+= --format-executable

CONFIGURE_ARGS+= --siteruby=${PREFIX}/${RUBY_VENDORLIB_BASE} \
--siterubyver=${PREFIX}/${RUBY_VENDORLIB} \
--siterubyverarch=${PREFIX}/${RUBY_VENDORARCHLIB}

post-install:
cd ${DESTDIR}${PREFIX}/bin && \
for f in *; do \
${MV} $${f} $${f}${RUBY_SUFFIX}; \
done

.include "../../lang/ruby/modules.mk"
.include "../../x11/ruby-gtk3/buildlink3.mk"
.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"
Loading

0 comments on commit 0d414df

Please sign in to comment.