Skip to content

Commit

Permalink
Updated devel/visualvm to 2.1.6
Browse files Browse the repository at this point in the history
2.1.6:

  Features and Enhancements:

    Full support for running on/monitoring & profiling JDK 20:
      GH-483: JDK 20 support
    Heap viewer improvements:
      GH-481: [HeapViewer] display number of GC roots attached to particular instance
      GH-478: [HeapViewer] display logical value of java.security.CodeSource
      GH-477: [OQL] add signers and protectionDomain properties
      GH-455: [HeapViewer] display logical value of subclasses of java.nio.Buffer
      GH-454: Allow keyboard shortcut to execute oql
      GH-452: [HeapViewer] show array items
    Other improvements:
      GH-468: Update generic JFR loader to version 8.3.0
      GH-466: Add application recognizers for JDK tools
      GH-464: Update graaljs plugin to GraalVM 22.3.

  Fixed Bugs:

    GH-487: Snapshot data are not released when snapshot is closed
    GH-485: Delay loading previous nps captures for servers in Applications tree
    GH-484: When enumerating the roots nextElement can fail with: Cannot read property "getInstanceId" from null
    GH-475: NPE in RecursiveMethodInstrumentor.scanBytecode()
    GH-474: [HeapViewer] Slow computation of threads view
    GH-470: VisualVM GUI slow when monitoring host
    GH-457: Unusual proxy port notation
    GH-445: AWT thread blocked for few minutes while expanding GC root

2.1.5:

  Features and Enhancements:

    Full support for running on/monitoring & profiling JDK 19:
      GH-415: JDK 19 support
    Heap viewer usability improvements:
      GH-437: Add logical value for several Nodes
      GH-431: [HeapViewer] add logical value for python class 'decimal.Decimal'
      GH-430: [HeapViewer] Add support for TruffleString in Python heap viewer
    Other improvements:
      GH-448: Detect GraalVM language using system property
      GH-435: Add information about JDK release date and LTS
      GH-423: Remove Self time nodes from the sampler/profiler CPU trees when their total time is at 0,0 ms.
      GH-429: Update generic JFR loader to version 8.2.1
    Powered by the NetBeans Platform 14.0:
      GH-438: Upgrade NetBeans Platform

  Fixed Bugs:

    GH-451: [Heapviewer] Fix logical value for Ruby classes
    GH-446: [HeapViewer] Cannot call progress on a task that was never started
    GH-442: NPE from JvmJvmstatModel.getFirstArgument()
    GH-436: NPE in TruffleFrame.createLocals()
    GH-434: Incorrect colour of diff bar in memory sampler
    GH-432: [HeapViewer] Python 'dict' does not have any items
    GH-428: Profiler tab updates for terminated applications
    GH-426: GitHub issue template should explain how to obtain messages.log
    GH-425: Nodejs heap dump does not have any JavaScript objects
    GH-424: NPE in TruffleFrame.getObjectArray
    GH-422: Automatic re-connect of JXM application does not work
    GH-421: Remote JMX application reported as <unknown>
    GH-420: Arguments line of remote JVM cropped at 1024 characters
    GH-418: JFR does not work for remote OracleJDK 8
    GH-417: JFR enabled for JDK 7
    GH-416: Move JFR support to org.graalvm.visualvm.tools module
    GH-414: Profiler calibration fails on Solaris with JDK 11
    GH-304: Don't see polyglot functionality when running via JMX

2.1.4:

  Features and Enhancements:

    HeapViewer improvements:
      GH-413: [HeapViewer] Sample different elements from large arrays when inspecting a heap dump
      GH-409: [HeapViewer] Try to improve the accuracy of the instance size
      GH-407: [HeapViewer] Improve preview for byte[] arrays.
      GH-404: [HeapViewer] Add UI for working with multi-heap dumps.
      GH-402: [HeapViewer] Display number of elements for java.util.Properties

  Fixed Bugs:

    GH-412: ArrayIndexOutOfBoundsException on Memory Snapshot Diff Class Expansion
    GH-410: Wrong metaspace max values visualisation
    GH-406: Allow to use HeapProgress in head-less environment
    GH-405: Add API to get number of dumps stored in multi-heap dump file.
    GH-398: Missing known blocking method in KQueue
    GH-187: Taking Heap Dump does not work for tunnelled connection to a remote host
  • Loading branch information
abs committed May 17, 2023
1 parent 322f063 commit 16496cd
Show file tree
Hide file tree
Showing 3 changed files with 18 additions and 17 deletions.
6 changes: 3 additions & 3 deletions devel/visualvm/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.6 2022/05/12 13:15:58 abs Exp $
# $NetBSD: Makefile,v 1.7 2023/05/17 18:35:25 abs Exp $

DISTNAME= visualvm_213
PKGNAME= visualvm-2.1.3
DISTNAME= visualvm_216
PKGNAME= visualvm-2.1.6
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=oracle/}
GITHUB_RELEASE= ${PKGNAME:S:visualvm-::}
Expand Down
21 changes: 11 additions & 10 deletions devel/visualvm/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2022/05/12 13:15:58 abs Exp $
@comment $NetBSD: PLIST,v 1.4 2023/05/17 18:35:25 abs Exp $
bin/visualvm
lib/visualvm/LICENSE.txt
lib/visualvm/THIRDPARTYLICENSE
Expand Down Expand Up @@ -83,9 +83,9 @@ lib/visualvm/platform/config/Modules/org-openide-loaders.xml
lib/visualvm/platform/config/Modules/org-openide-nodes.xml
lib/visualvm/platform/config/Modules/org-openide-text.xml
lib/visualvm/platform/config/Modules/org-openide-windows.xml
lib/visualvm/platform/core/asm-8.0.1.jar
lib/visualvm/platform/core/asm-commons-8.0.1.jar
lib/visualvm/platform/core/asm-tree-8.0.1.jar
lib/visualvm/platform/core/asm-9.2.jar
lib/visualvm/platform/core/asm-commons-9.2.jar
lib/visualvm/platform/core/asm-tree-9.2.jar
lib/visualvm/platform/core/core-base.jar
lib/visualvm/platform/core/core.jar
lib/visualvm/platform/core/org-netbeans-libs-asm.jar
Expand All @@ -100,16 +100,17 @@ lib/visualvm/platform/lib/org-openide-modules.jar
lib/visualvm/platform/lib/org-openide-util-lookup.jar
lib/visualvm/platform/lib/org-openide-util-ui.jar
lib/visualvm/platform/lib/org-openide-util.jar
lib/visualvm/platform/modules/ext/flatlaf-1.1.2.jar
lib/visualvm/platform/modules/ext/jna-5.10.0.jar
lib/visualvm/platform/modules/ext/jna-platform-5.10.0.jar
lib/visualvm/platform/modules/ext/flatlaf-2.1.jar
lib/visualvm/platform/modules/ext/jna-5.12.1.jar
lib/visualvm/platform/modules/ext/jna-platform-5.12.1.jar
lib/visualvm/platform/modules/ext/updater.jar
lib/visualvm/platform/modules/lib/aarch64/jnidispatch-nb.dll
lib/visualvm/platform/modules/lib/aarch64/libjnidispatch-nb.jnilib
lib/visualvm/platform/modules/lib/aarch64/linux/libjnidispatch-nb.so
lib/visualvm/platform/modules/lib/amd64/jnidispatch-nb.dll
lib/visualvm/platform/modules/lib/amd64/linux/libjnidispatch-nb.so
lib/visualvm/platform/modules/lib/i386/linux/libjnidispatch-nb.so
lib/visualvm/platform/modules/lib/riscv64/linux/libjnidispatch-nb.so
lib/visualvm/platform/modules/lib/x86/jnidispatch-nb.dll
lib/visualvm/platform/modules/lib/x86_64/libjnidispatch-nb.jnilib
lib/visualvm/platform/modules/org-netbeans-api-annotations-common.jar
Expand Down Expand Up @@ -316,11 +317,11 @@ lib/visualvm/visualvm/lib/deployed/jdk16/windows/profilerinterface.dll
lib/visualvm/visualvm/lib/deployed/jdk16/windows/profilerinterface.map
lib/visualvm/visualvm/lib/jfluid-server-15.jar
lib/visualvm/visualvm/lib/jfluid-server.jar
lib/visualvm/visualvm/modules/ext/common-8.1.0.jar
lib/visualvm/visualvm/modules/ext/common-8.3.0.jar
lib/visualvm/visualvm/modules/ext/encoder-1.2.3.jar
lib/visualvm/visualvm/modules/ext/flightrecorder-8.1.0.jar
lib/visualvm/visualvm/modules/ext/flightrecorder-8.3.0.jar
lib/visualvm/visualvm/modules/ext/locale/updater_visualvm.jar
lib/visualvm/visualvm/modules/ext/lz4-java-1.7.1.jar
lib/visualvm/visualvm/modules/ext/lz4-java-1.8.0.jar
lib/visualvm/visualvm/modules/ext/profilerprobe.jar
lib/visualvm/visualvm/modules/ext/stagent.jar
lib/visualvm/visualvm/modules/locale/org-netbeans-core-windows_visualvm.jar
Expand Down
8 changes: 4 additions & 4 deletions devel/visualvm/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.6 2022/05/12 13:15:58 abs Exp $
$NetBSD: distinfo,v 1.7 2023/05/17 18:35:25 abs Exp $

BLAKE2s (visualvm_213.zip) = 9e93b37682d2116cddb466ec833d9a40c2e6afe3512e51786617b2090c8d3d44
SHA512 (visualvm_213.zip) = 07ca452bbab0923fffe883355d14f3160a874794caf5c1722d5922da1b3d79a25b1637dada992dcb46d2c5470461553981650862d3e449358f9af5fc7b0caccf
Size (visualvm_213.zip) = 20016887 bytes
BLAKE2s (visualvm_216.zip) = dd49a48d51dd08b6d105dd056de7b258981374ea6f848d28e6b87ed45039835f
SHA512 (visualvm_216.zip) = d839d444eced9357fab61d0a03da93c23eef7fde37230f5282eb0b1d4c30c54f37ffa5e3816770c586b06a1f5f026bde1968303faf7aba77e12db361c50040c8
Size (visualvm_216.zip) = 20461523 bytes

0 comments on commit 16496cd

Please sign in to comment.