Skip to content

Commit

Permalink
Update to skylighting-0.12.2
Browse files Browse the repository at this point in the history
0.12.2
* Parser: handle context shift to external context, e.g.,
  BashOneLine##Bash. Closes #139 (issue with Dockerfile).
* Update xml files from upstream: bash, cmake, markdown, objectivecpp, php,
  sql-postgresql, sql, stan, zshr
* Fix formatting in Color doc-comment (Janek Spaderna).
* Add stan.xml (Brian Ward).

0.12.1
* Update syntax definitions: bash, cmake, dockerfile, gnuassembler,
  markdown, spdx-comments.
* Support hex escapes using \x in regex char classes (#135). These occur in
  a number of syntax definitions and weren't correctly interpreted
  before. Thanks to @Agnishom.
* Support regex property syntax, e.g. \p{Lu}.
* Regex: support \B (non-word-boundary).

0.12
* Properly handle include elements in keyword lists (#124). A number of
  syntaxes (e.g. typescript, scala) include keyword lists from other
  syntaxe,s and previously we weren't able to handle this.
* There are several pieces to this change. We need to store lists where
  other Syntaxes can look them up, so we add an sLists field to Syntax [API
  change], and modify the parser to fill this. We change lists so that
  their values are not just a Text, but a ListItem that can either be a
  textual value or an include directive, specifying a ListName (syntax name
  and list name).
* The Keyword constructor for Matcher now takes, instead of a WordSet,
  Either a ListName or a WordSet (API change).
* Skylighting.Parser now exports resolveKeywords (API change), which
  modifies all Keyword matchers in a syntax so that Left values with a
  ListName become Right values with resolved WordSets. The tokenizer
  applies this function automatically to the SyntaxMap given in Config. But
  it is more efficient to do this conversion just once, rather than every
  time tokenize is called. So we have loadSyntaxesFromDir call it on the
  SyntaxMap. With this optimization, there is not an appreciable
  performance cost to the changes described above.
* Skylighting.Regex: Fix bug with regexes like a{10}b (#133). This requires
  exactly 10 a's; previously we interpreted it as "at least 10."
* skylighting-extract: take a directory as argument rather than files. This
  allows us to use loadSyntaxesFromDir.
* Update xml syntax definitions from upstream: julia, cmake, cpp, isocpp,
  markdown, python, toml.

0.11
* Skylighting.Regex: Support regex subroutines (#118). For example, (?1) is
  replaced by the regex in the first capturing group. So far we only
  support this simple, absolute form, not the relative form (?-1) supported
  by some engines (but not used, I think, in KDE's syntax
  highlighters). This change involves an API change: Regex in
  Skylighting.Regex has a new Subroutine constructor, and the Recurse
  constructor has been removed. Instead of Recurse we use Subroutine 0,
  which unifies the code.
* Skylighting.Regex: handle e.g. [\1] and [\123] (without initial 0) as
  octal escapes (#118). These occur in the zsh.xml syntax definition.
* Pull xml definitions for bash, cmake, python, zsh from upstream.
* README: Add a note about pulling syntax definitions from upstream
  (#138). Update build instructions for recent cabal versions (#131).

0.10.5.2
* Added swift grammar definition (Igor Ranieri).
* Simplify README.md instructions for two-step build.
* Fix link to KDE documentation.
  • Loading branch information
depressed-pho committed Feb 12, 2022
1 parent 6034aea commit 446677c
Show file tree
Hide file tree
Showing 4 changed files with 16 additions and 11 deletions.
5 changes: 2 additions & 3 deletions textproc/hs-skylighting/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.4 2022/01/18 02:48:28 pho Exp $
# $NetBSD: Makefile,v 1.5 2022/02/12 07:27:35 pho Exp $

DISTNAME= skylighting-0.10.5.1
PKGREVISION= 2
DISTNAME= skylighting-0.12.2
CATEGORIES= textproc

MAINTAINER= [email protected]
Expand Down
8 changes: 7 additions & 1 deletion textproc/hs-skylighting/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2021/04/24 16:32:23 pho Exp $
@comment $NetBSD: PLIST,v 1.3 2022/02/12 07:27:35 pho Exp $
bin/skylighting
lib/skylighting-${PKGVERSION}/${HS_VERSION}/package-description
lib/skylighting-${PKGVERSION}/${HS_VERSION}/package-id
Expand Down Expand Up @@ -390,9 +390,15 @@ lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/SqlMysql.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/SqlPostgresql.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/SqlPostgresql.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/SqlPostgresql.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Stan.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Stan.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Stan.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Stata.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Stata.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Stata.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Swift.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Swift.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Swift.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Tcl.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Tcl.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Skylighting/Syntax/Tcl.p_hi
Expand Down
6 changes: 3 additions & 3 deletions textproc/hs-skylighting/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.4 2022/01/18 02:48:28 pho Exp $
# $NetBSD: buildlink3.mk,v 1.5 2022/02/12 07:27:35 pho Exp $

BUILDLINK_TREE+= hs-skylighting

.if !defined(HS_SKYLIGHTING_BUILDLINK3_MK)
HS_SKYLIGHTING_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.hs-skylighting+= hs-skylighting>=0.10.5
BUILDLINK_ABI_DEPENDS.hs-skylighting+= hs-skylighting>=0.10.5.1nb2
BUILDLINK_API_DEPENDS.hs-skylighting+= hs-skylighting>=0.12.2
BUILDLINK_ABI_DEPENDS.hs-skylighting+= hs-skylighting>=0.12.2
BUILDLINK_PKGSRCDIR.hs-skylighting?= ../../textproc/hs-skylighting

.include "../../textproc/hs-skylighting-core/buildlink3.mk"
Expand Down
8 changes: 4 additions & 4 deletions textproc/hs-skylighting/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 11:22:03 nia Exp $
$NetBSD: distinfo,v 1.5 2022/02/12 07:27:35 pho Exp $

BLAKE2s (skylighting-0.10.5.1.tar.gz) = ca0b98a335fc2cd73d33c2cdadb51e5402fd68f8ffab1cad8c2c208275d9e027
SHA512 (skylighting-0.10.5.1.tar.gz) = 03d157469c73e18d262e6eda771aceba12663e1144d754fce959550db9f0cbf3e9f762fa6e05924f0a24b3e25b14c533e17b69265aa00f7bd24bc425e8ce34c7
Size (skylighting-0.10.5.1.tar.gz) = 648106 bytes
BLAKE2s (skylighting-0.12.2.tar.gz) = c2e8e41ba91dceb83c0d419bdf933b54790e202c4612ac880506a888f40d8f34
SHA512 (skylighting-0.12.2.tar.gz) = 49f5ba07c85d24a275586c16cee93d01e5f788205526006b200290221f31d067730a173ed56a1b99705828328b3a657fb5e142105037d3d1965e80219626c07a
Size (skylighting-0.12.2.tar.gz) = 1167679 bytes

0 comments on commit 446677c

Please sign in to comment.