Skip to content

Commit

Permalink
dunst: Update to 1.4.0
Browse files Browse the repository at this point in the history
1.4.0 - 2019-03-30

Added

    Add support to override frame_color via rules (#498)
    Support for round corners (#420)
    Ability to reference $HOME in icon paths with ~/ (#520)
    Support to customize the mouse bindings (#530)
    Command to toggle pause status (#535)
    Ability to automatically replace similar notifications (like volume changes) via stack_tag (#552)
    Comparison of raw icons for duplicate notifications (#571)
    Introduce new desktop-entry filter (#470)
    fullscreen rule to hide notifications when a fullscreen window is active (#472)
    Added skip_display rule option to skip initial notification display, and include the notification in the history. (#590)

Fixed

    Notification age not counting the time while the computer was suspended (#492)
    Dunst losing always-on-top status on a window manager restart (#160)
    Xpm icons not being recognized
    When new notifications arrive, but display is full, important notifications don’t have to wait for a timeout in a displayed notification (#541)
    Dunst hanging while the context menu is open (#456)
    Having & inside a notification breaking markup (#546)
    <I> more notifications don’t occupy space anymore, if there is only a single notification waiting to get displayed. The notification gets displayed directly (#467)
    Segfault when comparing icon name with a notification with a raw icon (#536)
    Icon size can no longer be larger than the notification when a fixed width is specified (#540)

Changed

    Transient notifications no longer skip history by default (#508)
    The notification summary no longer accepts markup (#497)

Removed

    Dependency on libxdg-basedir (#550)

1.3.2 - 2018-05-06

Fixed

    Crash when trying to load an invalid or corrupt icon (#512)

1.3.1 - 2018-01-30

Fixed

    Race condition resulting in the service files being empty (#488)

1.3.0 - 2018-01-05

Added

    ellipsize option to control how long lines should be ellipsized when word_wrap is set to false (#374)
    A beginning tilde of a path is now expanded to the home of the current user (#351)
    The image-path hint is now respected, as GApplications send their icon only via this link (#447)
    The (legacy) image_data hint is now respected (#353)
    If dunst can’t acquire the DBus name, dunst prints the PID of the process holding the name (#458 #460)
    Increased accuracy of timeouts by using microseconds internally (#379 #291)
    Support for specifying timeout values in milliseconds, minutes, hours, or days. (#379)
    Support for HTML img tags (via context menu) (#428)

Fixed

    new_icon rule being ignored on notifications that had a raw icon (#423)
    Format strings being replaced recursively in some cases (#322 #365)
    DBus related memory leaks (#397)
    Crash on X11 servers with RandR support less than 1.5. (#413 #364)
    Silently reading the default config file, if -conf did not specify a valid file (#452)
    Notification window flickering when a notification is replaced (#320 #415)
    Inaccurate timeout in some cases (#291 #379)

Changed

    Transient hints are now handled (#343 #310) An additional rule option (match_transient and set_transient) is added to optionally reset the transient setting
    HTML links are now referred to by their text in the context menu rather than numbers (#428)
    icon_folders setting renamed to icon_path (#170)
    config.def.h and config.h got merged (#371)
    The dependency on GTK3+ has been removed. Instead of GTK3+, dunst now requires gdk-pixbuf which had been a transient dependency before. (#334 #376)
    The _GNU_SOURCE macros had been removed to make dunst portable to nonGNU systems (#403)
    Internal refactorings of the notification queue handling. (#411)
    Dunst does now install the systemd and dbus service files into their proper location given by pkg-config. Use SERVICEDIR_(DBUS|SYSTEMD) params to overwrite them. (#463)
  • Loading branch information
alarixnia committed Jun 10, 2019
1 parent 252b9b3 commit 8b09e4e
Show file tree
Hide file tree
Showing 5 changed files with 38 additions and 51 deletions.
16 changes: 11 additions & 5 deletions x11/dunst/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.13 2018/11/14 22:22:39 kleink Exp $
# $NetBSD: Makefile,v 1.14 2019/06/10 13:06:54 nia Exp $

DISTNAME= dunst-1.2.0
PKGREVISION= 4
DISTNAME= dunst-1.4.0
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GITHUB:=dunst-project/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand All @@ -14,6 +13,7 @@ LICENSE= modified-bsd
USE_TOOLS+= gmake pkg-config

MAKE_FLAGS+= MANPREFIX=${PREFIX}/${PKGMANDIR}
MAKE_FLAGS+= SYSTEMD=0

SUBST_CLASSES+= fix-paths
SUBST_STAGE.fix-paths= pre-configure
Expand All @@ -22,11 +22,17 @@ SUBST_FILES.fix-paths= dunstrc config.h
SUBST_SED.fix-paths+= -e 's,/usr/bin,${PREFIX}/bin,g'
SUBST_SED.fix-paths+= -e 's,/usr/share,${PREFIX}/share,g'

INSTALLATION_DIRS+= bin
INSTALLATION_DIRS+= ${PKGMANDIR}/man1
INSTALLATION_DIRS+= share/dbus-1/services
INSTALLATION_DIRS+= share/dunst

.include "../../devel/pango/buildlink3.mk"
.include "../../graphics/gdk-pixbuf2/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../x11/libxdg-basedir/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXScrnSaver/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/libXrandr/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
14 changes: 6 additions & 8 deletions x11/dunst/distinfo
Original file line number Diff line number Diff line change
@@ -1,9 +1,7 @@
$NetBSD: distinfo,v 1.4 2017/07/20 10:39:25 leot Exp $
$NetBSD: distinfo,v 1.5 2019/06/10 13:06:54 nia Exp $

SHA1 (dunst-1.2.0.tar.gz) = 0345274eb2d9a07690fad650523714c552465692
RMD160 (dunst-1.2.0.tar.gz) = 3314646f4baaf246397766e60fa2ec1fd6660641
SHA512 (dunst-1.2.0.tar.gz) = 223c8aae61574770a76bff84723643a3c03d3d9a8f4094bc4e92e16826703e7c0a7c3327945db8469b8dcc48fe5cfaba51e6724149e6571a7ffc1716656e30f3
Size (dunst-1.2.0.tar.gz) = 110628 bytes
SHA1 (patch-Makefile) = d56b2d25fccbee89eed23097defff9fa0cc561dd
SHA1 (patch-config.mk) = 36ff5dd95e73dfbc00181bc0e67e4cf0db40a93b
SHA1 (patch-src_notification.c) = 4ce64e6d2882303e24df9d99789491ac4b986fcf
SHA1 (dunst-1.4.0.tar.gz) = 33ca9f97c4ce25610c58543bf282c2b7fbf9e191
RMD160 (dunst-1.4.0.tar.gz) = 8e79af9a04e4f3e5f691e120664b959f6aa8e1cb
SHA512 (dunst-1.4.0.tar.gz) = b6945ab51f93504d83ce6634b9e333157d761033cd35759857c105a868ef4d42146fd1fd59ce88ec86d541bdd7ab6de15e24372be59051f5adbd7a2d5df597d6
Size (dunst-1.4.0.tar.gz) = 159632 bytes
SHA1 (patch-Makefile) = aa9d85e8ffcbca4b430f68fdae9727df0f9ecdd4
30 changes: 21 additions & 9 deletions x11/dunst/patches/patch-Makefile
Original file line number Diff line number Diff line change
@@ -1,14 +1,26 @@
$NetBSD: patch-Makefile,v 1.2 2017/07/20 10:39:25 leot Exp $
$NetBSD: patch-Makefile,v 1.3 2019/06/10 13:06:54 nia Exp $

Do not install systemd `.service' file.
Use BSD_INSTALL.

--- Makefile.orig 2017-07-12 08:22:04.000000000 +0000
--- Makefile.orig 2019-03-30 16:47:06.000000000 +0000
+++ Makefile
@@ -64,7 +64,6 @@ install-doc:
install-service: service
mkdir -p ${DESTDIR}${PREFIX}/share/dbus-1/services/
install -m644 org.knopwob.dunst.service ${DESTDIR}${PREFIX}/share/dbus-1/services
- install -Dm644 dunst.systemd.service ${DESTDIR}${PREFIX}/lib/systemd/user/dunst.service

@@ -157,15 +157,15 @@ clean-coverage-run:
install: install-dunst install-doc install-service

install-dunst: dunst doc
- install -Dm755 dunst ${DESTDIR}${BINDIR}/dunst
- install -Dm644 docs/dunst.1 ${DESTDIR}${MANPREFIX}/man1/dunst.1
+ ${BSD_INSTALL_PROGRAM} dunst ${DESTDIR}${BINDIR}/dunst
+ ${BSD_INSTALL_MAN} docs/dunst.1 ${DESTDIR}${MANPREFIX}/man1/dunst.1

install-doc:
- install -Dm644 dunstrc ${DESTDIR}${DATADIR}/dunst/dunstrc
+ ${BSD_INSTALL_DATA} dunstrc ${DESTDIR}${DATADIR}/dunst/dunstrc

install-service: install-service-dbus
install-service-dbus: service-dbus
- install -Dm644 org.knopwob.dunst.service ${DESTDIR}${SERVICEDIR_DBUS}/org.knopwob.dunst.service
+ ${BSD_INSTALL_DATA} org.knopwob.dunst.service ${DESTDIR}${SERVICEDIR_DBUS}/org.knopwob.dunst.service
ifneq (0,${SYSTEMD})
install-service: install-service-systemd
install-service-systemd: service-systemd
15 changes: 0 additions & 15 deletions x11/dunst/patches/patch-config.mk

This file was deleted.

14 changes: 0 additions & 14 deletions x11/dunst/patches/patch-src_notification.c

This file was deleted.

0 comments on commit 8b09e4e

Please sign in to comment.