forked from NetBSD/pkgsrc
-
Notifications
You must be signed in to change notification settings - Fork 51
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
pkgsrc note: the CVE listed below was only for 2.x, so pkgsrc is not affected. 2.0.5 Improve on parsing list. Make it possible to customize list regex. ref #331 2.0.4 Fix url plugin in <a> tag Fix * formatting 2.0.3 Fix table plugin Security fix for CVE-2022-34749 2.0.2 cape_url via #295 2.0.1 Fix XSS for image link syntax. 2.0.0 First release of Mistune v2. 2.0.0rc1 In this release, we have a Security Fix for harmful links. 2.0.0alpha1 This is the first release of v2. An alpha version for users to have a preview of the new mistune.
- Loading branch information
Showing
3 changed files
with
71 additions
and
13 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,19 +1,23 @@ | ||
# $NetBSD: Makefile,v 1.8 2022/01/04 20:54:59 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.9 2023/05/05 08:48:35 wiz Exp $ | ||
|
||
DISTNAME= mistune-0.8.4 | ||
DISTNAME= mistune-2.0.5 | ||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME} | ||
PKGREVISION= 1 | ||
CATEGORIES= textproc python | ||
MASTER_SITES= ${MASTER_SITE_PYPI:=m/mistune/} | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= https://github.com/lepture/mistune | ||
COMMENT= The fastest markdown parser in pure Python | ||
COMMENT= Sane Markdown parser with useful plugins and renderers | ||
LICENSE= modified-bsd | ||
|
||
TEST_DEPENDS+= ${PYPKGPREFIX}-nose-[0-9]*:../../devel/py-nose | ||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test | ||
|
||
USE_LANGUAGES= # none | ||
|
||
PYTHON_VERSIONS_INCOMPATIBLE= 27 | ||
|
||
do-test: | ||
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX} | ||
|
||
.include "../../lang/python/egg.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,63 @@ | ||
@comment $NetBSD: PLIST,v 1.3 2018/10/14 12:09:56 adam Exp $ | ||
@comment $NetBSD: PLIST,v 1.4 2023/05/05 08:48:35 wiz Exp $ | ||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO | ||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt | ||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt | ||
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe | ||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt | ||
${PYSITELIB}/mistune.py | ||
${PYSITELIB}/mistune.pyc | ||
${PYSITELIB}/mistune.pyo | ||
${PYSITELIB}/mistune/__init__.py | ||
${PYSITELIB}/mistune/__init__.pyc | ||
${PYSITELIB}/mistune/__init__.pyo | ||
${PYSITELIB}/mistune/block_parser.py | ||
${PYSITELIB}/mistune/block_parser.pyc | ||
${PYSITELIB}/mistune/block_parser.pyo | ||
${PYSITELIB}/mistune/directives/__init__.py | ||
${PYSITELIB}/mistune/directives/__init__.pyc | ||
${PYSITELIB}/mistune/directives/__init__.pyo | ||
${PYSITELIB}/mistune/directives/admonition.py | ||
${PYSITELIB}/mistune/directives/admonition.pyc | ||
${PYSITELIB}/mistune/directives/admonition.pyo | ||
${PYSITELIB}/mistune/directives/base.py | ||
${PYSITELIB}/mistune/directives/base.pyc | ||
${PYSITELIB}/mistune/directives/base.pyo | ||
${PYSITELIB}/mistune/directives/include.py | ||
${PYSITELIB}/mistune/directives/include.pyc | ||
${PYSITELIB}/mistune/directives/include.pyo | ||
${PYSITELIB}/mistune/directives/toc.py | ||
${PYSITELIB}/mistune/directives/toc.pyc | ||
${PYSITELIB}/mistune/directives/toc.pyo | ||
${PYSITELIB}/mistune/inline_parser.py | ||
${PYSITELIB}/mistune/inline_parser.pyc | ||
${PYSITELIB}/mistune/inline_parser.pyo | ||
${PYSITELIB}/mistune/markdown.py | ||
${PYSITELIB}/mistune/markdown.pyc | ||
${PYSITELIB}/mistune/markdown.pyo | ||
${PYSITELIB}/mistune/plugins/__init__.py | ||
${PYSITELIB}/mistune/plugins/__init__.pyc | ||
${PYSITELIB}/mistune/plugins/__init__.pyo | ||
${PYSITELIB}/mistune/plugins/abbr.py | ||
${PYSITELIB}/mistune/plugins/abbr.pyc | ||
${PYSITELIB}/mistune/plugins/abbr.pyo | ||
${PYSITELIB}/mistune/plugins/def_list.py | ||
${PYSITELIB}/mistune/plugins/def_list.pyc | ||
${PYSITELIB}/mistune/plugins/def_list.pyo | ||
${PYSITELIB}/mistune/plugins/extra.py | ||
${PYSITELIB}/mistune/plugins/extra.pyc | ||
${PYSITELIB}/mistune/plugins/extra.pyo | ||
${PYSITELIB}/mistune/plugins/footnotes.py | ||
${PYSITELIB}/mistune/plugins/footnotes.pyc | ||
${PYSITELIB}/mistune/plugins/footnotes.pyo | ||
${PYSITELIB}/mistune/plugins/table.py | ||
${PYSITELIB}/mistune/plugins/table.pyc | ||
${PYSITELIB}/mistune/plugins/table.pyo | ||
${PYSITELIB}/mistune/plugins/task_lists.py | ||
${PYSITELIB}/mistune/plugins/task_lists.pyc | ||
${PYSITELIB}/mistune/plugins/task_lists.pyo | ||
${PYSITELIB}/mistune/renderers.py | ||
${PYSITELIB}/mistune/renderers.pyc | ||
${PYSITELIB}/mistune/renderers.pyo | ||
${PYSITELIB}/mistune/scanner.py | ||
${PYSITELIB}/mistune/scanner.pyc | ||
${PYSITELIB}/mistune/scanner.pyo | ||
${PYSITELIB}/mistune/util.py | ||
${PYSITELIB}/mistune/util.pyc | ||
${PYSITELIB}/mistune/util.pyo |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
$NetBSD: distinfo,v 1.8 2021/10/26 11:23:08 nia Exp $ | ||
$NetBSD: distinfo,v 1.9 2023/05/05 08:48:35 wiz Exp $ | ||
|
||
BLAKE2s (mistune-0.8.4.tar.gz) = cb947311d0db69a660f19188e542f02b4518430760c185fc4010806e422cbcfb | ||
SHA512 (mistune-0.8.4.tar.gz) = 36c3ef5d5537f5cceaa43e4da20a84b27c378cb744a93f0380024faefde490bcb42c453f79002ca049083fc437278f4afb3e10de5462f9eeb9077ca2a2fcaea7 | ||
Size (mistune-0.8.4.tar.gz) = 58322 bytes | ||
BLAKE2s (mistune-2.0.5.tar.gz) = 400a32e13544e171f146d6d885eea4b358bfa98da3e856886daedb64239a9405 | ||
SHA512 (mistune-2.0.5.tar.gz) = 109447977a441ebbedfca2abbe62415139d94c48ae56c3d8cae04df3f93ccd1e8333b3dbb8bf61a2096b903df6c3aab2fadd0893fb82815416f17555465e98c7 | ||
Size (mistune-2.0.5.tar.gz) = 75854 bytes |