Skip to content

Commit

Permalink
Update to 1.001
Browse files Browse the repository at this point in the history
Upstream changes:
=== Version 1.001 (2020-11-05)

 lib/PDF/Table.pm  fix edge case where no borders led to no rules [GH 55].

 t/manifest.t, t/pod.t
  Make author-only (AUTHOR_TESTING=1). ref [GH 61]

 lib/PDF/Table.pm, t/pod.t
  POD change =head5 to =head4, to look better and stop older POD checkers
   from complaining (in t/pod.t). Also minimum Test::Pod version 1.52
   (was 1.00). ref [GH 61].

 examples/sample1.pl, t/lib/TestData.pm, INFO/Deprecated, lib/PDF/Table.pm
  Replace deprecated setting names by current names in the POD, examples, and
   t-tests. After November 2022, settings names (args) with a leading dash
   (hyphen) will no longer be permitted.

=== Version 1.000 (2020-11-03)

 INFO/Deprecated, INFO/Table.html, lib/PDF/Table.pm
  Final cleanup of POD and generation of HTML documentation, and listing of
   all deprecated setting names.

 t/lib/PDFAPI2Mock.pm  add linedash dummy call so t tests can run.

 lib/PDF/Table.pm, MANIFEST, examples/border_rules.pl, util/3_examples.pl
  Old "borders" was vertical and horizontal rules PLUS outside rules (frame).
   Separate into "borders" (outside) and "rules" (inside). Add border_rules.pl
   example to illustrate.

 examples/chess.pl  with DejaVu-Sans, can use chess piece images

 .github/worksflows/test.yml, README.md  minor fixes in README to make lint
   run happily, stop checking Table.html.

 examples/*.pl  Allow -A or -B on the command line (case insensitive) to
   override PDFpref file (if any) setting. This speeds up testing for PDF::API2
   vs PDF::Builder (default).

 lib/PDF/Table.pm, INFO/Deprecated, INFO/Table.html, MANIFEST,
   examples/chess.pl, t/PDF-Table.t, t/lib/PDFAPI2Mock.pm, util/3_examples.pl
  Clean up handling of minimum and maximum cell widths (min_w and max_w).
   Clean up handling of background and foreground colors. Add chess.pl example
   to show off color handling. Update t-tests for slight coordinate changes.

 Add row_props (row properties) similar to column_props, to set things on a
   per-row basis.

 If the table spills over to a new page, and next_y and/or next_h was NOT
   given, issue a warning and for a default use 90% of the media height for
   next_y and 80% for next_h (ref ticket #11). This should be better than
   using the (start_)y and (start_)h values for the table.

 Add new, more consistent aliases for a number of settings (ref ticket #13).
   The old setting names are still available for at least TWO YEARS, after
   which, they will be REMOVED. Over the next two years you should update your
   code to use the new setting names. The settings involved are:
      'start_y'               is now 'y'
      'start_h'               is now 'h'
      'row_height'            is now 'min_rh'
      'background_color'      is now 'bg_color'
      'background_color_odd'  is now 'bg_color_odd'
      'background_color_even' is now 'bg_color_even'
      'font_color'            is now 'fg_color'
      'font_color_odd'        is now 'fg_color_odd'
      'font_color_even'       is now 'fg_color_even'
      'font_underline'        is now 'underline'
      'lead'                  is now 'leading'
   These are listed in INFO/Deprecated. In the near future, the examples and
   t-tests will be updated to use the new setting names.

 Ship with Table.html (documentation) in INFO/. Update MANIFEST.

 Remove 010_fonts.pl from the util/3_examples.pl list. I'm still not sure why
   it should be in the examples -- basically, it shows that UTF-8 doesn't work
   with core fonts, but that's already a documented limitation (in
   PDF::Builder). 010_fonts.pl is still in the examples/ directory, if anyone
   wants to play with it.

 Add INFO/Deprecated to list names and interfaces scheduled to be removed in
   the future (at least 2 years). MANIFEST updated.

 Split out older Changes list into INFO/Changes_2019. MANIFEST updated.

 Increase default cell padding to 2pt. See documentation "COMPATIBILITY" for
   how to get the old behavior (0pt padding). t/Basics.t, t/Colspan.t,
   t/PDF-Table.t expected write locations updated. examples/colspan.pl and
   examples/header.pl were widened slightly to accommodate the padding.

 Make "odd/even" row consistent with or without a header (repeated or not),
   particularly when a table is split across pages, and when a row itself is
   split in such a case. See documentation "COMPATIBILITY" for how to get the
   old behavior.

 Header 'repeat' default changed from 0 (no) to 1 (yes), as most of the time
   a user will want to repeat any header on each new page. Suppress repeating
   a header with a value of 0. See documentation "COMPATIBILITY" for how to
   get the old behavior.

 Currently, PDF::Table is shipped to use the new behaviors, with as much
   compatibility as possible with existing code (see $compat_mode in Table.pm).
   Unless you have need to use the old behaviors for existing code, we
   suggest that you leave $compat_mode as 0, use the 'compatibility' setting, or
   individually set the flags, to make use of the new behaviors. Also use the
   new settings names, unless there is a need for compatibility in existing
   code. Eventually, use of the old names will produce warnings, and later,
   error messages, but the old behaviors should be available for a long time.
   You should examine your existing code and plan to update it over time.

 Initialize %arg entries (defaults) so no uninitialized errors. #57 reported by
   Larry Leszczynski (larryl) for text_block() along with PR.

 Minor build process cleanup
 Minor spelling and typo fixes in POD and examples
  • Loading branch information
wen committed Nov 15, 2020
1 parent a5edb59 commit b403edb
Show file tree
Hide file tree
Showing 2 changed files with 7 additions and 7 deletions.
4 changes: 2 additions & 2 deletions textproc/p5-PDF-Table/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.24 2020/09/07 14:45:32 wiz Exp $
# $NetBSD: Makefile,v 1.25 2020/11/15 07:00:37 wen Exp $

DISTNAME= PDF-Table-0.12
DISTNAME= PDF-Table-1.001
PKGNAME= p5-${DISTNAME}
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=PDF/}
Expand Down
10 changes: 5 additions & 5 deletions textproc/p5-PDF-Table/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.12 2020/09/07 14:45:32 wiz Exp $
$NetBSD: distinfo,v 1.13 2020/11/15 07:00:37 wen Exp $

SHA1 (PDF-Table-0.12.tar.gz) = dd60d4c2473ccac9b7c5d91203dc18a8078022fa
RMD160 (PDF-Table-0.12.tar.gz) = 66aa94eb22cfe00beab764cbfa44aeaed559dff1
SHA512 (PDF-Table-0.12.tar.gz) = 4fa453283f452638b3c1d152f1cc4436c43cb5d95a343431d6a4569cd1cdd439e7c82e7fd27ce1b466ae6487297922a3010450ee42c4217f1e18bbb8498c09be
Size (PDF-Table-0.12.tar.gz) = 33120 bytes
SHA1 (PDF-Table-1.001.tar.gz) = 482c82af64e244171282df3477baaefe38fd492c
RMD160 (PDF-Table-1.001.tar.gz) = 1e62650aeacf952ab4eafb00d2135dc8e6fe3b43
SHA512 (PDF-Table-1.001.tar.gz) = 413b2017a2cd1f3e70e9378cb5a1c4c0b65b1caa0838fecf4c1d608dabdba505803b2c01faefa2ccbc705f59364bdd8348fe3f7844a373ecaffa8ab00eb67910
Size (PDF-Table-1.001.tar.gz) = 74475 bytes

0 comments on commit b403edb

Please sign in to comment.