Skip to content

Commit

Permalink
(math/R-xts) Updated 0.11.2 to 0.12.1
Browse files Browse the repository at this point in the history
Changed in xts 0.12.1:

o  Various function could change the tclass of xts objects. This would happen
   in calls to reclass(), period.apply(), and for logical operations on
   POSIXct indexes. Thanks to Tom Andrews for the report and testing, and to
   Panagiotis Cheilaris for contributing test cases (#322, #323).

o  plot.xts() now supports y-axis labels via 'ylab'. Thanks to Jasen Mackie
   for the suggestion and PR (#333, #334).

o  The API header has been updated to fix the signatures of do_merge_xts() and
   is_xts, which did not return a SEXP as required of functions callable by
   .Call(). Thanks to Tomas Kalibera for the report (#317), and Dirk
   Eddelbuettel for the PR (#337). This is a breaking change, but is required
   to avoid the potential for a segfault.

o  Michael Chirico added an internal isUTC() function to recognize many UTC-
   equivalent time zones (#319).

o  first() now operates correctly on non-xts objects when 'n = -1'. Previously
   it would always return the last two values. Thanks to GitHub user vxg20
   for the report (#325).

o  The .xts() constructor would create an xts object with row names if 'x' had
   row names. This shouldn't happen, because xts objects do not have or
   support row names (#298).

o  Claymore Marshall added many examples of time-of-day subsetting to
   ?subset.xts. He also fixed a bug in time-of-day subsetting where subsetting
   by hour only returned wrong results (#304, #326, #328).

Changed in xts 0.12-0:

o  All the index-attributes have been removed from the xts object and are now
   only attached to the index itself (#245). We took great care to maintain
   backward compatibility, and throw warnings when deprecated functions are
   called and when index-attributes are found on the xts object. But there
   still may be some breaking changes lurking in edge cases.

   o @SamoPP found one edge case (#297) where an error was thrown when index()
     was called on an xts object with an index that had no tclass attribute.
   o ...which led Joshua to find that the index setting functions did not
     always copy index attributes (#305).

o  Several binary operations (e.g. +, -, !=, <, etc.) on variations of
   uncommon xts objects with other xts, matrix, or vector objects, could
   result in malformed xts objects (#295). Some examples of the types of
   uncommon xts objects: no dim attribute, zero-width, zero-length.

o  Calling as.matrix() on an xts object without a dim attribute no longer
   throws an error (#294).

o  merge.xts() now honors check.names = FALSE (#293).

o  The possible values for major.ticks, minor.ticks, and grid.ticks.on in the
   Details section of ?plot.xts have been corrected. Thanks to Harvey Smith
   (@harvey131) for the report and patch (#291).

o  as.zoo.xts() is now only registered for zoo versions prior to 1.8-5. Methods
   to convert an object to another class should reside in the package that
   implements the target class. Thanks to Kurt Hornik for the report (#287).

o  .parseISO8601() no longer has a potential length-1 logical error. Thanks to
   Kurt Hornik for the report (#280).

o  endpoints() now honors k > 0 when on = "quarters". Thanks to @alkment for
   the report (#279).

o  Performance for the period.XYZ() functions (sum, prod, min, max) is much
   faster (#278). Thanks to Harvey Smith (@harvey131) for the report and
   examples.

o  merge.xts() now creates shorter column names when passed unnamed objects.
   This is now consistent with zoo (#248).

o  Time-of-day performance is ~200x faster, thanks to StackOverflow
   user3226167 (#193).
  • Loading branch information
mef committed Jun 6, 2021
1 parent 0b412ae commit c234259
Show file tree
Hide file tree
Showing 2 changed files with 11 additions and 7 deletions.
8 changes: 6 additions & 2 deletions math/R-xts/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.12 2019/08/08 19:53:55 brook Exp $
# $NetBSD: Makefile,v 1.13 2021/06/06 15:12:59 mef Exp $

R_PKGNAME= xts
R_PKGVER= 0.11-2
R_PKGVER= 0.12.1
CATEGORIES= math

MAINTAINER= [email protected]
Expand All @@ -10,6 +10,10 @@ LICENSE= gnu-gpl-v2 OR gnu-gpl-v3

DEPENDS+= R-zoo>=1.7.12:../../math/R-zoo

# Packages suggested but not available:
# 'timeSeries', 'timeDate', 'tseries', 'chron', 'fts', 'tis', 'RUnit'


USE_LANGUAGES+= c fortran

.include "../../math/R/Makefile.extension"
Expand Down
10 changes: 5 additions & 5 deletions math/R-xts/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.10 2019/07/31 20:39:14 brook Exp $
$NetBSD: distinfo,v 1.11 2021/06/06 15:12:59 mef Exp $

SHA1 (R/xts_0.11-2.tar.gz) = 6da46e0ef460bcd45b7913a18179074b6443dae5
RMD160 (R/xts_0.11-2.tar.gz) = 78cd00f608fbda7df93017b1b54b5068c30cf0b0
SHA512 (R/xts_0.11-2.tar.gz) = d8c2008d9e91dbbaa66564040383ebc135bfd9cd05a7d2bb43e585484ad50695d67d9e51a611c159d77f6887ddc2677f26b9479c63ec2f139c7fb9c84842ddae
Size (R/xts_0.11-2.tar.gz) = 537024 bytes
SHA1 (R/xts_0.12.1.tar.gz) = a6d7d51851fbb99faf965d04cebd1e72febe8f05
RMD160 (R/xts_0.12.1.tar.gz) = b7924812705d7255b88c8ac13613b1c0640b35ec
SHA512 (R/xts_0.12.1.tar.gz) = ede6128a3222e8979a5dc2786c08b28061d3c475343b9124f866ac8b5bb84763db41ec56b8d158afb5db6396bdec43aadda9bba1929e6eba6b0f33d14efda94d
Size (R/xts_0.12.1.tar.gz) = 517875 bytes

0 comments on commit c234259

Please sign in to comment.