forked from NetBSD/pkgsrc
-
Notifications
You must be signed in to change notification settings - Fork 51
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
### 3.10.9 ### Fixed - Fix `int` serialization on 32-bit Python 3.8, 3.9, 3.10. This was introduced in 3.10.8. ### 3.10.8 ### Changed - `int` serialization no longer chains `OverflowError` to the the `__cause__` attribute of `orjson.JSONEncodeError` when range exceeded. - Compatibility with CPython 3.14 alpha 1. - Improve performance.
- Loading branch information
Showing
3 changed files
with
67 additions
and
85 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,41 +1,37 @@ | ||
# $NetBSD: cargo-depends.mk,v 1.4 2024/08/10 08:02:45 adam Exp $ | ||
# $NetBSD: cargo-depends.mk,v 1.5 2024/10/22 08:02:10 wiz Exp $ | ||
|
||
CARGO_CRATE_DEPENDS+= arrayvec-0.7.4 | ||
CARGO_CRATE_DEPENDS+= arrayvec-0.7.6 | ||
CARGO_CRATE_DEPENDS+= associative-cache-2.0.0 | ||
CARGO_CRATE_DEPENDS+= autocfg-1.3.0 | ||
CARGO_CRATE_DEPENDS+= beef-0.5.2 | ||
CARGO_CRATE_DEPENDS+= bytecount-0.6.8 | ||
CARGO_CRATE_DEPENDS+= castaway-0.2.3 | ||
CARGO_CRATE_DEPENDS+= cc-1.1.8 | ||
CARGO_CRATE_DEPENDS+= cc-1.1.31 | ||
CARGO_CRATE_DEPENDS+= cfg-if-1.0.0 | ||
CARGO_CRATE_DEPENDS+= chrono-0.4.34 | ||
CARGO_CRATE_DEPENDS+= compact_str-0.8.0 | ||
CARGO_CRATE_DEPENDS+= crunchy-0.2.2 | ||
CARGO_CRATE_DEPENDS+= encoding_rs-0.8.34 | ||
CARGO_CRATE_DEPENDS+= gimli-0.30.0 | ||
CARGO_CRATE_DEPENDS+= half-2.4.1 | ||
CARGO_CRATE_DEPENDS+= itoa-1.0.11 | ||
CARGO_CRATE_DEPENDS+= itoap-1.0.1 | ||
CARGO_CRATE_DEPENDS+= libc-0.2.155 | ||
CARGO_CRATE_DEPENDS+= jiff-0.1.13 | ||
CARGO_CRATE_DEPENDS+= libc-0.2.161 | ||
CARGO_CRATE_DEPENDS+= memchr-2.7.4 | ||
CARGO_CRATE_DEPENDS+= no-panic-0.1.30 | ||
CARGO_CRATE_DEPENDS+= num-traits-0.2.19 | ||
CARGO_CRATE_DEPENDS+= once_cell-1.19.0 | ||
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.86 | ||
CARGO_CRATE_DEPENDS+= pyo3-build-config-0.22.2 | ||
CARGO_CRATE_DEPENDS+= pyo3-ffi-0.22.2 | ||
CARGO_CRATE_DEPENDS+= quote-1.0.36 | ||
CARGO_CRATE_DEPENDS+= rustversion-1.0.17 | ||
CARGO_CRATE_DEPENDS+= once_cell-1.20.2 | ||
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.88 | ||
CARGO_CRATE_DEPENDS+= quote-1.0.37 | ||
CARGO_CRATE_DEPENDS+= rustversion-1.0.18 | ||
CARGO_CRATE_DEPENDS+= ryu-1.0.18 | ||
CARGO_CRATE_DEPENDS+= serde-1.0.205 | ||
CARGO_CRATE_DEPENDS+= serde_derive-1.0.205 | ||
CARGO_CRATE_DEPENDS+= serde_json-1.0.122 | ||
CARGO_CRATE_DEPENDS+= simdutf8-0.1.4 | ||
CARGO_CRATE_DEPENDS+= serde-1.0.210 | ||
CARGO_CRATE_DEPENDS+= serde_derive-1.0.210 | ||
CARGO_CRATE_DEPENDS+= serde_json-1.0.131 | ||
CARGO_CRATE_DEPENDS+= shlex-1.3.0 | ||
CARGO_CRATE_DEPENDS+= simdutf8-0.1.5 | ||
CARGO_CRATE_DEPENDS+= smallvec-1.13.2 | ||
CARGO_CRATE_DEPENDS+= static_assertions-1.1.0 | ||
CARGO_CRATE_DEPENDS+= syn-2.0.72 | ||
CARGO_CRATE_DEPENDS+= syn-2.0.79 | ||
CARGO_CRATE_DEPENDS+= target-lexicon-0.12.16 | ||
CARGO_CRATE_DEPENDS+= unicode-ident-1.0.12 | ||
CARGO_CRATE_DEPENDS+= unicode-ident-1.0.13 | ||
CARGO_CRATE_DEPENDS+= unwinding-0.2.2 | ||
CARGO_CRATE_DEPENDS+= version_check-0.9.5 | ||
CARGO_CRATE_DEPENDS+= xxhash-rust-0.8.12 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters