Skip to content

Commit

Permalink
cups-filters: Update to 1.27.4
Browse files Browse the repository at this point in the history
pkgsrc changes:
 - Remove patches/patch-configure: applied uptsream
 - Convert the CHECK_PORTABILITY_SKIP to a REPLACE_BASH: it is more consistent
   with other REPLACE_BASHes (there are several files that are not installed
   then) and complaining about `==' test(1) operator in a bash script is
   not correct.

Changes:
1.27.4
------
- libcupsfilters, cups-browsed: Fix memory issues in
  ppdgenerator and cups-browsed (Pull request #226).
- pdftops: Mention cups-filters README, CUPS README in debug
  log (Pull request #225).
- pdftopdf, gstoraster, foomatic-rip: Use "-dSAFER"
  Ghostscript option, instead of the deprecated
  "-dPARANOIDSAFER" (Pull request #224).
- Build System: Replace '==' in configure.ac test with '=', as
  the former is a bashism (Pull request #222).

1.27.3
------
- cups-browsed: Allow sharing local queues pointing to remote
  CUPS queues and re-sharing printers discovered via
  BrowsePoll by default, using
  AllowResharingRemoteCUPSPrinters and
  NewBrowsePollQueuesShared directives in cups-browsed.conf
  (Issue #101, Pull request #218).
- driverless: Correctly unlink temporary file when generating
  PPD file (Pull request #220).
- cups-browsed: Fixed memory leaks (Pull request #219).
- foomatic-rip: PDF page count side-loads the PDF file to
  count the pages in, so it cannot be run in -dSAFER mode. Run
  even in -dNOSAFER mode to override the -dSAFER default of
  newer Ghostscript versions. This should not cause a security
  problem as we do not take an input file which could do
  arbitrary side-loads but we run hard-coded PostScript
  commands instead (Issue #216).
- libfontembed: Add checks to the test programs to not
  segfault if the test font file is not found (Pull request
  #214).
- Build System: Let ./configure fail if the supplied test font
  file path (or the default) does not exist (Pull request
  #214), also use the "find" command to find the test font
  file DejaVuSans.ttf under /usr/share/fonts, as every
  distribution has it somewhere else.

1.27.2
------
- foomatic-rip: In some PostScript input files it was possible
  that option settings did not get inserted or lines inserted
  on the wron place (Issue #208, Pull request #210).
- foomatic-rip: For the PDF page count call Ghostscript in
  sandbox mode and fix pointer arithmetics (Pull request
  #212).
- foomatic-rip: Zero-page-job handling changes made the last
  page of PostScript files not printed, also turning one-page
  jobs into zero-page jobs (Issue #200, Issue #206, Issue
  #208, Pull request #209, Pull request #210, Pull request
  #211).
- cups-browsed: check_printer_with_option() function:
  Initialize the value, add further checks, freeing memory and
  stop allocating magic numbers (Pull request #204).
- cups-browsed: Additional checks against crashes in the
  is_local_hostname() function (Ubuntu bug #1863716)

1.27.1
------
- libcupsfilters: Let the PPD generator not put any dashes
  into the PPD option and choice names when translating them
  from IPP attribute names, to avoid that on the
  back-translation by CUPS no double-dashes are
  generated. This broke paper tray selections with tray names
  like "tray-1", "tray-2", ... (Issue #192, Issue #201, Debian
  bug #949315).
- foomatic-rip: Fixed segfault when PRINTER environment
  variable is not supplied.
- pdftopdf, pdftops, gstoraster, gstopdf, gstopxl,
  rastertoescpx, rastertopclx, foomatic-rip: Handle zero-page
  jobs (Issue #117, Pull request #196, Pull request #197, Pull
  request #198, Pull request #200).
- texttopdf: Added support for CJK (double-width) fonts (Issue
  #135, Pull request #199).
- cups-browsed: Switched default for "CreateIPPPrinterQueues"
  from "local-only" to "All". The configure script options
  "--enable-auto-setup-local-only" and
  "--enable-auto-setup-driverless-only" can be used to change
  this default (Debian bug #921252).
- rastertoescpx: Fixed wrong freeing of a buffer.
- pdftops: Added options "crop-to-fit" and "fill" to the
  pdftopdf options which the pstops called by pdftops should
  not apply a second time.
- pdftops: Added missing "-sstdout=%stderr" to Ghostscript
  command line, to assure that all messages are redirected to
  stderr and do not mix up with the output data.

1.27.0
------
- cups-browsed: Eliminate the use of the local CUPS daemon's
  (the CUPS we are attached to) port number completely, so
  that for attaching to an arbitrary local CUPS daemon
  listening on an arbitrary port (or even not listening on
  localhost at all) it is enough to tell cups-browsed the
  domain socket the CUPS daemon is listening on.
- cups-browsed, libcupsfilters: Identify DNS-SD-reported
  printers as of the local CUPS daemon via UUID and not via
  the port on which the local CUPS is listening, as we do not
  always have this port available.
- cups-browsed: Leave the port for legacy CUPS browsing and
  broadcasting on 631, do not use a possible alternative port
  of the CUPS we are attached to. The legacy CUPS servers we
  communicate with are always remote ones.
- libcupsfilters: in the PPD generator prioritize
  print-color-mode-supported against
  pwg-raster-document-type-supported (Issue #186, Pull request
  #188)
- rastertopdf, rastertops, texttopdf, pdftoraster,
  mupdftoraster: Handle zero-page jobs, corrections on
  zero-page job handling (Issue #117)
- cups-browsed: When restarting after a crash make sure that
  local queue names have same upper/lower case as before.
- cups-browsed: Small code improvements to reduce crash
  probability.

1.26.2
------
- cups-browsed: Added crash guards to avoid crashes in case
  the dummy printer entry for a deleted master entry is used.
- cups-browsed: Set the port of the local CUPS daemon to be
  used according to the IPP_PORT environment variable.
- cups-browsed: Eliminated the use of the cupsGetPPD2()
  function of libcups completely, also the remaining calls
  in the record_printer_options() and update_cups_queues()
  functions, the former causing incomplete recording of
  option settings and the latter use of CUPS-generated
  PPDs not working when CUPS is running on a non-standard
  port.
- cups-browsed: Eliminated the use of the cupsGetPPD2()
  function of libcups in queue_overwritten(). The function
  actually loads the queue's PPD file if the queue is on a
  local CUPS on port 631. Due to a bug the function fails if
  an alternative port is used. This lets queue_overwritten()
  always assume that the PPD got removed and therefore the
  queue got overwritten. So queues got released from
  cups-browsed if it was printed on them or if they were
  supposed to be removed on shutdown.
- foomatic-rip: Fixed compilation with -fno-common. Starting
  from the upcoming GCC 10, the default of the -fcommon option
  will change to -fno-common. This causes compilation errors
  in foomatic-rip due to missing "external" declarations.
  (Pull request #184).
  • Loading branch information
iamleot committed May 2, 2020
1 parent 3238189 commit eda1034
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 27 deletions.
9 changes: 3 additions & 6 deletions print/cups-filters/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.135 2020/04/07 13:55:16 ryoon Exp $
# $NetBSD: Makefile,v 1.136 2020/05/02 12:04:44 leot Exp $

DISTNAME= cups-filters-1.26.1
PKGREVISION= 5
DISTNAME= cups-filters-1.27.4
CATEGORIES= print
MASTER_SITES= http://openprinting.org/download/cups-filters/
EXTRACT_SUFX= .tar.xz
Expand Down Expand Up @@ -40,12 +39,10 @@ REPLACE_BASH+= filter/braille/drivers/generic/brftoembosser.in
REPLACE_BASH+= filter/braille/drivers/index/imageubrltoindexv3.in
REPLACE_BASH+= filter/braille/drivers/index/imageubrltoindexv4.in
REPLACE_BASH+= filter/braille/drivers/index/textbrftoindexv3.in
REPLACE_BASH+= filter/braille/filters/brftopagedbrf.in
REPLACE_BASH+= filter/braille/filters/imagetobrf.in
REPLACE_BASH+= filter/braille/filters/texttobrf.in

# Not included in package, and explicitly bash.
CHECK_PORTABILITY_SKIP+= filter/braille/filters/brftopagedbrf.in

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "Darwin"
Expand Down
11 changes: 5 additions & 6 deletions print/cups-filters/distinfo
Original file line number Diff line number Diff line change
@@ -1,10 +1,9 @@
$NetBSD: distinfo,v 1.66 2020/01/03 13:26:08 leot Exp $
$NetBSD: distinfo,v 1.67 2020/05/02 12:04:44 leot Exp $

SHA1 (cups-filters-1.26.1.tar.xz) = a1e761dfe7b5e18c4c0ba112eb0985a6ef9790cc
RMD160 (cups-filters-1.26.1.tar.xz) = fbd91623c3aa5035385bbd22433470c8b33fdcbb
SHA512 (cups-filters-1.26.1.tar.xz) = 0aaad7ceeb763aa3da4f961c99f85c0200cf4fcd071617506daf97dad4914de38fa744ae692b6fbc1d00a0eec62b4de4d7c5f865fd0e32e4155ab3f0c5a21ede
Size (cups-filters-1.26.1.tar.xz) = 1489804 bytes
SHA1 (patch-configure) = b55dc7dc22008351c396374aceb88d2be293d179
SHA1 (cups-filters-1.27.4.tar.xz) = 516af8c9f06b50e60f90605fa3edafb485382322
RMD160 (cups-filters-1.27.4.tar.xz) = 84f8a383910475b0944ef2a979315e2559b0954b
SHA512 (cups-filters-1.27.4.tar.xz) = 8005e94bb6b06d0a15fa4dfd8455d0bc67418478bf517e205af1c8c0018681a97ae9ea486db07570050ebeeb7f63f75319a8fe012c112c6d16c0941299eaa50e
Size (cups-filters-1.27.4.tar.xz) = 1493860 bytes
SHA1 (patch-filter_gstoraster.c) = 4eef8d91d8ca26a5a874e29885b836e9670d9e5d
SHA1 (patch-filter_mupdftoraster.c) = 81a06cbb3be9a7fd3e797a2effa5ef0aecfc2621
SHA1 (patch-fontembed_test__pdf.c) = 5ffb13a59ed4d860a3ae4355e364059973715290
Expand Down
15 changes: 0 additions & 15 deletions print/cups-filters/patches/patch-configure

This file was deleted.

0 comments on commit eda1034

Please sign in to comment.