forked from NetBSD/pkgsrc
-
Notifications
You must be signed in to change notification settings - Fork 51
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
1.4.0 - 2023.01.21 * - BREAKING CONFIG CHANGE - the position of the passwd_feedback in slim is now relative to the screen, not the panel. This is now consistent with slimlock and with the session and other messages. * The selected session is now preserved over failed logins * When testing themes with the -p option, the size of the window can now be specified, and the theme is previewed correctly for that size. * On exit from theme test, the "test message" now reports user and session * Failed login feedback is now disabled by default or if position negative * Applied some Devuan patches - Set the XDG_SESSION_CLASS. This fixes Gentoo bug #727544 - failure to register sessions with elogind in some instances. The (incorrect) bug note in the man page has therefore been removed again. - Use $DISPLAY instead of hardcoding :0.0 in sessionstart/stop commands - No longer always builds slimlock if using PAM - it must be explicitly enabled - Fixed formatting in slimlock man page - A couple of typos fixed in strings * Updated the README and encoded in UTF-8 * Corrected the handling of the -n / -nodaemon option so that it doesn't swallow the next option if given as -n * Bug fixes in slimlock - The active entry is for password, so show the password prompt, not the username one - Don't react to F1, as it isn't appropriate and used to blank the screen - Keep it all on one screen even when the WM hasn't set a "primary" for RandR purposes * Fix ticket #4 - the config parser now works properly. Previously it got confused by option names that were substrings of other option names * Themes with "background_style color" no longer need a redundant image file to make them work. - This needed a bit of a re-write of the image handling, which also improves efficiency * New default theme - the old one is retained as "original" * Some general documentation improvements (man pages, comments in example files) 1.3.9 - 2022.11.18 * Changed the handling of the "auth failed" message in DM mode so that it remains on display until a key is pressed. * Added a command line option to specify the configuration file * Allow the logfile to be specified as "stderr" to write to stderr Also now writes all log messages to stderr if they are printed before the log file is open, including when using the -p option. * Added a configuration option to retain the user name if authentication fails (which is probably more helpful if you just mistype your password) * Applied a modified version of the "wait for the X server" patch from guix * No longer unnecessarily re-opens an already open X display interface. Similarly removed a redundant "get root window" call * Deleted some unused member variables and methods. Various other internal clean-up * Reverted the install location definition for the configuration file, as the CMAKE_INSTALL_SYSCONFDIR wasn't right * Added a "bug" note to the man page, for the reliance on sessreg, which causes occasional misbehaviour for some people. 1.3.8 - 2022.03.01 * Fixed some bugs listed on bugs.gentoo.org: 832303 - failed to build with clang, Invalid suffix on string literal 580458 - open fd on /var/log/slim.log passed to session * Fixed handling of log stream so that all the code uses the same instance * Handle return values from calls, to clean up warn-unused-result warnings * Fixed "sessions" config option (the earlier patch was incomplete) * Several QA improvements * Updated cmake config - use standard install paths, don't force options 1.3.7 - 2022.01.30 * Imported several bug fixes from the Gentoo package: libslim-cmake-fixes disable-ck-for-systemd reinstate sessions config option as an alternative to sessiondir systemd session compatibility remove zlib dependency envcpy-bad-pointer-arithmetic patch add-missing-libgen_h wrong comparison for XCreateGC error return (GCC11 needs it fixed!) * Fixed a bug in handling expired user accounts with PAM * Show a message on login failure (using the same method as slimlock)
- Loading branch information
abs
committed
Jun 14, 2023
1 parent
c3356b2
commit f44b745
Showing
7 changed files
with
100 additions
and
91 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,7 @@ | ||
SLiM (Simple Login Manager) is a graphical login manager for X11. | ||
It aims to be simple, fast and independent from the various | ||
desktop environments. | ||
SLiM is based on latest stable release of Login.app by Per Liden. | ||
SLiM is an acronym for Simple Login Manager. SLiM is lightweight | ||
and easy to configure, and requires minimal dependencies - none of | ||
the GNOME or KDE desktop environments or their corresponding | ||
toolkits. | ||
|
||
It thus contributes to a lightweight system for users who also like | ||
to use lightweight desktops such as IceWM, Xfce, Openbox, or Fluxbox. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,12 +1,11 @@ | ||
# $NetBSD: Makefile,v 1.17 2023/03/25 22:54:22 gutteridge Exp $ | ||
# $NetBSD: Makefile,v 1.18 2023/06/14 09:43:50 abs Exp $ | ||
|
||
DISTNAME= slim-1.3.6 | ||
PKGREVISION= 11 | ||
DISTNAME= slim-1.4.0 | ||
CATEGORIES= x11 | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=slim.berlios/} | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=slim-fork/} | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= https://github.com/iwamatsu/slim | ||
HOMEPAGE= https://slim-fork.sourceforge.io/ | ||
COMMENT= Simple login manager | ||
LICENSE= gnu-gpl-v2 | ||
|
||
|
@@ -32,14 +31,21 @@ SUBST_VARS.paths+= X11BASE | |
|
||
.include "../../mk/bsd.prefs.mk" | ||
|
||
# Possible todos | ||
# - Install adjusted xinitrc.sample which uses ~/.xsession if present | ||
# - Adjust CMakeLists.txt to find fontconfig | ||
|
||
post-install: | ||
${INSTALL_DATA} ${WRKSRC}/xinitrc.sample ${DESTDIR}${PREFIX}/share/examples/slim | ||
|
||
.if ${OPSYS} == "NetBSD" | ||
# Drops the ability to pass theme as %session param to .xinitrc | ||
SLIM_LOGIN_CMD?= /bin/sh - /etc/X11/xdm/Xsession | ||
SLIM_XSERVER_ARGUMENTS?=vt05 -noretro | ||
SLIM_LOGIN_CMD?= /bin/sh - /etc/X11/xdm/Xsession | ||
SLIM_XSERVER_ARGUMENTS?= vt05 -noretro -nolisten tcp | ||
.else | ||
DEPENDS+= bash-[0-9]*:../../shells/bash | ||
SLIM_LOGIN_CMD?= @PREFIX@/bin/bash -login ~/.xinitrc %session | ||
SLIM_XSERVER_ARGUMENTS?= | ||
DEPENDS+= bash-[0-9]*:../../shells/bash | ||
SLIM_LOGIN_CMD?= @PREFIX@/bin/bash -login ~/.xinitrc %session | ||
SLIM_XSERVER_ARGUMENTS?= -nolisten tcp | ||
.endif | ||
|
||
CONF_FILES+= share/examples/slim/slim.conf \ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,13 @@ | ||
@comment $NetBSD: PLIST,v 1.1 2018/05/18 14:51:17 youri Exp $ | ||
@comment $NetBSD: PLIST,v 1.2 2023/06/14 09:43:50 abs Exp $ | ||
bin/slim | ||
lib/libslim.so | ||
lib/libslim.so.${PKGVERSION} | ||
man/man1/slim.1 | ||
man/man1/slimlock.1 | ||
share/examples/slim/slim.conf | ||
share/examples/slim/xinitrc.sample | ||
share/slim/themes/default/background.jpg | ||
share/slim/themes/default/panel.png | ||
share/slim/themes/default/slim.theme | ||
share/slim/themes/original/background.jpg | ||
share/slim/themes/original/panel.png | ||
share/slim/themes/original/slim.theme |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,7 @@ | ||
$NetBSD: distinfo,v 1.10 2023/03/15 13:39:16 abs Exp $ | ||
$NetBSD: distinfo,v 1.11 2023/06/14 09:43:50 abs Exp $ | ||
|
||
BLAKE2s (slim-1.3.6.tar.gz) = 45b562196e1253a1a341b821c866f4d0db9c747c73fda215cac52097af77ed2c | ||
SHA512 (slim-1.3.6.tar.gz) = 345b1dee5d6f0c3716dfa7c5c16274adbf18586bdaaa6af4f310e24c5a61f79a297ffac921a5ba545523317e9fe120916df226c36b9c9b49c2ac9c1ca21dee0c | ||
Size (slim-1.3.6.tar.gz) = 232547 bytes | ||
SHA1 (patch-CMakeLists.txt) = 8eaeba1bb48bcdb825a3809feefb62b7182fde42 | ||
SHA1 (patch-panel.cpp) = 51f87c90214cbc55fd5628f7d852d6287d763903 | ||
SHA1 (patch-slim.conf) = 3bc88e703e002801e757c27c778b0e79f0cb0ad6 | ||
BLAKE2s (slim-1.4.0.tar.gz) = 92dcdcdab082c4aaaeecffe62b2dba939959fef4983232df0b2258542927b48e | ||
SHA512 (slim-1.4.0.tar.gz) = 2ef38d39e2d5186f9342161d99740b0c8cd87f234deaf550ca1528c9a61c052d26123c7da26f4a0a5e658d01cb200b115cf7879d349ed51a6e8c729ee3fdf77f | ||
Size (slim-1.4.0.tar.gz) = 530318 bytes | ||
SHA1 (patch-CMakeLists.txt) = c922b9cbf6293d21a0f9ab9b3bf2c54c657a2879 | ||
SHA1 (patch-slim.conf) = d2b80700fd4227c350d63eba02e093099437ab25 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,61 +1,45 @@ | ||
$NetBSD: patch-CMakeLists.txt,v 1.2 2018/10/08 17:46:07 abs Exp $ | ||
$NetBSD: patch-CMakeLists.txt,v 1.3 2023/06/14 09:43:50 abs Exp $ | ||
|
||
Fix build. | ||
|
||
--- CMakeLists.txt.orig 2013-10-01 22:38:05.000000000 +0000 | ||
--- CMakeLists.txt.orig 2023-01-21 19:54:32.000000000 +0000 | ||
+++ CMakeLists.txt | ||
@@ -21,11 +21,11 @@ set(SLIM_VERSION_MINOR "3") | ||
set(SLIM_VERSION_PATCH "6") | ||
@@ -23,7 +23,7 @@ set(SLIM_VERSION_PATCH "0") | ||
set(SLIM_VERSION "${SLIM_VERSION_MAJOR}.${SLIM_VERSION_MINOR}.${SLIM_VERSION_PATCH}") | ||
|
||
-set(CMAKE_INSTALL_PREFIX "/usr/local" CACHE PATH "Installation Directory") | ||
+set(CMAKE_INSTALL_PREFIX "@PREFIX@" CACHE PATH "Installation Directory") | ||
set(PKGDATADIR "${CMAKE_INSTALL_PREFIX}/share/slim") | ||
set(PKGDATADIR "${CMAKE_INSTALL_FULL_DATADIR}/slim") | ||
-set(SYSCONFDIR "/etc") | ||
+set(SYSCONFDIR "@PKG_SYSCONFDIR@") | ||
set(LIBDIR "/lib") | ||
-set(MANDIR "${CMAKE_INSTALL_PREFIX}/share/man") | ||
+set(MANDIR "${CMAKE_INSTALL_PREFIX}/man") | ||
|
||
set(SLIM_DEFINITIONS) | ||
if(${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR | ||
@@ -104,13 +104,13 @@ find_package(PNG REQUIRED) | ||
find_package(ZLIB REQUIRED) | ||
@@ -96,13 +96,13 @@ find_package(JPEG REQUIRED) | ||
find_package(PNG REQUIRED) | ||
|
||
# Fontconfig | ||
-set(FONTCONFIG_DIR ${CMAKE_MODULE_PATH}) | ||
-find_package(FONTCONFIG REQUIRED) | ||
-if(FONTCONFIG_FOUND) | ||
- message("\tFontConfig Found") | ||
- target_link_libraries(${PROJECT_NAME} ${FONTCONFIG_LIBRARY}) | ||
- target_link_libraries(slim ${FONTCONFIG_LIBRARY}) | ||
- include_directories(${FONTCONFIG_INCLUDE_DIR}) | ||
-endif(FONTCONFIG_FOUND) | ||
+#set(FONTCONFIG_DIR ${CMAKE_MODULE_PATH}) | ||
+#find_package(FONTCONFIG REQUIRED) | ||
+#if(FONTCONFIG_FOUND) | ||
+ #message("\tFontConfig Found") | ||
+ #target_link_libraries(${PROJECT_NAME} ${FONTCONFIG_LIBRARY}) | ||
+ #include_directories(${FONTCONFIG_INCLUDE_DIR}) | ||
+# message("\tFontConfig Found") | ||
+# target_link_libraries(slim ${FONTCONFIG_LIBRARY}) | ||
+# include_directories(${FONTCONFIG_INCLUDE_DIR}) | ||
+#endif(FONTCONFIG_FOUND) | ||
|
||
# PAM | ||
if(USE_PAM) | ||
@@ -221,7 +221,9 @@ endif(BUILD_SLIMLOCK) | ||
####### install | ||
# slim | ||
install(TARGETS slim RUNTIME DESTINATION bin) | ||
+if(BUILD_SLIMLOCK) | ||
install(TARGETS slimlock RUNTIME DESTINATION bin) | ||
+endif(BUILD_SLIMLOCK) | ||
@@ -235,7 +235,7 @@ endif (BUILD_SHARED_LIBS) | ||
install(FILES slim.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1) | ||
|
||
if (BUILD_SHARED_LIBS) | ||
set_target_properties(libslim PROPERTIES | ||
@@ -238,7 +240,7 @@ endif (BUILD_SHARED_LIBS) | ||
install(FILES slim.1 DESTINATION ${MANDIR}/man1/) | ||
install(FILES slimlock.1 DESTINATION ${MANDIR}/man1/) | ||
# configure | ||
# configure - in theory we should use CMAKE_INSTALL_SYSCONFDIR but that doesn't work | ||
-install(FILES slim.conf DESTINATION ${SYSCONFDIR}) | ||
+install(FILES slim.conf DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples/slim/) | ||
# systemd service file | ||
if (${CMAKE_SYSTEM_NAME} MATCHES "Linux") | ||
install(FILES slim.service DESTINATION ${LIBDIR}/systemd/system) | ||
|
||
# systemd service file - commented out as broken - not all Linux uses systemd! | ||
#if (${CMAKE_SYSTEM_NAME} MATCHES "Linux") |
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters