Skip to content

Commit

Permalink
universe/py3-pyproject-hooks: update gpep517 build to use hidden dirs…
Browse files Browse the repository at this point in the history
… for dist/testenv

[ commit 083eb89bb9af1e5570429a2580c0c2d5d136be4c ]

this works around issues like pytest-dev/pytest#3151
  • Loading branch information
nekopsykose authored and konfetka1989 committed Jul 31, 2023
1 parent c1347c6 commit 216b707
Showing 1 changed file with 4 additions and 4 deletions.
8 changes: 4 additions & 4 deletions universe/py3-pyproject-hooks/APKBUILD
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
pkgname=py3-pyproject-hooks
pkgver=1.0.0
pkgrel=2
pkgrel=3
pkgdesc="Low-level library for calling build-backends in 'pyproject.toml'-based project"
url="https://pyproject-hooks.readthedocs.io/"
arch="noarch"
Expand All @@ -14,19 +14,19 @@ builddir="$srcdir/pyproject-hooks-$pkgver"

build() {
gpep517 build-wheel \
--wheel-dir dist \
--wheel-dir .dist \
--output-fd 3 3>&1 >&2
}

check() {
python3 -m venv --clear --without-pip --system-site-packages test-env
test-env/bin/python3 -m installer dist/pyproject_hooks*.whl
test-env/bin/python3 -m installer .dist/pyproject_hooks*.whl
test-env/bin/python3 -m pytest
}

package() {
python3 -m installer -d "$pkgdir" \
dist/pyproject_hooks*.whl
.dist/pyproject_hooks*.whl
}

sha512sums="
Expand Down

0 comments on commit 216b707

Please sign in to comment.