Skip to content

Commit

Permalink
gdal: Autospec creation for update from version 3.8.2 to version 3.8.3
Browse files Browse the repository at this point in the history
Even Rouault (21):
      CI: macosx: fix issue with lxml
      infback9: fix various build issues with clang 17
      autotest: updates to support libpng 1.6.40 and other library updates of fedora:rawhide
      gdalbuildvrt: in -separate mode, only use ComplexSource if needed
      OGRArrowArrayHelper::SetBoolOn(): fix wrong bit shift computation (affects ogr2ogr from GPKG/FlatGeoBuf to something else) (fixes #8998)
      Add specific documentation section about AWS IMDS (and fix typo)
      AWS S3: add explicit error message when IMDS fails and we know we are on EC2
      CoordinateTransformation::TransformBounds(): fix polar stereographic (including pole) to Web Mercator (fixes #8996)
      VRTDerivedRasterBand::IRasterIO(): fix potential multiplication overflow
      HOWTO-RELEASE: add signing
      Prepare for GDAL 3.8.3
      NEWS.md: fix version numbers
      VRTDerivedRasterBand::IRasterIO(): fix warning on 32-bit builds
      ogr2ogr: do not use ArrowArray interface if -clipsrc, -clipdst, -gcp or -wrapdateline are specified (fixes #9013)
      GPKG: disable by default multi-threaded ArrowArray interface. Make it opt-in with the OGR_GPKG_NUM_THREADS config option
      GPKG: fix build with sqlite 3.36.x (fixes #9021)
      Prepare for GDAL 3.8.3 RC2
      Internal libjson: resync random_seed.c with upstream, and use getrandom() implementation when available (fixes #9024)
      GPKG: fix multi-threaded ArrowArray interface and re-enable it by default
      jpegxl.py: make test pass with latest libjxl master
      Prepare for GDAL 3.8.3 RC3

Martin Daly (1):
      gdal2ogr.c: added missing close bracket
  • Loading branch information
fenrus75 committed Jan 9, 2024
1 parent 25505cc commit cb7e673
Show file tree
Hide file tree
Showing 8 changed files with 20 additions and 16 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := gdal
URL = https://download.osgeo.org/gdal/3.8.2/gdal-3.8.2.tar.xz
URL = https://download.osgeo.org/gdal/CURRENT/gdal-3.8.3.tar.xz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion buildreq_cache
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
3.8.2
3.8.3
pcre-dev
pcre2-dev
pkgconfig(libpng)
Expand Down
Binary file added gdal-3.8.3.tar.xz.sig
Binary file not shown.
22 changes: 11 additions & 11 deletions gdal.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,13 +3,13 @@
# Generated by: autospec.py
# Using build pattern: cmake
# autospec version: v3
# autospec commit: c1050fe
# autospec commit: ab27b0e
#
Name : gdal
Version : 3.8.2
Release : 110
URL : https://download.osgeo.org/gdal/3.8.2/gdal-3.8.2.tar.xz
Source0 : https://download.osgeo.org/gdal/3.8.2/gdal-3.8.2.tar.xz
Version : 3.8.3
Release : 111
URL : https://download.osgeo.org/gdal/CURRENT/gdal-3.8.3.tar.xz
Source0 : https://download.osgeo.org/gdal/CURRENT/gdal-3.8.3.tar.xz
Summary : Geospatial Data Abstraction Library
Group : Development/Tools
License : Apache-2.0 BSD-3-Clause ISC LGPL-2.0 Libpng MIT Public-Domain
Expand Down Expand Up @@ -144,15 +144,15 @@ python3 components for the gdal package.


%prep
%setup -q -n gdal-3.8.2
cd %{_builddir}/gdal-3.8.2
%setup -q -n gdal-3.8.3
cd %{_builddir}/gdal-3.8.3

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1703109645
export SOURCE_DATE_EPOCH=1704815315
mkdir -p clr-build
pushd clr-build
export GCC_IGNORE_WERROR=1
Expand Down Expand Up @@ -211,7 +211,7 @@ FFLAGS="$CLEAR_INTERMEDIATE_FFLAGS"
FCFLAGS="$CLEAR_INTERMEDIATE_FCFLAGS"
ASFLAGS="$CLEAR_INTERMEDIATE_ASFLAGS"
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS"
export SOURCE_DATE_EPOCH=1703109645
export SOURCE_DATE_EPOCH=1704815315
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/gdal
cp %{_builddir}/gdal-%{version}/LICENSE.TXT %{buildroot}/usr/share/package-licenses/gdal/51134147a0feb5f2a47099a8b81d33f1099dfd21 || :
Expand Down Expand Up @@ -592,9 +592,9 @@ rm -f %{buildroot}*/usr/etc/bash_completion.d/gdal-bash-completion.sh

%files lib
%defattr(-,root,root,-)
/V3/usr/lib64/libgdal.so.34.3.8.2
/V3/usr/lib64/libgdal.so.34.3.8.3
/usr/lib64/libgdal.so.34
/usr/lib64/libgdal.so.34.3.8.2
/usr/lib64/libgdal.so.34.3.8.3

%files license
%defattr(0644,root,root,0755)
Expand Down
4 changes: 3 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = gdal
url = https://download.osgeo.org/gdal/3.8.2/gdal-3.8.2.tar.xz
url = https://download.osgeo.org/gdal/CURRENT/gdal-3.8.3.tar.xz
archives =
giturl = https://github.com/OSGeo/gdal.git
domain =
Expand Down Expand Up @@ -59,6 +59,8 @@ server = false
skip_tests = false
# add .so files to the lib package instead of dev
so_to_lib = false
# configure build for apx
use_apx = true
# configure build for avx2
use_avx2 = true
# configure build for avx512
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
110
111
2 changes: 2 additions & 0 deletions symbols
Original file line number Diff line number Diff line change
Expand Up @@ -2282,6 +2282,7 @@ libgdal.so.34:_ZN10GDALDriver19DefaultCopyMetadataEP11GDALDatasetS1_PKPKcS5_
libgdal.so.34:_ZN10GDALDriver19VectorTranslateFromEPKcP11GDALDatasetPKS1_PFidS1_PvES6_
libgdal.so.34:_ZN10GDALDriver22CanVectorTranslateFromEPKcP11GDALDatasetPKS1_PPPc
libgdal.so.34:_ZN10GDALDriver22CreateMultiDimensionalEPKcPKS1_S3_
libgdal.so.34:_ZN10GDALDriver24QuietDeleteForCreateCopyEPKcP11GDALDataset
libgdal.so.34:_ZN10GDALDriver33DefaultCreateCopyMultiDimensionalEP11GDALDatasetS1_bPKPKcPFidS3_PvES6_
libgdal.so.34:_ZN10GDALDriver4OpenEP12GDALOpenInfob
libgdal.so.34:_ZN10GDALDriver6CreateEPKciii12GDALDataTypePKS1_
Expand Down Expand Up @@ -6119,6 +6120,7 @@ libgdal.so.34:_ZTv0_n72_NK26GDALMDArrayRegularlySpaced13GetDimensionsEv
libgdal.so.34:_ZTv0_n80_NK19GDALAttributeString11GetDataTypeEv
libgdal.so.34:_ZTv0_n80_NK20GDALAttributeNumeric11GetDataTypeEv
libgdal.so.34:_ZTv0_n80_NK26GDALMDArrayRegularlySpaced11GetDataTypeEv
libgdal.so.34:_ZZNSt9once_flag18_Prepare_executionC4IZSt9call_onceIZN18OSRPJContextHolderC4EvEUlvE_JEEvRS_OT_DpOT0_EUlvE_EERS6_ENUlvE_4_FUNEv
libgdal.so.34:json_object_new_double_with_precision
libgdal.so.34:json_object_new_double_with_significant_figures
libgdal.so.34:sqlite3_extension_init
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
9f36a7949961e17e6b7eac827b586505932065cd/gdal-3.8.2.tar.xz
2d8f815c92d93c914838181e2d656f224fea3411/gdal-3.8.3.tar.xz

0 comments on commit cb7e673

Please sign in to comment.