Skip to content
This repository has been archived by the owner on May 30, 2023. It is now read-only.

Commit

Permalink
sys-fs/squashfs-tools-ng: new package
Browse files Browse the repository at this point in the history
it's from a1845d3da41dd018a1c5c4659c40b1ea8dcc6f79

Signed-off-by: Mathieu Tortuyaux <[email protected]>
  • Loading branch information
tormath1 committed Feb 28, 2023
1 parent 1fd02f6 commit e94aaf3
Show file tree
Hide file tree
Showing 5 changed files with 171 additions and 0 deletions.
2 changes: 2 additions & 0 deletions sys-fs/squashfs-tools-ng/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
DIST squashfs-tools-ng-1.1.4.tar.xz 1311684 BLAKE2B b976ac223d57919958e0ad04c989e0a9cf2837e1c7ef1e1962069b4796b492fe2fc99c59d1e38b11e380226dc2fc4b2e25e29244635a32d03d0667f2b3ef1d7f SHA512 10e0bebd70de686862f1473588cdbf922ad766c86b64ebd4d6338fd863f862fe0c9374950fa54a197c0f02021c63943cf1ba57ebb7f93a4188e68e2b25b4a800
DIST squashfs-tools-ng-1.2.0.tar.xz 586992 BLAKE2B ca20e4e01033b4dfa3ada2abd0f618305cb3f49f683863d36ea93679c2cfc0c396ee209c3254fa318d30cb2c4c000c3634d4b625212842cabae0a5e53b4a2bdc SHA512 0c52890a92e2aee928db3e2407c087703d331e9dd8cba1b58ef44fe78cdd7ed1523e9b0485f7da83ad77423ffdccaf392a2b752ad948d62a5f1b5e600b523070
14 changes: 14 additions & 0 deletions sys-fs/squashfs-tools-ng/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Matt Turner</name>
</maintainer>
<use>
<flag name="tools">Build the gensquashfs, rdsquashfs, sqfs2tar, sqfsdiff, and tar2sqfs tools</flag>
</use>
<upstream>
<remote-id type="github">AgentD/squashfs-tools-ng</remote-id>
</upstream>
</pkgmetadata>
51 changes: 51 additions & 0 deletions sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="A new set of tools for working with SquashFS images"
HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi

LICENSE="LGPL-3+ tools? ( GPL-3+ )"
SLOT="0"
IUSE="lz4 +lzma lzo selinux +tools zstd"

DEPEND="
sys-libs/zlib:=
lz4? ( app-arch/lz4:= )
lzma? ( app-arch/xz-utils:= )
lzo? ( dev-libs/lzo:= )
selinux? ( sys-libs/libselinux:= )
zstd? ( app-arch/zstd:= )
"
RDEPEND="${DEPEND}"

src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf
}

src_configure() {
local myconf=(
--disable-static
$(use_with lz4)
$(use_with lzo)
$(use_with selinux)
$(use_with tools)
$(use_with lzma xz)
$(use_with zstd)
)
econf "${myconf[@]}"
}

src_install() {
default
find "${D}" -name "*.la" -delete || die
}
52 changes: 52 additions & 0 deletions sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DESCRIPTION="A new set of tools for working with SquashFS images"
HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi

LICENSE="LGPL-3+ BSD-2 MIT tools? ( GPL-3+ )"
SLOT="0"
IUSE="lz4 +lzma lzo selinux +tools zstd"

DEPEND="
app-arch/bzip2:=
sys-libs/zlib:=
lz4? ( app-arch/lz4:= )
lzma? ( app-arch/xz-utils )
lzo? ( dev-libs/lzo:2 )
selinux? ( sys-libs/libselinux:= )
zstd? ( app-arch/zstd:= )
"
RDEPEND="${DEPEND}"

src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf
}

src_configure() {
local myconf=(
--disable-static
$(use_with lz4)
$(use_with lzo)
$(use_with selinux)
$(use_with tools)
$(use_with lzma xz)
$(use_with zstd)
)
econf "${myconf[@]}"
}

src_install() {
default
find "${D}" -name "*.la" -delete || die
}
52 changes: 52 additions & 0 deletions sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DESCRIPTION="A new set of tools for working with SquashFS images"
HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
if [[ ${PV} = 9999* ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi

LICENSE="LGPL-3+ BSD-2 MIT tools? ( GPL-3+ )"
SLOT="0"
IUSE="lz4 +lzma lzo selinux +tools zstd"

DEPEND="
app-arch/bzip2:=
sys-libs/zlib:=
lz4? ( app-arch/lz4:= )
lzma? ( app-arch/xz-utils )
lzo? ( dev-libs/lzo:2 )
selinux? ( sys-libs/libselinux:= )
zstd? ( app-arch/zstd:= )
"
RDEPEND="${DEPEND}"

src_prepare() {
default
[[ ${PV} == "9999" ]] && eautoreconf
}

src_configure() {
local myconf=(
--disable-static
$(use_with lz4)
$(use_with lzo)
$(use_with selinux)
$(use_with tools)
$(use_with lzma xz)
$(use_with zstd)
)
econf "${myconf[@]}"
}

src_install() {
default
find "${D}" -name "*.la" -delete || die
}

0 comments on commit e94aaf3

Please sign in to comment.