-
Notifications
You must be signed in to change notification settings - Fork 2
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
merged: funtoo-overlay: 57ad3677f6a893e3624627fb3682c0bd337c8520
- Loading branch information
box
committed
Mar 21, 2015
1 parent
b88dd69
commit 5d6c1da
Showing
30,658 changed files
with
36,104 additions
and
37,009 deletions.
The diff you're trying to view is too large. We only load the first 3000 changed files.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/haskell-updater-1.2.9.ebuild,v 1.2 2015/03/20 23:09:07 slyfox Exp $ | ||
|
||
EAPI=5 | ||
|
||
CABAL_FEATURES="bin nocabaldep" | ||
inherit eutils haskell-cabal | ||
|
||
DESCRIPTION="Rebuild Haskell dependencies in Gentoo" | ||
HOMEPAGE="http://haskell.org/haskellwiki/Gentoo#haskell-updater" | ||
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris" | ||
IUSE="" | ||
|
||
DEPEND=">=dev-lang/ghc-6.12.1" | ||
|
||
# Need a lower version for portage to get --keep-going | ||
RDEPEND="|| ( >=sys-apps/portage-2.1.6 | ||
sys-apps/pkgcore | ||
sys-apps/paludis )" | ||
|
||
src_prepare() { | ||
if use prefix; then | ||
sed -i -e "s,/var/db/pkg,${EPREFIX}&,g" \ | ||
"${S}/Distribution/Gentoo/Packages.hs" || die | ||
|
||
sed -i -e 's,"/","'"${EPREFIX}"'/",g' \ | ||
"${S}/Distribution/Gentoo/GHC.hs" || die | ||
fi | ||
} | ||
|
||
src_configure() { | ||
cabal_src_configure \ | ||
--bindir="${EPREFIX}/usr/sbin" \ | ||
--constraint="Cabal == $(cabal-version)" | ||
} | ||
|
||
src_install() { | ||
cabal_src_install | ||
|
||
dodoc TODO | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST logstash-forwarder-0.4.0.tar.gz 35189 SHA256 d930cd33747b2826c7358238a25e690324751d1b098e7c00de1357944766b3c3 SHA512 1f89b065d1b26a6f5b18da6215bdaed5a312af12fa721835f5e1a77248dd67f398f5af08b5d93c0c4c5ef9623eb1ddb58449b52039c0db0241d5ca61872102ef WHIRLPOOL 7715c723f8b8712b5cccc1e678017b2d733f243ea936d312ab31938fba73934a66d552656516bc72b65a3541945401f99463d8346fdf6a00372e9b3a0ed67655 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
LOGSTASH_FORWARDER_ARGS="-quiet -syslog=true" |
63 changes: 63 additions & 0 deletions
63
app-admin/logstash-forwarder/files/logstash-forwarder.initd
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,63 @@ | ||
#!/sbin/runscript | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Header: /var/cvsroot/gentoo-x86/app-admin/logstash-forwarder/files/logstash-forwarder.initd,v 1.2 2015/03/20 19:43:26 aidecoe Exp $ | ||
|
||
create_tmpdir() { | ||
local tmpdir="$(mktemp -d -p /tmp logstash-forwarder.XXXXXXXXXX)" | ||
|
||
chown logstash:logstash "$tmpdir" || return 1 | ||
chmod 0750 "$tmpdir" || return 1 | ||
|
||
echo "$tmpdir" | ||
} | ||
|
||
remove_tmpdir() { | ||
local d='' | ||
local tmpdir='' | ||
|
||
for d in /tmp/logstash-forwarder.??????????; do | ||
[[ -e $d ]] || return 0 | ||
[[ -d $d ]] || continue | ||
|
||
if ! [[ $tmpdir ]]; then | ||
tmpdir="$d" | ||
else | ||
# There are more directories like that, so better keep them all. | ||
return 1 | ||
fi | ||
done | ||
|
||
rm -r "$tmpdir" | ||
} | ||
|
||
start() { | ||
local config_file=/etc/logstash-forwarder/logstash-forwarder.conf | ||
local tmpdir="$(create_tmpdir)" | ||
|
||
if ! [[ -d $tmpdir ]]; then | ||
eend 1 "Failed to create tmp directory for logstash-forwarder" | ||
return 1 | ||
fi | ||
|
||
ebegin "Starting logstash-forwarder" | ||
start-stop-daemon --start --exec /usr/bin/logstash-forwarder \ | ||
--make-pidfile --pidfile /run/logstash-forwarder.pid \ | ||
--background --wait 100 --chdir "$tmpdir" \ | ||
--user logstash --group logstash \ | ||
-- -config="${config_file}" ${LOGSTASH_FORWARDER_ARGS} | ||
eend $? | ||
} | ||
|
||
stop() { | ||
ebegin "Stopping logstash-forwarder" | ||
start-stop-daemon --stop --exec /usr/bin/logstash-forwarder \ | ||
--pidfile /run/logstash-forwarder.pid --user logstash --group logstash | ||
local rc=$? | ||
|
||
if ! remove_tmpdir; then | ||
ewarn "Failed to remove logstash-forwarder tmp directory" | ||
fi | ||
|
||
eend $rc | ||
} |
44 changes: 44 additions & 0 deletions
44
app-admin/logstash-forwarder/logstash-forwarder-0.4.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Header: /var/cvsroot/gentoo-x86/app-admin/logstash-forwarder/logstash-forwarder-0.4.0.ebuild,v 1.1 2015/03/20 16:06:41 aidecoe Exp $ | ||
|
||
EAPI=5 | ||
|
||
inherit user | ||
|
||
DESCRIPTION="Collects logs locally in preparation for processing elsewhere" | ||
HOMEPAGE="https://github.com/elastic/logstash-forwarder" | ||
SRC_URI="https://github.com/elastic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
DEPEND="dev-lang/go" | ||
RDEPEND="${DEPEND}" | ||
|
||
pkg_setup() { | ||
enewgroup logstash | ||
enewuser logstash -1 -1 -1 logstash | ||
} | ||
|
||
src_install() { | ||
dobin "${PN}" | ||
dodir "/etc/${PN}" | ||
dodoc "${PN}".conf.example CHANGELOG README.md | ||
newconfd "${FILESDIR}/${PN}.confd" "${PN}" | ||
newinitd "${FILESDIR}/${PN}.initd" "${PN}" | ||
} | ||
|
||
pkg_postinst() { | ||
if ! [[ -e /etc/${PN}/${PN}.conf ]]; then | ||
elog "Before starting logstash-forwarder create config file at" | ||
elog | ||
elog " /etc/${PN}/${PN}.conf" | ||
elog | ||
elog "See example in /usr/share/doc/${PVR} directory. You can remove" | ||
elog "-quiet from logstash-forward arguments in /etc/conf.d/${PN} to" | ||
elog "until you get working configuration. Search syslog for errors." | ||
fi | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer> | ||
<email>[email protected]</email> | ||
<name>Amadeusz Żołnowski</name> | ||
</maintainer> | ||
<longdescription lang="en"> | ||
logstash-forwarder is a lightweight replacement for logstash when you | ||
only need to collect logs locally in preparation for processing | ||
elsewhere. It is written in Go and uses not much memory. For | ||
transmission lumberjack protocol is used. It is is secure, low | ||
latency, low resource usage, and reliable. | ||
</longdescription> | ||
</pkgmetadata> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,4 @@ | ||
[Desktop Entry] | ||
Encoding=UTF-8 | ||
Type=Application | ||
Exec=vmware-user-suid-wrapper | ||
Name=VMware User Agent | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,9 @@ | ||
[Desktop Entry] | ||
Encoding=UTF-8 | ||
Type=Application | ||
Name=Rox-Filer | ||
Comment=The Rox File Manager | ||
Icon=rox | ||
Exec=rox | ||
Categories=GTK;Utility;System;Core; | ||
Categories=GTK;System;Core; | ||
StartupNotify=true | ||
Terminal=false |
Oops, something went wrong.