Skip to content

Commit

Permalink
Merge Official Source
Browse files Browse the repository at this point in the history
Signed-off-by: Tianling Shen <[email protected]>
  • Loading branch information
1715173329 committed Jan 4, 2025
2 parents 374b3da + c50de92 commit af9b9cd
Show file tree
Hide file tree
Showing 11 changed files with 32 additions and 32 deletions.
22 changes: 11 additions & 11 deletions libs/boost/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,13 +11,13 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=boost
PKG_VERSION:=1.86.0
PKG_SOURCE_VERSION:=1_86_0
PKG_VERSION:=1.87.0
PKG_SOURCE_VERSION:=1_87_0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://boostorg.jfrog.io/artifactory/main/release/$(PKG_VERSION)/source/
PKG_HASH:=1bed88e40401b2cb7a1f76d4bab499e352fa4d0c5f31c0dbae64e24d34d7513b
PKG_HASH:=af57be25cb4c4f4b413ed692fe378affb4352ea50fbe294a11ef548f4d527d89

PKG_MAINTAINER:=Carlos M. Ferreira <[email protected]>
PKG_LICENSE:=BSL-1.0
Expand All @@ -42,7 +42,7 @@ define Package/boost/Default
endef

define Package/boost/description
This package provides the Boost v1.86.0 libraries.
This package provides the Boost v1.87.0 libraries.
Boost is a set of free, peer-reviewed, portable C++ source libraries.

This package provides the following run-time libraries:
Expand Down Expand Up @@ -80,7 +80,7 @@ This package provides the following run-time libraries:
- wave

There are many more header-only libraries supported by Boost.
See more at http://www.boost.org/doc/libs/1_86_0/
See more at http://www.boost.org/doc/libs/1_87_0/
endef

PKG_BUILD_DEPENDS:=boost/host
Expand Down Expand Up @@ -339,7 +339,7 @@ endef
$(eval $(call DefineBoostLibrary,atomic,system))
$(eval $(call DefineBoostLibrary,charconv,,,,libquadmath))
$(eval $(call DefineBoostLibrary,chrono,system))
$(eval $(call DefineBoostLibrary,cobalt,system container))
$(eval $(call DefineBoostLibrary,cobalt,system container context date_time))
$(eval $(call DefineBoostLibrary,container))
$(eval $(call DefineBoostLibrary,context,chrono system,,!boost-context-exclude))
$(eval $(call DefineBoostLibrary,contract,system))
Expand All @@ -349,15 +349,15 @@ $(eval $(call DefineBoostLibrary,date_time))
$(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,!boost-fiber-exclude))
$(eval $(call DefineBoostLibrary,filesystem,system atomic))
$(eval $(call DefineBoostLibrary,graph,regex))
$(eval $(call DefineBoostLibrary,iostreams,,,,zlib liblzma libbz2 libzstd))
$(eval $(call DefineBoostLibrary,iostreams,system random regex,,,zlib liblzma libbz2 libzstd))
$(eval $(call DefineBoostLibrary,json,container))
$(eval $(call DefineBoostLibrary,locale,system chrono thread,,,icu))
$(eval $(call DefineBoostLibrary,log,system chrono date_time thread filesystem regex))
$(eval $(call DefineBoostLibrary,math))
$(eval $(call DefineBoostLibrary,math, container random system))
#$(eval $(call DefineBoostLibrary,mpi,,)) # OpenMPI does no exist in OpenWRT at this time.
$(eval $(call DefineBoostLibrary,nowide))
$(eval $(call DefineBoostLibrary,program_options))
$(eval $(call DefineBoostLibrary,python3,,,,python3-base))
$(eval $(call DefineBoostLibrary,python3,container graph,,,python3-base))
$(eval $(call DefineBoostLibrary,random,system))
$(eval $(call DefineBoostLibrary,regex,,,,icu))
$(eval $(call DefineBoostLibrary,serialization))
Expand All @@ -367,8 +367,8 @@ $(eval $(call DefineBoostLibrary,system))
$(eval $(call DefineBoostLibrary,thread,system chrono atomic))
$(eval $(call DefineBoostLibrary,timer,chrono))
$(eval $(call DefineBoostLibrary,type_erasure,chrono system thread))
$(eval $(call DefineBoostLibrary,url))
$(eval $(call DefineBoostLibrary,wave,date_time thread filesystem))
$(eval $(call DefineBoostLibrary,url, system))
$(eval $(call DefineBoostLibrary,wave,date_time thread filesystem container serialization))

include $(INCLUDE_DIR)/host-build.mk

Expand Down
6 changes: 3 additions & 3 deletions libs/hwloc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=hwloc
PKG_VERSION:=2.10.0
PKG_VERSION:=2.11.2
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.open-mpi.org/release/$(PKG_NAME)/v2.10
PKG_HASH:=0305dd60c9de2fbe6519fe2a4e8fdc6d3db8de574a0ca7812b92e80c05ae1392
PKG_SOURCE_URL:=https://download.open-mpi.org/release/$(PKG_NAME)/v2.11
PKG_HASH:=f7f88fecae067100f1a1a915b658add0f4f71561259482910a69baea22fe8409

PKG_MAINTAINER:=W. Michael Petullo <[email protected]>
PKG_LICENSE:=BSD-3-Clause
Expand Down
4 changes: 2 additions & 2 deletions libs/libgcrypt/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=libgcrypt
PKG_VERSION:=1.10.3
PKG_VERSION:=1.11.0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.gnupg.org/ftp/gcrypt/libgcrypt/
PKG_HASH:=8b0870897ac5ac67ded568dcfadf45969cfa8a6beb0fd60af2a9eadc2a3272aa
PKG_HASH:=09120c9867ce7f2081d6aaa1775386b98c2f2f246135761aae47d81f58685b9c

PKG_MAINTAINER:=W. Michael Petullo <[email protected]>
PKG_CPE_ID:=cpe:/a:gnupg:libgcrypt
Expand Down
4 changes: 2 additions & 2 deletions libs/libgpg-error/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=libgpg-error
PKG_VERSION:=1.49
PKG_VERSION:=1.51
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://mirrors.dotsrc.org/gcrypt/libgpg-error \
http://ring.ksc.gr.jp/archives/net/gnupg/libgpg-error \
https://www.gnupg.org/ftp/gcrypt/libgpg-error
PKG_HASH:=8b79d54639dbf4abc08b5406fb2f37e669a2dec091dd024fb87dd367131c63a9
PKG_HASH:=be0f1b2db6b93eed55369cdf79f19f72750c8c7c39fc20b577e724545427e6b2

PKG_MAINTAINER:=W. Michael Petullo <[email protected]>
PKG_LICENSE:=LGPL-2.1-or-later
Expand Down
2 changes: 1 addition & 1 deletion libs/libgpg-error/patches/001-cross-compile-fix.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,21 @@ AM_SILENT_RULES
@@ -76,6 +76,21 @@ AM_SILENT_RULES
AC_CANONICAL_HOST
AB_INIT

Expand Down
4 changes: 2 additions & 2 deletions libs/libsoup3/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=libsoup3
PKG_VERSION:=3.4.4
PKG_VERSION:=3.6.1
PKG_RELEASE:=1

PKG_SOURCE:=libsoup-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNOME/libsoup/$(basename $(PKG_VERSION))
PKG_HASH:=291c67725f36ed90ea43efff25064b69c5a2d1981488477c05c481a3b4b0c5aa
PKG_HASH:=ceb1f1aa2bdd73b2cd8159d3998c96c55ef097ef15e4b4f36029209fa18af838
PKG_BUILD_DIR:=$(BUILD_DIR)/libsoup-$(PKG_VERSION)

PKG_MAINTAINER:=W. Michael Petullo <[email protected]>
Expand Down
4 changes: 2 additions & 2 deletions libs/openldap/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=openldap
PKG_VERSION:=2.6.8
PKG_VERSION:=2.6.9
PKG_RELEASE:=2

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://mirror.eu.oneandone.net/software/openldap/openldap-release/ \
https://www.openldap.org/software/download/OpenLDAP/openldap-release/
PKG_HASH:=48969323e94e3be3b03c6a132942dcba7ef8d545f2ad35401709019f696c3c4e
PKG_HASH:=2cb7dc73e9c8340dff0d99357fbaa578abf30cc6619f0521972c555681e6b2ff
PKG_LICENSE:=OLDAP-2.8
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:openldap:openldap
Expand Down
4 changes: 2 additions & 2 deletions libs/vips/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=vips
PKG_VERSION:=8.15.2
PKG_VERSION:=8.16.0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
PKG_HASH:=a2ab15946776ca7721d11cae3215f20f1f097b370ff580cd44fc0f19387aee84
PKG_HASH:=6eca46c6ba5fac86224fd69007741012b0ea1f9aa1fcb9256b0cbc2faf768563

PKG_MAINTAINER:=W. Michael Petullo <[email protected]>
PKG_LICENSE:=LGPL-2.1-or-later
Expand Down
6 changes: 3 additions & 3 deletions net/tgt/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,12 +4,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=tgt
PKG_VERSION:=1.0.93
PKG_RELEASE:=2
PKG_VERSION:=1.0.94
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/fujita/tgt/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=587e4a160a46851d049dbf07b0fae7e269ed1c3f58ad3fbbdbe45c9bb36093db
PKG_HASH:=bb2a49130dd83310268af2eaa435f43be61d92a5bd22b9d360f7c751947f37b9

PKG_MAINTAINER:=Maxim Storchak <[email protected]>
PKG_LICENSE:=GPL-2.0-only
Expand Down
4 changes: 2 additions & 2 deletions utils/fuse-overlayfs/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=fuse-overlayfs
PKG_VERSION:=1.13
PKG_VERSION:=1.14
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/containers/fuse-overlayfs/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=96d10344921d5796bcba7a38580ae14a53c4e60399bb90b238ac5a10b3bb65b2
PKG_HASH:=0779d1ee8fbb6adb48df40e54efa9c608e1d7bbd844800a4c32c110d5fcbe9f2

PKG_MAINTAINER:=W. Michael Petullo <[email protected]>
PKG_LICENSE:=GPL-3.0-or-later
Expand Down
4 changes: 2 additions & 2 deletions utils/lsof/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk

PKG_NAME:=lsof
PKG_VERSION:=4.99.3
PKG_VERSION:=4.99.4
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lsof-org/lsof/releases/download/$(PKG_VERSION)
PKG_HASH:=86428a8881b0d1147a52058e853c775b83d794f0da685d549b2bfd07063ed1cd
PKG_HASH:=0c444e2dabec14ad146cbb7f5b52b5ab4976728402ff348d9feced9ad9740c66
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)

PKG_MAINTAINER:=Maxim Storchak <[email protected]>
Expand Down

0 comments on commit af9b9cd

Please sign in to comment.