Skip to content

Commit

Permalink
Update ruby-rspec-rails to 2.12.0.
Browse files Browse the repository at this point in the history
### 2.12.0 / 2012-11-12
[full changelog](http://github.com/rspec/rspec-rails/compare/v2.11.4...2.12.0)

Enhancements

* Support validation contexts when using `#errors_on` (Woody Peterson)
* Include RequestExampleGroup in groups in spec/api

Bug fixes

* Add `should` and `should_not` to `CollectionProxy` (Rails 3.1+) and
  `AssociationProxy` (Rails 3.0).  (Myron Marston)
* `controller.controller_path` is set correctly for view specs in Rails 3.1+.
  (Andy Lindeman)
* Generated specs support module namespacing (e.g., in a Rails engine).
  (Andy Lindeman)
* `render` properly infers the view to be rendered in Rails 3.0 and 3.1
  (John Firebaugh)
* AutoTest mappings involving config/ work correctly (Brent J. Nordquist)
* Failures message for `be_new_record` are more useful (Andy Lindeman)

### 2.11.4 / 2012-10-14
[full changelog](http://github.com/rspec/rspec-rails/compare/v2.11.0...v2.11.4)

Capybara-2.0 integration support:

* include RailsExampleGroup in spec/features (necessary when there is no AR)
* include Capybara::DSL and Capybara::RSpecMatchers in spec/features

See [https://github.com/jnicklas/capybara/pull/809](https://github.com/jnicklas/capybara/pull/809)
and [http://rubydoc.info/gems/rspec-rails/file/Capybara.md](http://rubydoc.info/gems/rspec-rails/file/Capybara.md)
for background.

2.11.1, .2, .3 were yanked due to errant documentation.
  • Loading branch information
taca committed Dec 16, 2012
1 parent b697471 commit 60ca0b7
Show file tree
Hide file tree
Showing 3 changed files with 16 additions and 8 deletions.
8 changes: 5 additions & 3 deletions devel/ruby-rspec-rails/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.7 2012/09/04 14:52:19 taca Exp $
# $NetBSD: Makefile,v 1.8 2012/12/16 16:46:14 taca Exp $

DISTNAME= rspec-rails-2.11.0
DISTNAME= rspec-rails-2.12.0
CATEGORIES= devel

MAINTAINER= [email protected]
Expand All @@ -11,7 +11,9 @@ LICENSE= mit
DEPENDS+= ${RUBY_ACTIVESUPPORT_DEPENDS}
DEPENDS+= ${RUBY_ACTIONPACK_DEPENDS}
DEPENDS+= ${RUBY_RAILTIES_DEPENDS}
DEPENDS+= ${RUBY_PKGPREFIX}-rspec>=2.11.0<2.12:../../devel/ruby-rspec
DEPENDS+= ${RUBY_PKGPREFIX}-rspec-core>=2.12.0<2.13:../../devel/ruby-rspec-core
DEPENDS+= ${RUBY_PKGPREFIX}-rspec-expectations>=2.12.0<2.13:../../devel/ruby-rspec-expectations
DEPENDS+= ${RUBY_PKGPREFIX}-rspec-mocks>=2.12.0<2.13:../../devel/ruby-rspec-mocks

RUBY_RAILS_SUPPORTED=

Expand Down
8 changes: 7 additions & 1 deletion devel/ruby-rspec-rails/PLIST
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
@comment $NetBSD: PLIST,v 1.6 2012/09/04 14:52:19 taca Exp $
@comment $NetBSD: PLIST,v 1.7 2012/12/16 16:46:14 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/.document
${GEM_LIBDIR}/.yardopts
${GEM_LIBDIR}/Capybara.md
${GEM_LIBDIR}/Changelog.md
${GEM_LIBDIR}/License.txt
${GEM_LIBDIR}/README.md
Expand All @@ -19,6 +20,7 @@ ${GEM_LIBDIR}/features/controller_specs/bypass_rescue.feature
${GEM_LIBDIR}/features/controller_specs/controller_spec.feature
${GEM_LIBDIR}/features/controller_specs/isolation_from_views.feature
${GEM_LIBDIR}/features/controller_specs/render_views.feature
${GEM_LIBDIR}/features/feature_specs/feature_spec.feature
${GEM_LIBDIR}/features/helper_specs/helper_spec.feature
${GEM_LIBDIR}/features/mailer_specs/url_helpers.feature
${GEM_LIBDIR}/features/matchers/README.md
Expand Down Expand Up @@ -76,6 +78,7 @@ ${GEM_LIBDIR}/lib/rspec/rails.rb
${GEM_LIBDIR}/lib/rspec/rails/adapters.rb
${GEM_LIBDIR}/lib/rspec/rails/example.rb
${GEM_LIBDIR}/lib/rspec/rails/example/controller_example_group.rb
${GEM_LIBDIR}/lib/rspec/rails/example/feature_example_group.rb
${GEM_LIBDIR}/lib/rspec/rails/example/helper_example_group.rb
${GEM_LIBDIR}/lib/rspec/rails/example/mailer_example_group.rb
${GEM_LIBDIR}/lib/rspec/rails/example/model_example_group.rb
Expand All @@ -85,6 +88,7 @@ ${GEM_LIBDIR}/lib/rspec/rails/example/routing_example_group.rb
${GEM_LIBDIR}/lib/rspec/rails/example/view_example_group.rb
${GEM_LIBDIR}/lib/rspec/rails/extensions.rb
${GEM_LIBDIR}/lib/rspec/rails/extensions/active_record/base.rb
${GEM_LIBDIR}/lib/rspec/rails/extensions/active_record/proxy.rb
${GEM_LIBDIR}/lib/rspec/rails/fixture_support.rb
${GEM_LIBDIR}/lib/rspec/rails/matchers.rb
${GEM_LIBDIR}/lib/rspec/rails/matchers/be_a_new.rb
Expand Down Expand Up @@ -116,6 +120,7 @@ ${GEM_LIBDIR}/spec/rspec/rails/assertion_adapter_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/configuration_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/deprecations_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/example/controller_example_group_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/example/feature_example_group_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/example/helper_example_group_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/example/mailer_example_group_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/example/model_example_group_spec.rb
Expand All @@ -129,6 +134,7 @@ ${GEM_LIBDIR}/spec/rspec/rails/matchers/be_a_new_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/matchers/be_new_record_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/matchers/be_routable_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/matchers/errors_on_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/matchers/has_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/matchers/have_rendered_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/matchers/redirect_to_spec.rb
${GEM_LIBDIR}/spec/rspec/rails/matchers/relation_match_array_spec.rb
Expand Down
8 changes: 4 additions & 4 deletions devel/ruby-rspec-rails/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.6 2012/09/04 14:52:19 taca Exp $
$NetBSD: distinfo,v 1.7 2012/12/16 16:46:14 taca Exp $

SHA1 (rspec-rails-2.11.0.gem) = b9b1111ad23a64c92fbfe15c394edb130d32c230
RMD160 (rspec-rails-2.11.0.gem) = 8f0cf7a0312848d77fc5179e7707f6cadacf556d
Size (rspec-rails-2.11.0.gem) = 61440 bytes
SHA1 (rspec-rails-2.12.0.gem) = 5bde65c5c6ffcfbe0db1ba69589b8852032ca8ef
RMD160 (rspec-rails-2.12.0.gem) = d50ba26b797f57ded5f5baab33cf8001f2629456
Size (rspec-rails-2.12.0.gem) = 66048 bytes

0 comments on commit 60ca0b7

Please sign in to comment.