This repository has been archived by the owner on Sep 26, 2020. It is now read-only.
-
Notifications
You must be signed in to change notification settings - Fork 3
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
[x11-libs/kimageannotator] Update ebuild syntax (fix: ksnip/kImageAnn…
- Loading branch information
Showing
3 changed files
with
155 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
EBUILD kimageannotator-0.1.0_p20190225.ebuild 712 BLAKE2B 144e31ec388b2adbebc948ddd5d3d1f46a4d2b8f2d4f20284efefed8f803b993c022555f62a9beed185a9960c4c0535a3fe3de7136389064812aa552df540f7a SHA512 df0a659a72b6983bfa291612cef37733300b4ac817d0cd2c17fa679acc2cc2cffc78bb79d655fc5f097e073adbddd821c010bfc612284c82dc96af63baf9b21d | ||
AUX kimageannotator-0.1.0_p20190226_set_blurRadiusWidget_to_nullptr_in_constructor.patch 4265 BLAKE2B b661bc0ee923225e20f22a56bb68231790716ce455f3c279df9a80b65f8ab6960433d30368ac5a7eef22ddfd74a9ed872f8ed187c48c8f93d307b3ff823abdca SHA512 b511adbe2d47ff3c8d22b42cc7d712e4c55ebeefc4d79a738ab07e170e0aa4850bc1b6cc049fcb74d384e58f8b6442752dfc50a0664bda9fd0634cbfa5ceadbe | ||
EBUILD kimageannotator-0.1.0_p20190226.ebuild 902 BLAKE2B 3f32ae1c7ad1b52ebaba515ed06506e627e77b68f3a569dcb4de066c116efc161473e37524a7cdafc78334f17f59e8120cca605979503b29a6b4a45ab960f6a7 SHA512 b72eb5fc256dc79b7fdf811b6d3399d9b52d6f1b72a952be9140c1e595f761fcad4d4a86f3a84b33d90cf744e6a198d20b9137ba1f35ce5bdd9586e164a7fb49 | ||
MISC metadata.xml 250 BLAKE2B 9a35b9f97dcc586e1b779c3a8851f66dff74d0b2b562ce47abdd5d7c6a3bb5a9a2de53b2b0db741ffdf1b30077b5fc71280a960b623210a70c95e8b0ad7193c3 SHA512 9fe7eab542aaca9f9ce755836d10e228acafc035e573d58a52365b4e013508a243f292cae31acc0c8421edf907580f3fddb44bde39cba7f2f13f23c845a97e62 |
147 changes: 147 additions & 0 deletions
147
...iles/kimageannotator-0.1.0_p20190226_set_blurRadiusWidget_to_nullptr_in_constructor.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,147 @@ | ||
diff --git a/src/gui/annotator/WidgetConfigurator.cpp b/src/gui/annotator/WidgetConfigurator.cpp | ||
index 9108c6b..e574b98 100644 | ||
--- a/src/gui/annotator/WidgetConfigurator.cpp | ||
+++ b/src/gui/annotator/WidgetConfigurator.cpp | ||
@@ -29,6 +29,7 @@ WidgetConfigurator::WidgetConfigurator() | ||
mFillTypeWidget = nullptr; | ||
mFontSizeWidget = nullptr; | ||
mFirstNumberWidget = nullptr; | ||
+ mBlurRadiusWidget = nullptr; | ||
|
||
mCurrentTool = ToolTypes::Select; | ||
} | ||
@@ -85,13 +86,13 @@ void WidgetConfigurator::setBlurRadiusWidget(NumberPicker *widget) | ||
updateWidgets(); | ||
} | ||
|
||
-void WidgetConfigurator::updateWidgets() | ||
+void WidgetConfigurator::updateWidgets() const | ||
{ | ||
updateProperties(); | ||
updateVisibility(); | ||
} | ||
|
||
-void WidgetConfigurator::updateProperties() | ||
+void WidgetConfigurator::updateProperties() const | ||
{ | ||
switch (mCurrentTool) { | ||
case ToolTypes::Text: | ||
@@ -103,20 +104,7 @@ void WidgetConfigurator::updateProperties() | ||
} | ||
} | ||
|
||
-void WidgetConfigurator::setNoFillAndNoBorderEnabled(bool enabled) const | ||
-{ | ||
- if (mFillTypeWidget == nullptr) { | ||
- return; | ||
- } | ||
- | ||
- if (enabled) { | ||
- mFillTypeWidget->addNoFillAndNoBorderToList(); | ||
- } else { | ||
- mFillTypeWidget->removeNoFillAndNoBorderToList(); | ||
- } | ||
-} | ||
- | ||
-void WidgetConfigurator::updateVisibility() | ||
+void WidgetConfigurator::updateVisibility() const | ||
{ | ||
switch (mCurrentTool) { | ||
case ToolTypes::Select: | ||
@@ -201,48 +189,61 @@ void WidgetConfigurator::updateVisibility() | ||
} | ||
} | ||
|
||
-void WidgetConfigurator::setColorWidgetEnabled(bool enabled) | ||
+void WidgetConfigurator::setColorWidgetEnabled(bool enabled) const | ||
{ | ||
if (mColorWidget) { | ||
mColorWidget->setEnabled(enabled); | ||
} | ||
} | ||
|
||
-void WidgetConfigurator::setTextColorWidgetEnabled(bool enabled) | ||
+void WidgetConfigurator::setTextColorWidgetEnabled(bool enabled) const | ||
{ | ||
if (mTextColorWidget) { | ||
mTextColorWidget->setEnabled(enabled); | ||
} | ||
} | ||
|
||
-void WidgetConfigurator::setWidthWidgetEnabled(bool enabled) | ||
+void WidgetConfigurator::setWidthWidgetEnabled(bool enabled) const | ||
{ | ||
if (mWidthWidget) { | ||
mWidthWidget->setEnabled(enabled); | ||
} | ||
} | ||
|
||
-void WidgetConfigurator::setFillWidgetEnabled(bool enabled) | ||
+void WidgetConfigurator::setFillWidgetEnabled(bool enabled) const | ||
{ | ||
if (mFillTypeWidget) { | ||
mFillTypeWidget->setEnabled(enabled); | ||
} | ||
} | ||
|
||
-void WidgetConfigurator::setFontSizeWidgetEnabled(bool enabled) | ||
+void WidgetConfigurator::setFontSizeWidgetEnabled(bool enabled) const | ||
{ | ||
if (mFontSizeWidget) { | ||
mFontSizeWidget->setEnabled(enabled); | ||
} | ||
} | ||
|
||
-void WidgetConfigurator::setFirstNumberWidgetEnabled(bool enabled) | ||
+void WidgetConfigurator::setFirstNumberWidgetEnabled(bool enabled) const | ||
{ | ||
if (mFirstNumberWidget) { | ||
mFirstNumberWidget->setEnabled(enabled); | ||
} | ||
} | ||
|
||
+void WidgetConfigurator::setNoFillAndNoBorderEnabled(bool enabled) const | ||
+{ | ||
+ if (mFillTypeWidget == nullptr) { | ||
+ return; | ||
+ } | ||
+ | ||
+ if (enabled) { | ||
+ mFillTypeWidget->addNoFillAndNoBorderToList(); | ||
+ } else { | ||
+ mFillTypeWidget->removeNoFillAndNoBorderToList(); | ||
+ } | ||
+} | ||
+ | ||
void WidgetConfigurator::setBlurRadiusWidgetEnabled(bool enabled) const | ||
{ | ||
if (mBlurRadiusWidget) { | ||
diff --git a/src/gui/annotator/WidgetConfigurator.h b/src/gui/annotator/WidgetConfigurator.h | ||
index 4cd0587..eb938ee 100644 | ||
--- a/src/gui/annotator/WidgetConfigurator.h | ||
+++ b/src/gui/annotator/WidgetConfigurator.h | ||
@@ -54,15 +54,15 @@ class WidgetConfigurator | ||
NumberPicker *mFirstNumberWidget; | ||
NumberPicker *mBlurRadiusWidget; | ||
|
||
- void updateWidgets(); | ||
- void updateProperties(); | ||
- void updateVisibility(); | ||
- void setColorWidgetEnabled(bool enabled); | ||
- void setTextColorWidgetEnabled(bool enabled); | ||
- void setWidthWidgetEnabled(bool enabled); | ||
- void setFillWidgetEnabled(bool enabled); | ||
- void setFontSizeWidgetEnabled(bool enabled); | ||
- void setFirstNumberWidgetEnabled(bool enabled); | ||
+ void updateWidgets() const; | ||
+ void updateProperties() const; | ||
+ void updateVisibility() const; | ||
+ void setColorWidgetEnabled(bool enabled) const; | ||
+ void setTextColorWidgetEnabled(bool enabled) const; | ||
+ void setWidthWidgetEnabled(bool enabled) const; | ||
+ void setFillWidgetEnabled(bool enabled) const; | ||
+ void setFontSizeWidgetEnabled(bool enabled) const; | ||
+ void setFirstNumberWidgetEnabled(bool enabled) const; | ||
void setNoFillAndNoBorderEnabled(bool enabled) const; | ||
void setBlurRadiusWidgetEnabled(bool enabled) const; | ||
}; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters