Skip to content
This repository was archived by the owner on Jul 27, 2023. It is now read-only.

Commit

Permalink
update@20230706
Browse files Browse the repository at this point in the history
  • Loading branch information
github-actions[bot] committed Jul 6, 2023
1 parent 2561cf7 commit 0e8efc4
Show file tree
Hide file tree
Showing 8 changed files with 28 additions and 14 deletions.
2 changes: 1 addition & 1 deletion aliyundrive-webdav/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=aliyundrive-webdav
PKG_VERSION:=2.2.1
PKG_VERSION:=2.2.2
PKG_RELEASE:=1

PKG_LICENSE:=MIT
Expand Down
2 changes: 1 addition & 1 deletion luci-app-aliyundrive-webdav/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=luci-app-aliyundrive-webdav
PKG_VERSION:=2.2.1
PKG_VERSION:=2.2.2
PKG_RELEASE:=1
PKG_PO_VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)

Expand Down
2 changes: 1 addition & 1 deletion luci-app-dockerman/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ PKG_LICENSE:=AGPL-3.0
PKG_MAINTAINER:=lisaac <[email protected]> \
Florian Eckert <[email protected]>

PKG_VERSION:=v0.5.25
PKG_VERSION:=v0.5.26

include $(TOPDIR)/feeds/luci/luci.mk

Expand Down
11 changes: 10 additions & 1 deletion luci-app-dockerman/luasrc/model/cbi/dockerman/container.lua
Original file line number Diff line number Diff line change
Expand Up @@ -188,8 +188,17 @@ local start_stop_remove = function(m, cmd)
end
end

local c_color
if container_info.State.Status == 'running' then
c_color = 'green'
elseif container_info.State.Status == 'restarting' then
c_color = 'yellow'
else
c_color = 'red'
end

m=SimpleForm("docker",
translatef("Docker - Container (%s)", container_info.Name:sub(2)),
translatef("Docker - Container (<font color='%s'>%s</font>)", c_color, container_info.Name:sub(2)),
translate("On this page, the selected container can be managed."))
m.redirect = luci.dispatcher.build_url("admin/docker/containers")

Expand Down
1 change: 1 addition & 0 deletions luci-app-mosdns/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,7 @@ endef

define Package/$(PKG_NAME)/postinst
#!/bin/sh
[ ! -f /etc/openwrt_release ] && exit 0
[ -n "${IPKG_INSTROOT}" ] || {
sysctl -p /etc/sysctl.d/20-mosdns-buffer-increase.conf
exit 0
Expand Down
2 changes: 2 additions & 0 deletions luci-app-mosdns/root/etc/init.d/mosdns
Original file line number Diff line number Diff line change
Expand Up @@ -20,6 +20,8 @@
# along with this program. If not, see <https://www.gnu.org/licenses/>.
#

[ ! -f /etc/openwrt_release ] && exit 0

START=99
USE_PROCD=1

Expand Down
6 changes: 0 additions & 6 deletions luci-app-oaf/po/zh_Hans/oaf.po
Original file line number Diff line number Diff line change
Expand Up @@ -189,12 +189,6 @@ msgstr "网关模式"
msgid "Bypass Mode"
msgstr "旁路模式"

msgid "Bypass Mode"
msgstr "旁路模式"

msgid "Current version"
msgstr "当前版本"

msgid "Current version"
msgstr "当前版本"

Expand Down
16 changes: 12 additions & 4 deletions oaf/src/app_filter.c
Original file line number Diff line number Diff line change
Expand Up @@ -1156,25 +1156,31 @@ int af_send_msg_to_user(char *pbuf, uint16_t len)
struct sk_buff *nl_skb;
struct nlmsghdr *nlh;
int buf_len = OAF_EXTRA_MSG_BUF_LEN + len;
char *msg_buf = kmalloc(buf_len, GFP_KERNEL);
char *msg_buf = NULL;
struct af_msg_hdr *hdr = NULL;
char *p_data = NULL;
int ret;
if (len >= MAX_OAF_NL_MSG_LEN)
return -1;

memset(msg_buf, 0x0, sizeof(buf_len));
msg_buf = kmalloc(buf_len, GFP_KERNEL);
if (!msg_buf)
return -1;

memset(msg_buf, 0x0, buf_len);
nl_skb = nlmsg_new(len + sizeof(struct af_msg_hdr), GFP_ATOMIC);
if (!nl_skb)
{
return -1;
ret = -1;
goto fail;
}

nlh = nlmsg_put(nl_skb, 0, 0, OAF_NETLINK_ID, len + sizeof(struct af_msg_hdr), 0);
if (nlh == NULL)
{
nlmsg_free(nl_skb);
return -1;
ret = -1;
goto fail;
}

hdr = (struct af_msg_hdr *)msg_buf;
Expand All @@ -1184,6 +1190,8 @@ int af_send_msg_to_user(char *pbuf, uint16_t len)
memcpy(p_data, pbuf, len);
memcpy(nlmsg_data(nlh), msg_buf, len + sizeof(struct af_msg_hdr));
ret = netlink_unicast(oaf_sock, nl_skb, 999, MSG_DONTWAIT);

fail:
kfree(msg_buf);
return ret;
}
Expand Down

0 comments on commit 0e8efc4

Please sign in to comment.