-
Notifications
You must be signed in to change notification settings - Fork 125
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
3 changed files
with
38 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -4,6 +4,7 @@ NOT_FOR_ARCHS = powerpc64 riscv64 sparc64 | |
COMMENT = Spotify client running as UNIX daemon | ||
DIST_TUPLE = github Spotifyd spotifyd v0.3.5 . | ||
CATEGORIES = audio net | ||
REVISION = 0 | ||
|
||
MAINTAINER = Klemens Nanni <[email protected]> | ||
|
||
|
@@ -25,10 +26,8 @@ CONFIGURE_STYLE = cargo | |
SEPARATE_BUILD = Yes | ||
|
||
MODCARGO_NO_DEFAULT_FEATURES = Yes | ||
# "dbus_keyring" breaks build: | ||
# error[E0433]: failed to resolve: use of undeclared crate or module `default` | ||
# --> ${MODCARGO_VENDOR_DIR}/modcargo-crates/keyring-2.0.1/src/lib.rs:176:54 | ||
MODCARGO_FEATURES = dbus_mpris \ | ||
MODCARGO_FEATURES = dbus_keyring \ | ||
dbus_mpris \ | ||
portaudio_backend | ||
|
||
.include "crates.inc" | ||
|
17 changes: 17 additions & 0 deletions
17
audio/spotifyd/patches/patch-modcargo-crates_keyring-2_0_1_Cargo_toml
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
Recognise OpenBSD to unbreak/build "dbus_keyring" feature | ||
https://github.com/hwchen/keyring-rs/pull/156 | ||
|
||
Index: modcargo-crates/keyring-2.0.1/Cargo.toml | ||
--- modcargo-crates/keyring-2.0.1/Cargo.toml.orig | ||
+++ modcargo-crates/keyring-2.0.1/Cargo.toml | ||
@@ -72,6 +72,10 @@ linux-secret-service-rt-tokio-crypto-rust = ["secret-s | ||
version = "3" | ||
optional = true | ||
|
||
+[target."cfg(target_os = \"openbsd\")".dependencies.secret-service] | ||
+version = "3" | ||
+optional = true | ||
+ | ||
[target."cfg(target_os = \"ios\")".dependencies.security-framework] | ||
version = "2.6" | ||
|
18 changes: 18 additions & 0 deletions
18
audio/spotifyd/patches/patch-modcargo-crates_keyring-2_0_1_src_lib_rs
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
Recognise OpenBSD to unbreak/build "dbus_keyring" feature | ||
https://github.com/hwchen/keyring-rs/pull/156 | ||
|
||
Index: modcargo-crates/keyring-2.0.1/src/lib.rs | ||
--- modcargo-crates/keyring-2.0.1/src/lib.rs.orig | ||
+++ modcargo-crates/keyring-2.0.1/src/lib.rs | ||
@@ -122,9 +122,9 @@ use crate::secret_service as default; | ||
#[cfg(all(target_os = "linux", feature = "linux-default-keyutils"))] | ||
use keyutils as default; | ||
|
||
-#[cfg(target_os = "freebsd")] | ||
+#[cfg(any(target_os = "freebsd", target_os = "openbsd"))] | ||
pub mod secret_service; | ||
-#[cfg(target_os = "freebsd")] | ||
+#[cfg(any(target_os = "freebsd", target_os = "openbsd"))] | ||
use crate::secret_service as default; | ||
|
||
#[cfg(target_os = "windows")] |