Skip to content

Commit

Permalink
textproc/nlohmann-json: update to 3.11.2
Browse files Browse the repository at this point in the history
- cmake/.pc files are now installed to share/ as arch-independant, cf
  nlohmann/json#3619 for the rationale
from kn@:
- set NO_BUILD as this is a header-only port
- Defer building tests to do-test target
- Drop NO_TEST, all tests succeed (except the 4 that try to reach network via
  git clone)

all consumers (mtxclient, nheko and mkvtoolnix) build fine with it.

should fix a warzone2100 build failure seen by tb@
  • Loading branch information
landryb committed Feb 4, 2023
1 parent 5e6c2df commit 54dd6c8
Show file tree
Hide file tree
Showing 3 changed files with 66 additions and 10 deletions.
8 changes: 6 additions & 2 deletions textproc/nlohmann-json/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
COMMENT = JSON for modern C++

# the "release" contain only json.hpp, and we want tests and CMake config file
V = 3.9.1
V = 3.11.2
GH_ACCOUNT = nlohmann
GH_PROJECT = json
GH_TAGNAME = v${V}
Expand All @@ -19,6 +19,10 @@ COMPILER = base-clang ports-gcc

MODULES = devel/cmake

NO_TEST = Yes
# only tests are built, defer compilation to running tests
NO_BUILD = Yes
# only 4 tests that try to git clone fail
pre-test:
@${MODCMAKE_BUILD_TARGET}

.include <bsd.port.mk>
4 changes: 2 additions & 2 deletions textproc/nlohmann-json/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (nlohmann-json-3.9.1.tar.gz) = TPDfaXMUlGaL3WRg7YyyabaN6cGa2MJ6vCTNcmBbLVs=
SIZE (nlohmann-json-3.9.1.tar.gz) = 6882818
SHA256 (nlohmann-json-3.11.2.tar.gz) = 1p+d62p14lgEZcbExREbicTcL6lOOoX80v/NmhQ9knM=
SIZE (nlohmann-json-3.11.2.tar.gz) = 8097673
64 changes: 58 additions & 6 deletions textproc/nlohmann-json/pkg/PLIST
Original file line number Diff line number Diff line change
@@ -1,8 +1,60 @@
include/nlohmann/
include/nlohmann/adl_serializer.hpp
include/nlohmann/byte_container_with_subtype.hpp
include/nlohmann/detail/
include/nlohmann/detail/abi_macros.hpp
include/nlohmann/detail/conversions/
include/nlohmann/detail/conversions/from_json.hpp
include/nlohmann/detail/conversions/to_chars.hpp
include/nlohmann/detail/conversions/to_json.hpp
include/nlohmann/detail/exceptions.hpp
include/nlohmann/detail/hash.hpp
include/nlohmann/detail/input/
include/nlohmann/detail/input/binary_reader.hpp
include/nlohmann/detail/input/input_adapters.hpp
include/nlohmann/detail/input/json_sax.hpp
include/nlohmann/detail/input/lexer.hpp
include/nlohmann/detail/input/parser.hpp
include/nlohmann/detail/input/position_t.hpp
include/nlohmann/detail/iterators/
include/nlohmann/detail/iterators/internal_iterator.hpp
include/nlohmann/detail/iterators/iter_impl.hpp
include/nlohmann/detail/iterators/iteration_proxy.hpp
include/nlohmann/detail/iterators/iterator_traits.hpp
include/nlohmann/detail/iterators/json_reverse_iterator.hpp
include/nlohmann/detail/iterators/primitive_iterator.hpp
include/nlohmann/detail/json_pointer.hpp
include/nlohmann/detail/json_ref.hpp
include/nlohmann/detail/macro_scope.hpp
include/nlohmann/detail/macro_unscope.hpp
include/nlohmann/detail/meta/
include/nlohmann/detail/meta/call_std/
include/nlohmann/detail/meta/call_std/begin.hpp
include/nlohmann/detail/meta/call_std/end.hpp
include/nlohmann/detail/meta/cpp_future.hpp
include/nlohmann/detail/meta/detected.hpp
include/nlohmann/detail/meta/identity_tag.hpp
include/nlohmann/detail/meta/is_sax.hpp
include/nlohmann/detail/meta/std_fs.hpp
include/nlohmann/detail/meta/type_traits.hpp
include/nlohmann/detail/meta/void_t.hpp
include/nlohmann/detail/output/
include/nlohmann/detail/output/binary_writer.hpp
include/nlohmann/detail/output/output_adapters.hpp
include/nlohmann/detail/output/serializer.hpp
include/nlohmann/detail/string_concat.hpp
include/nlohmann/detail/string_escape.hpp
include/nlohmann/detail/value_t.hpp
include/nlohmann/json.hpp
lib/cmake/
lib/cmake/nlohmann_json/
lib/cmake/nlohmann_json/nlohmann_jsonConfig.cmake
lib/cmake/nlohmann_json/nlohmann_jsonConfigVersion.cmake
lib/cmake/nlohmann_json/nlohmann_jsonTargets.cmake
lib/pkgconfig/nlohmann_json.pc
include/nlohmann/json_fwd.hpp
include/nlohmann/ordered_map.hpp
include/nlohmann/thirdparty/
include/nlohmann/thirdparty/hedley/
include/nlohmann/thirdparty/hedley/hedley.hpp
include/nlohmann/thirdparty/hedley/hedley_undef.hpp
share/cmake/
share/cmake/nlohmann_json/
share/cmake/nlohmann_json/nlohmann_jsonConfig.cmake
share/cmake/nlohmann_json/nlohmann_jsonConfigVersion.cmake
share/cmake/nlohmann_json/nlohmann_jsonTargets.cmake
share/pkgconfig/nlohmann_json.pc

0 comments on commit 54dd6c8

Please sign in to comment.