Skip to content

Commit

Permalink
Merge pull request #22 from leenaS-d/feature/kirkstone-community-plat…
Browse files Browse the repository at this point in the history
…forms

RDKVREFPLT-3800: Initial kirkstone changes for app layer
  • Loading branch information
deepthi-ps authored Oct 28, 2024
2 parents 381d54c + 96f9b12 commit 787989d
Show file tree
Hide file tree
Showing 9 changed files with 27 additions and 25 deletions.
2 changes: 1 addition & 1 deletion conf/layer.conf
Original file line number Diff line number Diff line change
Expand Up @@ -10,5 +10,5 @@ BBFILE_PATTERN_application-development = "^${LAYERDIR}/"
BBFILE_PRIORITY_application-development = "6"

LAYERDEPENDS_application-development = "core"
LAYERSERIES_COMPAT_application-development = "dunfell"
LAYERSERIES_COMPAT_application-development = "dunfell kirkstone"

2 changes: 1 addition & 1 deletion conf/machine/include/application.inc
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
# To support layered ipk generation
APP_LAYER_ARCH = "${MACHINE}-application"

PACKAGE_EXTRA_ARCHS_append = " ${APP_LAYER_ARCH}"
PACKAGE_EXTRA_ARCHS:append = " ${APP_LAYER_ARCH}"
require package_revisions.inc
12 changes: 6 additions & 6 deletions conf/machine/include/package_revisions.inc
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@

PV_pn-rdkresidentapp= "1.0.0"
PR_pn-rdkresidentapp= "r0"
PACKAGE_ARCH_pn-lib32-rdkresidentapp = "${APP_LAYER_ARCH}"
PV:pn-rdkresidentapp= "1.0.0"
PR:pn-rdkresidentapp= "r0"
PACKAGE_ARCH:pn-lib32-rdkresidentapp = "${APP_LAYER_ARCH}"

PV_pn-residentui= "1.0.0"
PR_pn-residentui= "r0"
PACKAGE_ARCH_pn-lib32-residentui = "${APP_LAYER_ARCH}"
PV:pn-residentui= "1.0.0"
PR:pn-residentui= "r0"
PACKAGE_ARCH:pn-lib32-residentui = "${APP_LAYER_ARCH}"
12 changes: 7 additions & 5 deletions conf/template/bblayers.conf.sample
Original file line number Diff line number Diff line change
Expand Up @@ -9,11 +9,13 @@ RDKROOT := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..
include manifest_vars.conf

BBLAYERS ?= " \
${RDKROOT}/rdke/common/poky/meta \
${RDKROOT}/rdke/common/meta-openembedded/meta-oe \
${RDKROOT}/rdke/common/meta-openembedded/meta-python \
${RDKROOT}/rdke/common/meta-openembedded/meta-multimedia \
"
${MANIFEST_PATH_POKY}/meta \
${MANIFEST_PATH_OPENEMBEDDED}/meta-oe \
${MANIFEST_PATH_OPENEMBEDDED}/meta-python \
${MANIFEST_PATH_OPENEMBEDDED}/meta-webserver \
${MANIFEST_PATH_OPENEMBEDDED}/meta-multimedia \
${MANIFEST_PATH_OPENEMBEDDED}/meta-networking \
"

BBLAYERS =+ "${@'${MANIFEST_PATH_COMMON_OSS_REFERENCE}' if os.path.isfile('${MANIFEST_PATH_COMMON_OSS_REFERENCE}/conf/layer.conf') else ''}"
BBLAYERS =+ "${@'${MANIFEST_PATH_OSS_RELEASE}' if os.path.isfile('${MANIFEST_PATH_OSS_RELEASE}/conf/layer.conf') else ''}"
Expand Down
2 changes: 1 addition & 1 deletion conf/template/local.conf.sample
Original file line number Diff line number Diff line change
Expand Up @@ -235,7 +235,7 @@ BB_DISKMON_DIRS = "\
# By default qemu will build with a builtin VNC server where graphical output can be
# seen. The two lines below enable the SDL backend too. This assumes there is a
# libsdl library available on your build system.
# PACKAGECONFIG_append_pn-qemu-native = " sdl"
# PACKAGECONFIG:append:pn-qemu-native = " sdl"
# ASSUME_PROVIDED += "libsdl-native"

# Nice debug data
Expand Down
12 changes: 6 additions & 6 deletions recipes-apps/rdkresidentapp/rdkresidentapp.bb
Original file line number Diff line number Diff line change
Expand Up @@ -4,15 +4,15 @@ HOMEPAGE = ""
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3cc4d276e918f48b04eb2faf952d0537"

RDEPENDS_${PN} += "bash lighttpd wpeframework"
RDEPENDS:${PN} += "bash lighttpd wpeframework"
inherit systemd syslog-ng-config-gen
SYSLOG-NG_FILTER = "residentapp"
SYSLOG-NG_SERVICE_residentapp = "residentapp.service"
SYSLOG-NG_DESTINATION_residentapp = "residentapp.log"
SYSLOG-NG_LOGRATE_residentapp = "low"

# FIXME: Move to a common config
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"

PACKAGE_ARCH = "${APP_LAYER_ARCH}"

Expand All @@ -35,11 +35,11 @@ do_install() {
}

# FIXME: Move to a common config
do_install_append() {
do_install:append() {
install -d ${D}${sysconfdir}/lighttpd.d
install -m 0644 ${WORKDIR}/ref-webui-docroot-path.conf ${D}${sysconfdir}/lighttpd.d/
}

SYSTEMD_SERVICE_${PN} = "residentapp.service"
FILES_${PN} += "${systemd_unitdir}/system/residentapp.service"
FILES_${PN} += "/lib/rdk/residentApp.sh"
SYSTEMD_SERVICE:${PN} = "residentapp.service"
FILES:${PN} += "${systemd_unitdir}/system/residentapp.service"
FILES:${PN} += "/lib/rdk/residentApp.sh"
4 changes: 2 additions & 2 deletions recipes-apps/residentui/residentui.bb
Original file line number Diff line number Diff line change
Expand Up @@ -14,12 +14,12 @@ S = "${WORKDIR}/git/accelerator-home-ui/dist/"
do_compile[noexec] = "1"
do_configure[noexec] = "1"

RDEPENDS_${PN}-dev = ""
RDEPENDS:${PN}-dev = ""

do_install() {
install -d ${D}/home/root/lxresui
cp -r ${S}/* ${D}/home/root/lxresui/
}


FILES_${PN} += "/home/root/*"
FILES:${PN} += "/home/root/*"
4 changes: 2 additions & 2 deletions recipes-core/images/application-test-image.bb
Original file line number Diff line number Diff line change
Expand Up @@ -3,15 +3,15 @@ SUMMARY = "RDKE Bootable Image with App support"
LICENSE = "MIT"
IMAGE_INSTALL = " \
packagegroup-vendor-layer \
packagegroup-middleware-generic \
packagegroup-middleware-layer \
packagegroup-application-layer \
"
inherit core-image

inherit custom-rootfs-creation

IMAGE_ROOTFS_SIZE ?= "8192"
IMAGE_ROOTFS_EXTRA_SPACE_append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"
IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"

create_init_link() {
ln -sf /sbin/init ${IMAGE_ROOTFS}/init
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@ inherit packagegroup
##Change the version number for each release.
PV = "1.1.0"

RDEPENDS_packagegroup-application-layer = " \
RDEPENDS:packagegroup-application-layer = " \
residentui \
rdkresidentapp \
"

0 comments on commit 787989d

Please sign in to comment.