Skip to content

Commit

Permalink
Merge pull request #32 from leenaS-d/develop
Browse files Browse the repository at this point in the history
Activate rdkshell plugin via systemd service
  • Loading branch information
deepthi-ps authored Dec 10, 2024
2 parents 2751c53 + b5fa3ed commit a052292
Show file tree
Hide file tree
Showing 3 changed files with 35 additions and 0 deletions.
4 changes: 4 additions & 0 deletions recipes-apps/rdkresidentapp/files/00-activate-rdkshell.conf
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
# To activate rdkshell plugin before residentapp
After=wpeframework-rdkshell.service
Requires= wpeframework-rdkshell.service

12 changes: 12 additions & 0 deletions recipes-apps/rdkresidentapp/files/wpeframework-rdkshell.service
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
# To do: Remove whrn RDKEMW-671 is released


[Unit]
Description=WPEFramework RDKShell Initialiser
Requires=wpeframework.service iarmbusd.service dsmgr.service
After=wpeframework.service iarmbusd.service dsmgr.service\

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/bin/PluginActivator org.rdk.RDKShell
19 changes: 19 additions & 0 deletions recipes-apps/rdkresidentapp/rdkresidentapp.bb
Original file line number Diff line number Diff line change
Expand Up @@ -23,17 +23,29 @@ SRC_URI = "${CMF_GIT_ROOT}/rdk/components/generic/appmanager;protocol=${CMF_GIT_
# FIXME: Move to a common config
SRC_URI += "file://ref-webui-docroot-path.conf"

SRC_URI += "file://00-activate-rdkshell.conf"

# Remove once RDKEMW-671 is release. Workaround to fix UI issue
SRC_URI += "file://wpeframework-rdkshell.service"

SRCREV_generic = "${AUTOREV}"
SRCREV_FORMAT = "generic"

do_install() {
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${S}/resources/systemd/residentapp.service ${D}${systemd_unitdir}/system/residentapp.service

install -D -m 0644 ${WORKDIR}/00-activate-rdkshell.conf ${D}${systemd_unitdir}/system/residentapp.service.d/00-activate-rdkshell.conf

install -d ${D}/lib/rdk
install -m 0755 ${S}/residentapp/residentApp.sh ${D}/lib/rdk/residentApp.sh
}

# Remove once RDKEMW-671 is release. Workaround to fix UI issue
do_install_append() {
install -m 0644 ${S}/resources/systemd/wpeframework-rdkshell.service ${D}${systemd_unitdir}/system/wpeframework-rdkshell.service
}

# FIXME: Move to a common config
do_install_append() {
install -d ${D}${sysconfdir}/lighttpd.d
Expand All @@ -43,3 +55,10 @@ do_install_append() {
SYSTEMD_SERVICE_${PN} = "residentapp.service"
FILES_${PN} += "${systemd_unitdir}/system/residentapp.service"
FILES_${PN} += "/lib/rdk/residentApp.sh"
FILES_${PN} += "${systemd_unitdir}/system/residentapp.service.d/*"


# Remove once RDKEMW-671 is release. Workaround to fix UI issue
SYSTEMD_SERVICE_${PN} += "wpeframework-rdkshell.service"
FILES_${PN} += "${systemd_unitdir}/system/wpeframework-rdkshell.service"

0 comments on commit a052292

Please sign in to comment.