Skip to content

Commit

Permalink
Merge pull request #8 from rdkcentral/topic/RDKE-34-add-westeros-comp…
Browse files Browse the repository at this point in the history
…onent

RDKE-34 Add westeros and gstreamer1.0-plugins-base to vendor layer
  • Loading branch information
deepthi-ps authored Apr 29, 2024
2 parents 13ab835 + cc4b7bb commit 9c30904
Show file tree
Hide file tree
Showing 3 changed files with 69 additions and 3 deletions.
30 changes: 28 additions & 2 deletions conf/include/vendor_pkg_versions.inc
Original file line number Diff line number Diff line change
Expand Up @@ -8,8 +8,6 @@ PV_pn-android-raspberrypi = "5.10.82"
PR_pn-android-raspberrypi = "r0"
PACKAGE_ARCH_pn-android-raspberrypi = "${VENDOR_LAYER_EXTENSION}"

#PREFERRED_VERSION_linux-libc-headers = "5.10.%"

PV_pn-cairo = "1.14.6"
PR_pn-cairo = "r1"
PACKAGE_ARCH_pn-cairo = "${VENDOR_LAYER_EXTENSION}"
Expand All @@ -22,3 +20,31 @@ GST_REVISION = "r0"
PV_pn-gstreamer1.0 = "${GST_VERSION}"
PR_pn-gstreamer1.0 = "${GST_REVISION}"
PACKAGE_ARCH_pn-gstreamer1.0 = "${VENDOR_LAYER_EXTENSION}"

PV_pn-gstreamer1.0-plugins-base = "${GST_VERSION}"
PR_pn-gstreamer1.0-plugins-base = "${GST_REVISION}"
PACKAGE_ARCH_pn-gstreamer1.0-plugins-base = "${VENDOR_LAYER_EXTENSION}"

PV_pn-gstreamer1.0-plugins-base-meta = "${GST_VERSION}"
PR_pn-gstreamer1.0-plugins-base-meta = "${GST_REVISION}"
PACKAGE_ARCH_pn-gstreamer1.0-plugins-base-meta = "${VENDOR_LAYER_EXTENSION}"

#westeros components
WESTEROS_VERSION = "1.0.0"
WESTEROS_REVISION = "r0"

PV_pn-westeros-simplebuffer = "${WESTEROS_VERSION}"
PR_pn-westeros-simplebuffer = "${WESTEROS_REVISION}"
PACKAGE_ARCH_pn-westeros-simplebuffer = "${VENDOR_LAYER_EXTENSION}"

PV_pn-westeros-simpleshell = "${WESTEROS_VERSION}"
PR_pn-westeros-simpleshell = "${WESTEROS_REVISION}"
PACKAGE_ARCH_pn-westeros-simpleshell = "${VENDOR_LAYER_EXTENSION}"

PV_pn-westeros-soc-drm = "${WESTEROS_VERSION}"
PR_pn-westeros-soc-drm = "${WESTEROS_REVISION}"
PACKAGE_ARCH_pn-westeros-soc-drm = "${VENDOR_LAYER_EXTENSION}"

PV_pn-westeros = "${WESTEROS_VERSION}"
PR_pn-westeros = "${WESTEROS_REVISION}"
PACKAGE_ARCH_pn-westeros = "${VENDOR_LAYER_EXTENSION}"
7 changes: 6 additions & 1 deletion recipes-core/packagegroups/packagegroup-vendor-layer.bb
Original file line number Diff line number Diff line change
Expand Up @@ -14,6 +14,11 @@ PR = "r0"

RDEPENDS_${PN} = "\
cairo \
gstreamer1.0 \
gstreamer1.0 \
westeros-simplebuffer \
westeros-simpleshell \
westeros-soc-drm \
westeros \
gstreamer1.0-plugins-base \
"

35 changes: 35 additions & 0 deletions recipes-graphics/westeros-soc/westeros-soc-drm.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
require recipes-graphics/westeros/westeros.inc

SUMMARY = "This receipe compiles the westeros gl component for drm supported platforms, currently the HiKey board"
LICENSE_LOCATION = "${S}/../LICENSE"

S = "${WORKDIR}/git/drm"

COMPATIBLE_MACHINE = "(hikey-32|dragonboard-410c-32|dragonboard-820c-32|poplar|imx8mqevk)"

DEPENDS = "wayland virtual/egl glib-2.0 libdrm"

PROVIDES = "virtual/westeros-soc westeros-soc"
RPROVIDES_${PN} = "virtual/westeros-soc westeros-soc"

CFLAGS_append = " -I${STAGING_INCDIR}/libdrm"

SECURITY_CFLAGS_remove = "-fpie"
SECURITY_CFLAGS_remove = "-pie"

DEBIAN_NOAUTONAME_${PN} = "1"
DEBIAN_NOAUTONAME_${PN}-dbg = "1"
DEBIAN_NOAUTONAME_${PN}-dev = "1"
DEBIAN_NOAUTONAME_${PN}-staticdev = "1"

inherit autotools pkgconfig

#Commented below line to get "westeros-gl-console" binary into final image.
#FILES_${PN} = "${libdir}/*"

COMPATIBLE_MACHINE = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '(.*)', 'null', d)}"

# incase if enabled in bb file, it should be removed for Rpi
CFLAGS_remove = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '-DWESTEROS_GL_NO_PLANES', '', d)}"
CFLAGS_append = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', ' -DDRM_NO_NATIVE_FENCE', '', d)}"

0 comments on commit 9c30904

Please sign in to comment.