Skip to content

Commit

Permalink
webos: bluez5 (refresh patches to apply on 5.71 version)
Browse files Browse the repository at this point in the history
:Release Notes:

:Detailed Notes:
Fixes:
http://gecko.lge.com:8000/Errors/Details/748755

ERROR: Applying patch '0012-Support-enabling-avdtp-delayReport.patch' on target directory 'TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/bluez5/5.71/bluez-5.71'
CmdError('quilt --quiltrc TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/bluez5/5.71/recipe-sysroot-native/etc/quiltrc push', 0, 'stdout: Applying patch 0012-Support-enabling-avdtp-delayReport.patch
patching file profiles/audio/a2dp.c
patching file profiles/audio/a2dp.h
patching file profiles/audio/avdtp.c
patching file profiles/audio/avdtp.h
patching file profiles/audio/media.c
Hunk #1 succeeded at 133 (offset 1 line).
Hunk #2 succeeded at 1494 (offset 44 lines).
Hunk webosose#3 succeeded at 3321 (offset 78 lines).
patching file profiles/audio/media.h
Hunk #2 succeeded at 25 with fuzz 2 (offset -1 lines).
patching file src/adapter.c
Hunk #2 succeeded at 288 (offset 2 lines).
Hunk webosose#3 succeeded at 369 (offset 2 lines).
Hunk webosose#4 succeeded at 576 (offset 2 lines).
Hunk webosose#5 succeeded at 3516 (offset 8 lines).
Hunk webosose#6 FAILED at 3933.
Hunk webosose#7 succeeded at 5352 (offset 41 lines).
Hunk webosose#8 succeeded at 6898 (offset 41 lines).
Hunk webosose#9 succeeded at 6943 (offset 41 lines).
Hunk webosose#10 succeeded at 6954 (offset 41 lines).
1 out of 10 hunks FAILED -- rejects in file src/adapter.c
patching file src/adapter.h
patching file src/btd.h
patching file src/main.c
Hunk #2 succeeded at 1037 (offset 4 lines).
patching file src/main.conf
Patch 0012-Support-enabling-avdtp-delayReport.patch does not apply (enforce with -f)

:Testing Performed:
Only build tested.

:QA Notes:
No change to image.

:Issues Addressed:
[WRQ-504] Create GPVB with Yocto 5.0 Scarthgap

Change-Id: If1e2b507096a953d3803c6e4edf22996a9ff4340
shr-project committed Dec 3, 2024
1 parent d677772 commit 78248c9
Showing 19 changed files with 119 additions and 109 deletions.
Original file line number Diff line number Diff line change
@@ -35,7 +35,7 @@ index 9b58e0c4e..021bd29ae 100644
uint16_t vendor_src;
uint16_t vendor;
uint16_t product;
@@ -1020,6 +1021,21 @@ static gboolean dev_property_get_class(const GDBusPropertyTable *property,
@@ -1013,6 +1014,21 @@ static gboolean dev_property_get_class(const GDBusPropertyTable *property,
return TRUE;
}

@@ -57,7 +57,7 @@ index 9b58e0c4e..021bd29ae 100644
static gboolean get_appearance(const GDBusPropertyTable *property, void *data,
uint16_t *appearance)
{
@@ -3168,6 +3184,7 @@ static const GDBusMethodTable device_methods[] = {
@@ -3178,6 +3194,7 @@ static const GDBusMethodTable device_methods[] = {
static const GDBusPropertyTable device_properties[] = {
{ "Address", "s", dev_property_get_address },
{ "AddressType", "s", property_get_address_type },
Original file line number Diff line number Diff line change
@@ -30,10 +30,10 @@ Upstream-Status: Pending
1 file changed, 28 insertions(+)

diff --git a/src/device.c b/src/device.c
index 021bd29ae..60515b262 100644
index ccc9b41fc..41d271e04 100644
--- a/src/device.c
+++ b/src/device.c
@@ -2573,6 +2573,33 @@ static DBusMessage *dev_connect(DBusConnection *conn, DBusMessage *msg,
@@ -2583,6 +2583,33 @@ static DBusMessage *dev_connect(DBusConnection *conn, DBusMessage *msg,
return connect_profiles(dev, bdaddr_type, msg, NULL);
}

@@ -67,7 +67,7 @@ index 021bd29ae..60515b262 100644
static DBusMessage *connect_profile(DBusConnection *conn, DBusMessage *msg,
void *user_data)
{
@@ -3172,6 +3199,7 @@ static DBusMessage *cancel_pairing(DBusConnection *conn, DBusMessage *msg,
@@ -3182,6 +3209,7 @@ static DBusMessage *cancel_pairing(DBusConnection *conn, DBusMessage *msg,
static const GDBusMethodTable device_methods[] = {
{ GDBUS_ASYNC_METHOD("Disconnect", NULL, NULL, dev_disconnect) },
{ GDBUS_ASYNC_METHOD("Connect", NULL, NULL, dev_connect) },
Original file line number Diff line number Diff line change
@@ -75,10 +75,10 @@ index 90d0c0c8e..369e9e91c 100644
return -EIO;

diff --git a/obexd/client/pbap.c b/obexd/client/pbap.c
index 1ed8c68ec..3af55440b 100644
index 2d2aa9508..d3821b80a 100644
--- a/obexd/client/pbap.c
+++ b/obexd/client/pbap.c
@@ -1302,7 +1302,7 @@ int pbap_init(void)
@@ -1303,7 +1303,7 @@ int pbap_init(void)

DBG("");

Original file line number Diff line number Diff line change
@@ -25,7 +25,7 @@ Upstream-Status: Inappropriate [webos specific]
1 file changed, 49 insertions(+), 1 deletion(-)

diff --git a/src/device.c b/src/device.c
index 60515b262..43642d4f8 100644
index 41d271e04..bc92fe74c 100644
--- a/src/device.c
+++ b/src/device.c
@@ -230,6 +230,7 @@ struct btd_device {
@@ -36,7 +36,7 @@ index 60515b262..43642d4f8 100644
GSList *primaries; /* List of primary services */
GSList *services; /* List of btd_service */
GSList *pending; /* Pending services */
@@ -1052,6 +1053,28 @@ static gboolean get_appearance(const GDBusPropertyTable *property, void *data,
@@ -1045,6 +1046,28 @@ static gboolean get_appearance(const GDBusPropertyTable *property, void *data,
return FALSE;
}

@@ -65,7 +65,7 @@ index 60515b262..43642d4f8 100644
static gboolean dev_property_exists_appearance(
const GDBusPropertyTable *property, void *data)
{
@@ -2097,8 +2120,14 @@ static void device_profile_connected(struct btd_device *dev,
@@ -2107,8 +2130,14 @@ static void device_profile_connected(struct btd_device *dev,

DBG("%s %s (%d)", profile->name, strerror(-err), -err);

@@ -81,7 +81,7 @@ index 60515b262..43642d4f8 100644

if (dev->pending == NULL)
goto done;
@@ -2624,6 +2653,14 @@ static DBusMessage *connect_profile(DBusConnection *conn, DBusMessage *msg,
@@ -2634,6 +2663,14 @@ static DBusMessage *connect_profile(DBusConnection *conn, DBusMessage *msg,
static void device_profile_disconnected(struct btd_device *dev,
struct btd_profile *profile, int err)
{
@@ -96,15 +96,15 @@ index 60515b262..43642d4f8 100644
if (!dev->disconnect)
return;

@@ -3229,6 +3266,7 @@ static const GDBusPropertyTable device_properties[] = {
@@ -3239,6 +3276,7 @@ static const GDBusPropertyTable device_properties[] = {
{ "RSSI", "n", dev_property_get_rssi, NULL, dev_property_exists_rssi },
{ "Connected", "b", dev_property_get_connected },
{ "UUIDs", "as", dev_property_get_uuids },
+ { "ConnectedUUIDS", "as", dev_property_get_connected_uuids },
{ "Modalias", "s", dev_property_get_modalias, NULL,
dev_property_exists_modalias },
{ "Adapter", "o", dev_property_get_adapter },
@@ -3338,8 +3376,18 @@ void device_remove_connection(struct btd_device *device, uint8_t bdaddr_type,
@@ -3350,8 +3388,18 @@ void device_remove_connection(struct btd_device *device, uint8_t bdaddr_type,
if (!state->connected)
return;

Original file line number Diff line number Diff line change
@@ -56,7 +56,7 @@ index 6f64f162b..b002470f9 100644
break;
}
diff --git a/src/device.c b/src/device.c
index 43642d4f8..ec407a808 100644
index bc92fe74c..41c6a7987 100644
--- a/src/device.c
+++ b/src/device.c
@@ -185,6 +185,11 @@ enum {
@@ -80,7 +80,7 @@ index 43642d4f8..ec407a808 100644
};

static const uint16_t uuid_list[] = {
@@ -1463,6 +1470,18 @@ dev_property_manufacturer_data_exist(const GDBusPropertyTable *property,
@@ -1456,6 +1463,18 @@ dev_property_manufacturer_data_exist(const GDBusPropertyTable *property,
return bt_ad_has_manufacturer_data(device->ad, NULL);
}

@@ -99,7 +99,7 @@ index 43642d4f8..ec407a808 100644
static void append_service_data(void *data, void *user_data)
{
struct bt_ad_service_data *sd = data;
@@ -1481,13 +1500,13 @@ dev_property_get_service_data(const GDBusPropertyTable *property,
@@ -1474,13 +1493,13 @@ dev_property_get_service_data(const GDBusPropertyTable *property,
struct btd_device *device = data;
DBusMessageIter dict;

@@ -114,7 +114,7 @@ index 43642d4f8..ec407a808 100644
bt_ad_foreach_service_data(device->ad, append_service_data, &dict);

dbus_message_iter_close_container(iter, &dict);
@@ -1495,6 +1514,28 @@ dev_property_get_service_data(const GDBusPropertyTable *property,
@@ -1488,6 +1507,28 @@ dev_property_get_service_data(const GDBusPropertyTable *property,
return TRUE;
}

@@ -143,7 +143,7 @@ index 43642d4f8..ec407a808 100644
static gboolean
dev_property_service_data_exist(const GDBusPropertyTable *property,
void *data)
@@ -2239,6 +2280,15 @@ void device_set_manufacturer_data(struct btd_device *dev, GSList *list,
@@ -2249,6 +2290,15 @@ void device_set_manufacturer_data(struct btd_device *dev, GSList *list,
g_slist_foreach(list, add_manufacturer_data, dev);
}

@@ -159,7 +159,7 @@ index 43642d4f8..ec407a808 100644
static void add_service_data(void *data, void *user_data)
{
struct eir_sd *sd = data;
@@ -3272,6 +3322,8 @@ static const GDBusPropertyTable device_properties[] = {
@@ -3282,6 +3332,8 @@ static const GDBusPropertyTable device_properties[] = {
{ "Adapter", "o", dev_property_get_adapter },
{ "ManufacturerData", "a{qv}", dev_property_get_manufacturer_data,
NULL, dev_property_manufacturer_data_exist },
@@ -168,7 +168,7 @@ index 43642d4f8..ec407a808 100644
{ "ServiceData", "a{sv}", dev_property_get_service_data,
NULL, dev_property_service_data_exist },
{ "TxPower", "n", dev_property_get_tx_power, NULL,
@@ -4311,6 +4363,9 @@ static struct btd_device *device_new(struct btd_adapter *adapter,
@@ -4323,6 +4375,9 @@ static struct btd_device *device_new(struct btd_adapter *adapter,
device->sirks = queue_new();
device->temporary = true;

@@ -179,10 +179,10 @@ index 43642d4f8..ec407a808 100644
gatt_service_removed, device, NULL);

diff --git a/src/device.h b/src/device.h
index 3252e14ef..9dcb3c140 100644
index 8bb38669d..2c9a84a41 100644
--- a/src/device.h
+++ b/src/device.h
@@ -196,3 +196,5 @@ typedef void (*bt_device_ad_func_t)(void *data, void *user_data);
@@ -199,3 +199,5 @@ typedef void (*bt_device_ad_func_t)(void *data, void *user_data);

void btd_device_foreach_ad(struct btd_device *dev, bt_device_ad_func_t func,
void *data);
Original file line number Diff line number Diff line change
@@ -49,10 +49,10 @@ index dda9a303f..4063650c7 100644
}

diff --git a/profiles/audio/media.c b/profiles/audio/media.c
index 66f512e00..3e3a1013a 100644
index 62f53defa..1ce2792cb 100644
--- a/profiles/audio/media.c
+++ b/profiles/audio/media.c
@@ -1913,7 +1913,7 @@ static uint32_t media_player_get_position(void *user_data)
@@ -1970,7 +1970,7 @@ static uint32_t media_player_get_position(void *user_data)
sec = (uint32_t) timedelta;
msec = (uint32_t) ((timedelta - sec) * 1000);

@@ -62,10 +62,10 @@ index 66f512e00..3e3a1013a 100644

static uint32_t media_player_get_duration(void *user_data)
diff --git a/src/device.c b/src/device.c
index ec407a808..caa8c55ca 100644
index 41c6a7987..7e98da6ba 100644
--- a/src/device.c
+++ b/src/device.c
@@ -2289,6 +2289,22 @@ void recieve_passThrough_commands(struct btd_device *dev, const char* code, cons
@@ -2299,6 +2299,22 @@ void recieve_passThrough_commands(struct btd_device *dev, const char* code, cons
DEVICE_INTERFACE, "KeyCode");
}

@@ -88,7 +88,7 @@ index ec407a808..caa8c55ca 100644
static void add_service_data(void *data, void *user_data)
{
struct eir_sd *sd = data;
@@ -3283,6 +3299,12 @@ static DBusMessage *cancel_pairing(DBusConnection *conn, DBusMessage *msg,
@@ -3293,6 +3309,12 @@ static DBusMessage *cancel_pairing(DBusConnection *conn, DBusMessage *msg,
return dbus_message_new_method_return(msg);
}

@@ -101,7 +101,7 @@ index ec407a808..caa8c55ca 100644
static const GDBusMethodTable device_methods[] = {
{ GDBUS_ASYNC_METHOD("Disconnect", NULL, NULL, dev_disconnect) },
{ GDBUS_ASYNC_METHOD("Connect", NULL, NULL, dev_connect) },
@@ -4351,7 +4373,7 @@ static struct btd_device *device_new(struct btd_adapter *adapter,
@@ -4363,7 +4385,7 @@ static struct btd_device *device_new(struct btd_adapter *adapter,

if (g_dbus_register_interface(dbus_conn,
device->path, DEVICE_INTERFACE,
@@ -111,10 +111,10 @@ index ec407a808..caa8c55ca 100644
device_free) == FALSE) {
error("Unable to register device interface for %s", address);
diff --git a/src/device.h b/src/device.h
index 9dcb3c140..ae54e71cf 100644
index 2c9a84a41..d2ff12306 100644
--- a/src/device.h
+++ b/src/device.h
@@ -198,3 +198,6 @@ void btd_device_foreach_ad(struct btd_device *dev, bt_device_ad_func_t func,
@@ -201,3 +201,6 @@ void btd_device_foreach_ad(struct btd_device *dev, bt_device_ad_func_t func,
void *data);

void recieve_passThrough_commands(struct btd_device *dev, const char* code, const char* state);
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From dcc06f3359fd20877f9b420044042a752ed14c24 Mon Sep 17 00:00:00 2001
From 4b83704a797e531deb5256c189e961d760ae0d91 Mon Sep 17 00:00:00 2001
From: "sameer.mulla" <[email protected]>
Date: Tue, 5 Feb 2019 18:10:55 +0530
Subject: [PATCH] avrcp getting remote device features list
@@ -80,7 +80,7 @@ index 4063650c7..f3f2009f4 100644
}

diff --git a/src/device.c b/src/device.c
index caa8c55ca..fd26b6057 100644
index 7e98da6ba..d4f67eb03 100644
--- a/src/device.c
+++ b/src/device.c
@@ -298,6 +298,8 @@ struct btd_device {
@@ -92,7 +92,7 @@ index caa8c55ca..fd26b6057 100644
};

static const uint16_t uuid_list[] = {
@@ -1536,6 +1538,46 @@ static gboolean dev_property_get_key_code(const GDBusPropertyTable *property,
@@ -1529,6 +1531,46 @@ static gboolean dev_property_get_key_code(const GDBusPropertyTable *property,
return TRUE;
}

@@ -139,7 +139,7 @@ index caa8c55ca..fd26b6057 100644
static gboolean
dev_property_service_data_exist(const GDBusPropertyTable *property,
void *data)
@@ -2305,6 +2347,25 @@ void media_metadata_request(struct btd_device *dev)
@@ -2315,6 +2357,25 @@ void media_metadata_request(struct btd_device *dev)
DBUS_TYPE_INVALID);
}

@@ -165,7 +165,7 @@ index caa8c55ca..fd26b6057 100644
static void add_service_data(void *data, void *user_data)
{
struct eir_sd *sd = data;
@@ -3346,6 +3407,10 @@ static const GDBusPropertyTable device_properties[] = {
@@ -3356,6 +3417,10 @@ static const GDBusPropertyTable device_properties[] = {
NULL, dev_property_manufacturer_data_exist },
{ "KeyCode", "a{sv}", dev_property_get_key_code,
NULL, dev_property_key_code_exist},
@@ -176,7 +176,7 @@ index caa8c55ca..fd26b6057 100644
{ "ServiceData", "a{sv}", dev_property_get_service_data,
NULL, dev_property_service_data_exist },
{ "TxPower", "n", dev_property_get_tx_power, NULL,
@@ -4388,6 +4453,9 @@ static struct btd_device *device_new(struct btd_adapter *adapter,
@@ -4400,6 +4465,9 @@ static struct btd_device *device_new(struct btd_adapter *adapter,
device->passththough_key.state = NULL;
device->passththough_key.key = NULL;

@@ -187,7 +187,7 @@ index caa8c55ca..fd26b6057 100644
gatt_service_removed, device, NULL);

diff --git a/src/device.h b/src/device.h
index ae54e71cf..6856177d6 100644
index d2ff12306..19e49717a 100644
--- a/src/device.h
+++ b/src/device.h
@@ -10,6 +10,10 @@
@@ -201,7 +201,7 @@ index ae54e71cf..6856177d6 100644

struct btd_device;

@@ -201,3 +205,4 @@ void recieve_passThrough_commands(struct btd_device *dev, const char* code, cons
@@ -204,3 +208,4 @@ void recieve_passThrough_commands(struct btd_device *dev, const char* code, cons

void media_play_request(struct btd_device *dev);
void media_metadata_request(struct btd_device *dev);
Original file line number Diff line number Diff line change
@@ -26,10 +26,10 @@ Upstream-Status: Pending
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/profiles/audio/transport.c b/profiles/audio/transport.c
index dd923b03e..96fa29e7c 100644
index 23ea267f6..83dec8f0d 100644
--- a/profiles/audio/transport.c
+++ b/profiles/audio/transport.c
@@ -1333,7 +1333,7 @@ static int media_transport_init_source(struct media_transport *transport)
@@ -1176,7 +1176,7 @@ static int media_transport_init_source(struct media_transport *transport)
transport->data = a2dp;
transport->destroy = destroy_a2dp;

Original file line number Diff line number Diff line change
@@ -28,10 +28,10 @@ Upstream-Status: Inappropriate [webos specific]
2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/profiles/audio/media.c b/profiles/audio/media.c
index 3e3a1013a..d24329dcd 100644
index 1ce2792cb..50b7b7edd 100644
--- a/profiles/audio/media.c
+++ b/profiles/audio/media.c
@@ -1928,8 +1928,8 @@ static void media_player_set_volume(int8_t volume, struct btd_device *dev,
@@ -1985,8 +1985,8 @@ static void media_player_set_volume(int8_t volume, struct btd_device *dev,
{
struct media_player *mp = user_data;

@@ -43,10 +43,10 @@ index 3e3a1013a..d24329dcd 100644
mp->volume = volume;
}
diff --git a/profiles/audio/transport.c b/profiles/audio/transport.c
index 96fa29e7c..f2ad172ef 100644
index 83dec8f0d..155695b1a 100644
--- a/profiles/audio/transport.c
+++ b/profiles/audio/transport.c
@@ -779,8 +779,8 @@ static void set_volume(const GDBusPropertyTable *property,
@@ -811,8 +811,8 @@ static void set_volume(const GDBusPropertyTable *property,
}

volume = (int8_t)arg;
@@ -57,7 +57,7 @@ index 96fa29e7c..f2ad172ef 100644

notify = transport->source_watch ? true : false;
if (notify) {
@@ -1967,8 +1967,8 @@ void media_transport_update_volume(struct media_transport *transport,
@@ -1717,8 +1717,8 @@ void media_transport_update_volume(struct media_transport *transport,
return;

/* Check if volume really changed */
Original file line number Diff line number Diff line change
@@ -90,10 +90,10 @@ index 102a2603e..b167f2dab 100644
uint16_t avdtp_get_version(struct avdtp *session);
+void avdtp_local_sep_set_delay_report(struct avdtp_local_sep *lsep, bool delay_reporting);
diff --git a/profiles/audio/media.c b/profiles/audio/media.c
index d24329dcd..63ee334c7 100644
index 50b7b7edd..aaafbb8bd 100644
--- a/profiles/audio/media.c
+++ b/profiles/audio/media.c
@@ -132,6 +132,19 @@ struct media_player {
@@ -133,6 +133,19 @@ struct media_player {

static GSList *adapters = NULL;

@@ -113,7 +113,7 @@ index d24329dcd..63ee334c7 100644
static void endpoint_request_free(struct endpoint_request *request)
{
if (request->call)
@@ -1437,6 +1450,9 @@ media_endpoint_create(struct media_adapter *adapter,
@@ -1481,6 +1494,9 @@ media_endpoint_create(struct media_adapter *adapter,
}

endpoint->adapter = adapter;
@@ -123,7 +123,7 @@ index d24329dcd..63ee334c7 100644

for (i = 0; i < ARRAY_SIZE(init_table); i++) {
init = &init_table[i];
@@ -3227,6 +3243,7 @@ int media_register(struct btd_adapter *btd_adapter)
@@ -3305,6 +3321,7 @@ int media_register(struct btd_adapter *btd_adapter)
return -1;
}

@@ -132,7 +132,7 @@ index d24329dcd..63ee334c7 100644

return 0;
diff --git a/profiles/audio/media.h b/profiles/audio/media.h
index 0eeb5746a..ad33c8816 100644
index 2b579877b..704a25ea9 100644
--- a/profiles/audio/media.h
+++ b/profiles/audio/media.h
@@ -10,6 +10,7 @@
@@ -143,13 +143,13 @@ index 0eeb5746a..ad33c8816 100644

typedef void (*media_endpoint_cb_t) (struct media_endpoint *endpoint,
void *ret, int size, void *user_data);
@@ -25,3 +26,4 @@ struct btd_adapter *media_endpoint_get_btd_adapter(
bool media_endpoint_is_broadcast(
struct media_endpoint *endpoint);
@@ -24,3 +25,4 @@ struct btd_adapter *media_endpoint_get_btd_adapter(
struct media_endpoint *endpoint);
bool media_endpoint_is_broadcast(struct media_endpoint *endpoint);
int8_t media_player_get_device_volume(struct btd_device *device);
+void media_set_delay_reporting(struct media_adapter* adapter, bool delay_reporting);
diff --git a/src/adapter.c b/src/adapter.c
index 5ebfc4752..e2b66e1d3 100644
index ee70b00d2..f8883b19e 100644
--- a/src/adapter.c
+++ b/src/adapter.c
@@ -67,6 +67,7 @@
@@ -160,7 +160,7 @@ index 5ebfc4752..e2b66e1d3 100644

#define MODE_OFF 0x00
#define MODE_CONNECTABLE 0x01
@@ -285,6 +286,9 @@ struct btd_adapter {
@@ -287,6 +288,9 @@ struct btd_adapter {
bool filtered_discovery; /* we are doing filtered discovery */
bool no_scan_restart_delay; /* when this flag is set, restart scan
* without delay */
@@ -170,7 +170,7 @@ index 5ebfc4752..e2b66e1d3 100644
uint8_t discovery_type; /* current active discovery type */
uint8_t discovery_enable; /* discovery enabled/disabled */
bool discovery_suspended; /* discovery has been suspended */
@@ -363,6 +367,11 @@ typedef enum {
@@ -365,6 +369,11 @@ typedef enum {
ADAPTER_AUTHORIZE_CHECK_CONNECTED
} adapter_authorize_type;

@@ -182,7 +182,7 @@ index 5ebfc4752..e2b66e1d3 100644
static struct btd_adapter *btd_adapter_lookup(uint16_t index)
{
GList *list;
@@ -565,6 +574,8 @@ static void store_adapter_info(struct btd_adapter *adapter)
@@ -567,6 +576,8 @@ static void store_adapter_info(struct btd_adapter *adapter)

g_key_file_set_boolean(key_file, "General", "Discoverable",
discoverable);
@@ -191,7 +191,7 @@ index 5ebfc4752..e2b66e1d3 100644

if (adapter->discoverable_timeout != btd_opts.discovto)
g_key_file_set_integer(key_file, "General",
@@ -3497,6 +3508,30 @@ static gboolean property_get_roles(const GDBusPropertyTable *property,
@@ -3505,6 +3516,30 @@ static gboolean property_get_roles(const GDBusPropertyTable *property,

return TRUE;
}
@@ -222,15 +222,15 @@ index 5ebfc4752..e2b66e1d3 100644

static void property_append_experimental(void *data, void *user_data)
{
@@ -3898,6 +3933,7 @@ static const GDBusPropertyTable adapter_properties[] = {
{ "Roles", "as", property_get_roles },
{ "ExperimentalFeatures", "as", property_get_experimental, NULL,
@@ -3931,6 +3966,7 @@ static const GDBusPropertyTable adapter_properties[] = {
property_experimental_exists },
{ "Manufacturer", "q", property_get_manufacturer },
{ "Version", "y", property_get_version },
+ { "DelayReport", "b", property_get_delay_report_feature, property_set_delay_report_feature },
{ }
};

@@ -5276,6 +5312,11 @@ bool btd_adapter_get_bredr(struct btd_adapter *adapter)
@@ -5317,6 +5353,11 @@ bool btd_adapter_get_bredr(struct btd_adapter *adapter)
return false;
}

@@ -242,7 +242,7 @@ index 5ebfc4752..e2b66e1d3 100644
struct btd_gatt_database *btd_adapter_get_database(struct btd_adapter *adapter)
{
if (!adapter)
@@ -6817,6 +6858,15 @@ static void load_config(struct btd_adapter *adapter)
@@ -6858,6 +6899,15 @@ static void load_config(struct btd_adapter *adapter)
gerr = NULL;
}

@@ -258,15 +258,15 @@ index 5ebfc4752..e2b66e1d3 100644
g_key_file_free(key_file);
}

@@ -6853,6 +6903,7 @@ static struct btd_adapter *btd_adapter_new(uint16_t index)
@@ -6894,6 +6944,7 @@ static struct btd_adapter *btd_adapter_new(uint16_t index)
btd_opts.did_version);
adapter->discoverable_timeout = btd_opts.discovto;
adapter->pairable_timeout = btd_opts.pairto;
+ adapter->delay_report = btd_opts.delay_report;

DBG("System name: %s", adapter->system_name);
DBG("Major class: %u", adapter->major_class);
@@ -6863,6 +6914,7 @@ static struct btd_adapter *btd_adapter_new(uint16_t index)
@@ -6904,6 +6955,7 @@ static struct btd_adapter *btd_adapter_new(uint16_t index)
if (blocked > 0)
DBG("Power state: %s",
adapter_power_state_str(adapter->power_state));
@@ -308,7 +308,7 @@ index b7e7ebd61..176689859 100644
uint16_t did_source;
uint16_t did_vendor;
diff --git a/src/main.c b/src/main.c
index 2134fcf75..a8cb58ffb 100644
index b1339c230..dcccd030e 100644
--- a/src/main.c
+++ b/src/main.c
@@ -82,6 +82,7 @@ static const char *supported_options[] = {
@@ -319,7 +319,7 @@ index 2134fcf75..a8cb58ffb 100644
"Privacy",
"JustWorksRepairing",
"TemporaryTimeout",
@@ -1032,6 +1033,9 @@ static void parse_general(GKeyFile *config)
@@ -1036,6 +1037,9 @@ static void parse_general(GKeyFile *config)
parse_config_u32(config, "General", "RemoteNameRequestRetryDelay",
&btd_opts.name_request_retry_delay,
0, UINT32_MAX);
@@ -330,7 +330,7 @@ index 2134fcf75..a8cb58ffb 100644

static void parse_gatt_cache(GKeyFile *config)
diff --git a/src/main.conf b/src/main.conf
index d108934a8..81225861c 100644
index 085c81a46..b3ce9a69a 100644
--- a/src/main.conf
+++ b/src/main.conf
@@ -69,6 +69,9 @@
Original file line number Diff line number Diff line change
@@ -24,10 +24,10 @@ Upstream-Status: Inappropriate [webos specific]
1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/src/device.c b/src/device.c
index fd26b6057..fa8d310b2 100644
index d4f67eb03..53628b290 100644
--- a/src/device.c
+++ b/src/device.c
@@ -7414,9 +7414,11 @@ static void service_state_changed(struct btd_service *service,
@@ -7429,9 +7429,11 @@ static void service_state_changed(struct btd_service *service,
new_state == BTD_SERVICE_STATE_DISCONNECTING)
return;

Original file line number Diff line number Diff line change
@@ -23,10 +23,10 @@ Upstream-Status: Inappropriate [webos specific]
1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/src/device.c b/src/device.c
index fa8d310b2..8bb363d25 100644
index 53628b290..7cd991748 100644
--- a/src/device.c
+++ b/src/device.c
@@ -2783,7 +2783,10 @@ static void device_profile_disconnected(struct btd_device *dev,
@@ -2793,7 +2793,10 @@ static void device_profile_disconnected(struct btd_device *dev,
DBG("%s %s (%d)", profile->name, strerror(-err), -err);
if (!err) {
if (dev->connected_uuids)
Original file line number Diff line number Diff line change
@@ -28,10 +28,10 @@ Upstream-Status: Inappropriate [webos specific]
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/src/device.c b/src/device.c
index 8bb363d25..cdec9900a 100644
index 7cd991748..150d0745a 100644
--- a/src/device.c
+++ b/src/device.c
@@ -2203,13 +2203,13 @@ static void device_profile_connected(struct btd_device *dev,
@@ -2213,13 +2213,13 @@ static void device_profile_connected(struct btd_device *dev,

DBG("%s %s (%d)", profile->name, strerror(-err), -err);

Original file line number Diff line number Diff line change
@@ -38,7 +38,7 @@ index f3f2009f4..4f17740da 100644
if (!session->controller || !session->controller->player)
return FALSE;
diff --git a/src/device.c b/src/device.c
index cdec9900a..b9a28ef05 100644
index 150d0745a..df0aa3f7e 100644
--- a/src/device.c
+++ b/src/device.c
@@ -300,6 +300,7 @@ struct btd_device {
@@ -49,7 +49,7 @@ index cdec9900a..b9a28ef05 100644
};

static const uint16_t uuid_list[] = {
@@ -1538,6 +1539,17 @@ static gboolean dev_property_get_key_code(const GDBusPropertyTable *property,
@@ -1531,6 +1532,17 @@ static gboolean dev_property_get_key_code(const GDBusPropertyTable *property,
return TRUE;
}

@@ -67,7 +67,7 @@ index cdec9900a..b9a28ef05 100644
static gboolean dev_property_get_avrcp_ct_feature(const GDBusPropertyTable *property,
DBusMessageIter *iter, void *data)
{
@@ -2366,6 +2378,14 @@ void set_avrcp_feature(struct btd_device *dev, uint8_t feature, bool is_controll
@@ -2376,6 +2388,14 @@ void set_avrcp_feature(struct btd_device *dev, uint8_t feature, bool is_controll
}
}

@@ -82,7 +82,7 @@ index cdec9900a..b9a28ef05 100644
static void add_service_data(void *data, void *user_data)
{
struct eir_sd *sd = data;
@@ -3414,6 +3434,7 @@ static const GDBusPropertyTable device_properties[] = {
@@ -3424,6 +3444,7 @@ static const GDBusPropertyTable device_properties[] = {
NULL, dev_property_avrcp_ct_feature_exist},
{ "AvrcpTGFeatures", "y", dev_property_get_avrcp_tg_feature,
NULL, dev_property_avrcp_tg_feature_exist},
Original file line number Diff line number Diff line change
@@ -24,7 +24,7 @@ Upstream-Status: Inappropriate [webos specific]
1 file changed, 167 insertions(+), 1 deletion(-)

diff --git a/src/device.c b/src/device.c
index b9a28ef05..7e94e505a 100644
index df0aa3f7e..4a774cd03 100644
--- a/src/device.c
+++ b/src/device.c
@@ -235,6 +235,8 @@ struct btd_device {
@@ -36,15 +36,15 @@ index b9a28ef05..7e94e505a 100644
GSList *connected_uuids;
GSList *primaries; /* List of primary services */
GSList *services; /* List of btd_service */
@@ -449,6 +451,7 @@ static gboolean store_device_info_cb(gpointer user_data)
@@ -442,6 +444,7 @@ static gboolean store_device_info_cb(gpointer user_data)
char *str;
char class[9];
char **uuids = NULL;
+ char **mapInstances = NULL;
gsize length = 0;

device->store_id = 0;
@@ -517,6 +520,35 @@ static gboolean store_device_info_cb(gpointer user_data)
@@ -510,6 +513,35 @@ static gboolean store_device_info_cb(gpointer user_data)
g_key_file_remove_key(key_file, "General", "Services", NULL);
}

@@ -80,15 +80,15 @@ index b9a28ef05..7e94e505a 100644
if (device->vendor_src) {
g_key_file_set_integer(key_file, "DeviceID", "Source",
device->vendor_src);
@@ -559,6 +591,7 @@ static gboolean store_device_info_cb(gpointer user_data)
@@ -552,6 +584,7 @@ static gboolean store_device_info_cb(gpointer user_data)

g_key_file_free(key_file);
g_free(uuids);
+ g_free(mapInstances);

return FALSE;
}
@@ -828,6 +861,10 @@ static void device_free(gpointer user_data)
@@ -821,6 +854,10 @@ static void device_free(gpointer user_data)
g_slist_free_full(device->uuids, g_free);
g_slist_free_full(device->primaries, g_free);
g_slist_free_full(device->svc_callbacks, svc_dev_remove);
@@ -99,7 +99,7 @@ index b9a28ef05..7e94e505a 100644

/* Reset callbacks since the device is going to be freed */
gatt_db_unregister(device->db, device->db_id);
@@ -1399,6 +1436,46 @@ static gboolean dev_property_get_uuids(const GDBusPropertyTable *property,
@@ -1392,6 +1429,46 @@ static gboolean dev_property_get_uuids(const GDBusPropertyTable *property,
return TRUE;
}

@@ -146,7 +146,7 @@ index b9a28ef05..7e94e505a 100644
static gboolean dev_property_get_modalias(const GDBusPropertyTable *property,
DBusMessageIter *iter, void *data)
{
@@ -3451,6 +3528,8 @@ static const GDBusPropertyTable device_properties[] = {
@@ -3461,6 +3538,8 @@ static const GDBusPropertyTable device_properties[] = {
dev_property_wake_allowed_exist },
{ "Sets", "a{oa{sv}}", dev_property_get_set, NULL,
dev_property_set_exists },
@@ -155,7 +155,7 @@ index b9a28ef05..7e94e505a 100644
{ }
};

@@ -3828,6 +3907,32 @@ static void load_services(struct btd_device *device, char **uuids)
@@ -3840,6 +3919,32 @@ static void load_services(struct btd_device *device, char **uuids)
g_strfreev(uuids);
}

@@ -188,7 +188,7 @@ index b9a28ef05..7e94e505a 100644
static void convert_info(struct btd_device *device, GKeyFile *key_file)
{
char filename[PATH_MAX];
@@ -3880,7 +3985,7 @@ static void load_info(struct btd_device *device, const char *local,
@@ -3892,7 +3997,7 @@ static void load_info(struct btd_device *device, const char *local,
gboolean store_needed = FALSE;
gboolean blocked;
gboolean wake_allowed;
@@ -197,7 +197,7 @@ index b9a28ef05..7e94e505a 100644
int source, vendor, product, version;
char **techno, **t;

@@ -3978,6 +4083,23 @@ next:
@@ -3990,6 +4095,23 @@ next:
device->bredr_state.svc_resolved = true;
}

@@ -221,7 +221,7 @@ index b9a28ef05..7e94e505a 100644
/* Load device id */
source = g_key_file_get_integer(key_file, "DeviceID", "Source", NULL);
if (source) {
@@ -5280,6 +5402,29 @@ static int update_record(struct browse_req *req, const char *uuid,
@@ -5295,6 +5417,29 @@ static int update_record(struct browse_req *req, const char *uuid,
return 0;
}

@@ -251,7 +251,7 @@ index b9a28ef05..7e94e505a 100644
static void update_bredr_services(struct browse_req *req, sdp_list_t *recs)
{
struct btd_device *device = req->device;
@@ -5337,6 +5482,23 @@ static void update_bredr_services(struct browse_req *req, sdp_list_t *recs)
@@ -5352,6 +5497,23 @@ static void update_bredr_services(struct browse_req *req, sdp_list_t *recs)
if (!profile_uuid)
continue;

@@ -275,7 +275,7 @@ index b9a28ef05..7e94e505a 100644
if (bt_uuid_strcmp(profile_uuid, PNP_UUID) == 0) {
uint16_t source, vendor, product, version;
sdp_data_t *pdlist;
@@ -5515,6 +5677,10 @@ static void search_cb(sdp_list_t *recs, int err, gpointer user_data)
@@ -5530,6 +5692,10 @@ static void search_cb(sdp_list_t *recs, int err, gpointer user_data)
/* Propagate services changes */
g_dbus_emit_property_changed(dbus_conn, req->device->path,
DEVICE_INTERFACE, "UUIDs");
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From d8d5b1de4d9a08fc5d3a4976029739334090dddd Mon Sep 17 00:00:00 2001
From 46b68afb4a44acd6d4c6fc7b459f80d55650b7c7 Mon Sep 17 00:00:00 2001
From: Vibhanshu Dhote <vibhanshu.dhote@lge.com>
Date: Tue, 28 Jul 2020 16:04:27 +0530
Subject: [PATCH] Disabling DB Hash for Gatt
Original file line number Diff line number Diff line change
@@ -9,6 +9,18 @@ Added Notification property in org.bluez.obex.MessageAccess1
:Detailed Notes:
New Properties Notification is added for MAP.

Move the obex-api changes to doc/org.bluez.obex.MessageAccess.rst
but they still need to be converted to rst formatting as other
files were in:
commit 345ad5e352b1b77c18ceecb06523a0d1352dee38
Author: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
Date: Thu Oct 12 13:20:44 2023 -0700

doc/obex-*-api: Rename to org.bluez.obex.*.rst

This renames obex-*-api.txt to org.bluez.obex.*.rst and generate
manpages org.bluez.obex.*.5.

:QA Notes:
NA

@@ -17,18 +29,19 @@ NA
---
Upstream-Status: Inappropriate [webos specific]

doc/obex-api.txt | 48 ++++++++++++++
obexd/client/map.c | 153 ++++++++++++++++++++++++++++++++++++++++++++-
2 files changed, 198 insertions(+), 3 deletions(-)
doc/org.bluez.obex.MessageAccess.rst | 49 +++++++++
obexd/client/map.c | 153 ++++++++++++++++++++++++++-
2 files changed, 199 insertions(+), 3 deletions(-)

diff --git a/doc/obex-api.txt b/doc/obex-api.txt
index f39355af0..85301dcda 100644
--- a/doc/obex-api.txt
+++ b/doc/obex-api.txt
@@ -799,6 +799,54 @@ Filter: uint16 Offset:
Possible values: True for high priority or False for
non-high priority
diff --git a/doc/org.bluez.obex.MessageAccess.rst b/doc/org.bluez.obex.MessageAccess.rst
index 4f7f07d1b..2508ecdfc 100644
--- a/doc/org.bluez.obex.MessageAccess.rst
+++ b/doc/org.bluez.obex.MessageAccess.rst
@@ -199,3 +199,52 @@ object, dict PushMessage(string sourcefile, string folder, dict args)

:org.bluez.obex.Error.InvalidArguments:
:org.bluez.obex.Error.Failed:
+
+Properties dict Notification [readonly]
+
+ Notification data contains list of below property
@@ -77,9 +90,6 @@ index f39355af0..85301dcda 100644
+
+ Message Priority, only available for "NewMessage"
+
Message hierarchy
=================

diff --git a/obexd/client/map.c b/obexd/client/map.c
index 2eb2c17a6..ada9377b8 100644
--- a/obexd/client/map.c
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 15f90c1ce644fc1121c68b1224a0f2f659bb29bf Mon Sep 17 00:00:00 2001
From 1229b7c218debbd4dde9c5e0247fff9b961a108d Mon Sep 17 00:00:00 2001
From: "ramya.hegde" <ramya.hegde@lge.com>
Date: Mon, 25 Jan 2021 16:27:58 +0530
Subject: [PATCH] Add support for meshd to use RAW channel
@@ -105,7 +105,7 @@ index 145bcfa98..489bbef64 100644
usage();
status = EXIT_SUCCESS;
diff --git a/mesh/mesh-io-generic.c b/mesh/mesh-io-generic.c
index 00932ade7..f50d282f7 100644
index 13a863b48..ccb396a7d 100644
--- a/mesh/mesh-io-generic.c
+++ b/mesh/mesh-io-generic.c
@@ -38,6 +38,7 @@ struct mesh_io_private {
Original file line number Diff line number Diff line change
@@ -25,10 +25,10 @@ Upstream-Status: Inappropriate [webos specific]
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Makefile.am b/Makefile.am
index 93931d121..d9a2d2921 100644
index e7221bd61..41de3fa0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -698,7 +698,7 @@ ell/internal: Makefile
@@ -802,7 +802,7 @@ ell/internal: Makefile
fi \
done > $@

0 comments on commit 78248c9

Please sign in to comment.