Skip to content

Commit

Permalink
webos: systemd: update patches to apply on v257
Browse files Browse the repository at this point in the history
:Release Notes:
Upgraded in:
https://git.openembedded.org/openembedded-core/commit/?id=4891f47cdaf919033bf1c02cc12e4805e5db99a0

:Detailed Notes:
Fixes:
http://gecko.lge.com:8000/Errors/Details/1077222

ERROR: Applying patch '0002-Add-webos-interface.patch' on target directory 'TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/systemd/257.1/git'
CmdError('quilt --quiltrc TOPDIR/BUILD/work/raspberrypi4_64-webos-linux/systemd/257.1/recipe-sysroot-native/etc/quiltrc push', 0, 'stdout: Applying patch 0002-Add-webos-interface.patch
patching file src/oom/com.webos.MemoryManager1.conf
patching file src/oom/meson.build
patching file src/oom/oomd-manager.c
Hunk #1 FAILED at 16.
Hunk #2 succeeded at 394 (offset -3 lines).
Hunk webosose#3 succeeded at 520 (offset -3 lines).
1 out of 3 hunks FAILED -- rejects in file src/oom/oomd-manager.c
patching file src/oom/oomd.c
Hunk #2 succeeded at 224 (offset 35 lines).
patching file src/oom/webos-manager-bus.c
patching file src/oom/webos-manager-bus.h
patching file src/oom/webos-manager.c
patching file src/oom/webos-manager.h
patching file units/systemd-oomd.service.in
Patch 0002-Add-webos-interface.patch does not apply (enforce with -f)

stderr: ')

:Testing Performed:
Only build tested.

:QA Notes:
No change to image.

:Issues Addressed:
[WRR-5443] Create GPVB with Yocto 5.2 Walnascar

Change-Id: Ie249b05060a60f8a0c176ae25af051dbea4767ce
  • Loading branch information
shr-project committed Jan 20, 2025
1 parent 43d1e59 commit 807d881
Show file tree
Hide file tree
Showing 6 changed files with 18 additions and 21 deletions.
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From a23bcc49098ce6fb92192367d0d074618ed0c97c Mon Sep 17 00:00:00 2001
From befc72d85e76226a2804c6f03cac32ac9f9bb72a Mon Sep 17 00:00:00 2001
From: Hotaek Jung <[email protected]>
Date: Mon, 12 Jul 2021 19:16:26 +0900
Subject: [PATCH] systemd-oomd: depend on swap-on
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 736a50f53946119b90b91ba75f1bcab19b3dc16a Mon Sep 17 00:00:00 2001
From 32dcb39c1d7217a442ad137e93a6a2b0a2140eca Mon Sep 17 00:00:00 2001
From: Hotaek Jung <[email protected]>
Date: Mon, 12 Jul 2021 19:16:26 +0900
Subject: [PATCH] Add webos interface
Expand Down Expand Up @@ -93,19 +93,19 @@ index 690ed7ac6b..83e605313f 100644
install_dir : dbussystemservicedir)

diff --git a/src/oom/oomd-manager.c b/src/oom/oomd-manager.c
index 6081254b3d..6ee1465bb9 100644
index baa88a2f2a..9cca9f7ade 100644
--- a/src/oom/oomd-manager.c
+++ b/src/oom/oomd-manager.c
@@ -16,6 +16,8 @@
#include "path-util.h"
@@ -19,6 +19,8 @@
#include "percent-util.h"
#include "varlink-io.systemd.oom.h"
#include "varlink-util.h"
+#include "webos-manager.h"
+#include "webos-manager-bus.h"

typedef struct ManagedOOMMessage {
ManagedOOMMode mode;
@@ -397,6 +399,9 @@ static int monitor_swap_contexts_handler(sd_event_source *s, uint64_t usec, void
@@ -394,6 +396,9 @@ static int monitor_swap_contexts_handler(sd_event_source *s, uint64_t usec, void
m->system_context.swap_used, m->system_context.swap_total,
PERMYRIAD_AS_PERCENT_FORMAT_VAL(m->swap_used_limit_permyriad));

Expand All @@ -115,7 +115,7 @@ index 6081254b3d..6ee1465bb9 100644
r = get_monitored_cgroup_contexts_candidates(m->monitored_swap_cgroup_contexts, &candidates);
if (r == -ENOMEM)
return log_oom();
@@ -520,6 +525,8 @@ static int monitor_memory_pressure_contexts_handler(sd_event_source *s, uint64_t
@@ -517,6 +522,8 @@ static int monitor_memory_pressure_contexts_handler(sd_event_source *s, uint64_t
log_debug_errno(r, "Failed to update monitored memory pressure candidate cgroup contexts, ignoring: %m");
else
clear_candidates = NULL;
Expand All @@ -125,7 +125,7 @@ index 6081254b3d..6ee1465bb9 100644
r = oomd_kill_by_pgscan_rate(m->monitored_mem_pressure_cgroup_contexts_candidates,
/* prefix= */ t->path,
diff --git a/src/oom/oomd.c b/src/oom/oomd.c
index ecc2eda5dc..b8e8e445f0 100644
index dd34251cd2..feedf6bd06 100644
--- a/src/oom/oomd.c
+++ b/src/oom/oomd.c
@@ -17,6 +17,8 @@
Expand All @@ -137,7 +137,7 @@ index ecc2eda5dc..b8e8e445f0 100644

static bool arg_dry_run = false;
static int arg_swap_used_limit_permyriad = -1;
@@ -187,6 +189,9 @@ static int run(int argc, char *argv[]) {
@@ -222,6 +224,9 @@ static int run(int argc, char *argv[]) {

log_debug("systemd-oomd started%s.", arg_dry_run ? " in dry run mode" : "");

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From fe8a4508b9c0e9764a1b7350f7a68f70439df90a Mon Sep 17 00:00:00 2001
From e06ec65f0f925fc4fea3b7899e125afd17cb84c0 Mon Sep 17 00:00:00 2001
From: Hotaek Jung <[email protected]>
Date: Mon, 12 Jul 2021 19:16:26 +0900
Subject: [PATCH] systemd-oomd: modify oomd.conf
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 5127e9277f8d6b99dfb4a3d11f763c2d365b47b8 Mon Sep 17 00:00:00 2001
From 4fbc471744a265744b210ceb01b92f3bdbe103f7 Mon Sep 17 00:00:00 2001
From: Hotaek Jung <[email protected]>
Date: Tue, 23 Nov 2021 10:42:42 +0900
Subject: [PATCH] oomd: to some
Expand All @@ -9,10 +9,10 @@ Upstream-Status: Pending
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/oom/oomd-util.c b/src/oom/oomd-util.c
index f9f0af2d04..45c9d715a5 100644
index b996787039..77e620f549 100644
--- a/src/oom/oomd-util.c
+++ b/src/oom/oomd-util.c
@@ -404,7 +404,7 @@ int oomd_cgroup_context_acquire(const char *path, OomdCGroupContext **ret) {
@@ -421,7 +421,7 @@ int oomd_cgroup_context_acquire(const char *path, OomdCGroupContext **ret) {
if (r < 0)
return log_debug_errno(r, "Error getting cgroup memory pressure path from %s: %m", path);

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From cc0817d1a482d54f9136d5f3e0d190909ce3ec98 Mon Sep 17 00:00:00 2001
From 2a4210c7c8a4bc0fb27b81085d4b6becb03a40f1 Mon Sep 17 00:00:00 2001
From: Hotaek Jung <[email protected]>
Date: Tue, 23 Nov 2021 10:42:42 +0900
Subject: [PATCH] oomd: change duration
Expand All @@ -9,7 +9,7 @@ Upstream-Status: Pending
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/oom/oomd-manager.h b/src/oom/oomd-manager.h
index 8f0dd412da..6120621f74 100644
index 635e16ddfc..850429b704 100644
--- a/src/oom/oomd-manager.h
+++ b/src/oom/oomd-manager.h
@@ -25,7 +25,7 @@
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 52f65c0868cb665a3212b884398642f842318caa Mon Sep 17 00:00:00 2001
From fee73657866b733110bae92151745b90eab72c05 Mon Sep 17 00:00:00 2001
From: "gaurav.mahajan" <[email protected]>
Date: Mon, 22 May 2023 15:47:15 +0530
Subject: [PATCH] Change ownership of media directory to support non-root media
Expand All @@ -13,14 +13,11 @@ Upstream-Status: Inappropriate [webOS specific]
1 file changed, 1 insertion(+)

diff --git a/tmpfiles.d/systemd.conf.in b/tmpfiles.d/systemd.conf.in
index 11a45a3f4b..a1fa787c1d 100644
index 6436400cde..e29b4ca50d 100644
--- a/tmpfiles.d/systemd.conf.in
+++ b/tmpfiles.d/systemd.conf.in
@@ -68,6 +68,7 @@ d /var/lib/systemd/ephemeral-trees 0755 root root 0
@@ -65,3 +65,4 @@ d /var/lib/systemd/ephemeral-trees 0755 root root 0
d /var/lib/private 0700 root root -
d /var/log/private 0700 root root -
d /var/cache/private 0700 root root -
+d /media 0775 media media -

{% if ENABLE_EFI %}
# Copy sd-stub provided PCR signature and public key file from initrd into /run/, so that it will survive the initrd stage

0 comments on commit 807d881

Please sign in to comment.