Skip to content

Commit

Permalink
[new package] python-aenum 3.1.15 (msys2#23421)
Browse files Browse the repository at this point in the history
* [new package] python-aenum 3.1.15

* use purl

---------

Co-authored-by: Christoph Reiter <[email protected]>
  • Loading branch information
fsagbuya and lazka authored Feb 18, 2025
1 parent 2359be4 commit 70ba0e2
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions mingw-w64-python-aenum/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Maintainer: fsagbuya <[email protected]>

_realname=aenum
pkgbase=mingw-w64-python-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-python-${_realname}")
pkgver=3.1.15
pkgrel=1
pkgdesc="Advanced Enumerations (compatible with Python's stdlib Enum), NamedTuples, and NamedConstants (mingw-w64)"
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64')
url="https://github.com/ethanfurman/aenum"
msys2_references=(
'purl: pkg:pypi/aenum'
)
license=('spdx:BSD-3-Clause')
depends=("${MINGW_PACKAGE_PREFIX}-python")
makedepends=("${MINGW_PACKAGE_PREFIX}-python-build"
"${MINGW_PACKAGE_PREFIX}-python-installer"
"${MINGW_PACKAGE_PREFIX}-python-setuptools")
options=('!strip')
source=("https://pypi.org/packages/source/${_realname::1}/${_realname}/${_realname}-${pkgver}.tar.gz")
sha256sums=('8cbd76cd18c4f870ff39b24284d3ea028fbe8731a58df3aa581e434c575b9559')

build() {
cp -r "${_realname}-${pkgver}" "python-build-${MSYSTEM}" && cd "python-build-${MSYSTEM}"

python -m build --wheel --skip-dependency-check --no-isolation
}

package() {
cd "python-build-${MSYSTEM}"

MSYS2_ARG_CONV_EXCL="--prefix=" \
python -m installer --prefix=${MINGW_PREFIX} \
--destdir="${pkgdir}" dist/*.whl

install -Dm644 aenum/LICENSE "${pkgdir}${MINGW_PREFIX}/share/licenses/python-${_realname}/LICENSE"
}

0 comments on commit 70ba0e2

Please sign in to comment.