Skip to content

Commit

Permalink
userland: refresh patch
Browse files Browse the repository at this point in the history
:Release Notes:
New Yocto is more strict about applying patches which don't apply
cleanly.

:Detailed Notes:
WARNING: userland-20180130-r0 do_patch:
Some of the context lines in patches were ignored. This can lead to incorrectly applied patches.
The context lines in the patches can be updated with devtool:

    devtool modify <recipe>
    devtool finish --force-patch-refresh <recipe> <layer_path>

Then the updated patches and the source tree (in devtool's workspace)
should be reviewed to make sure the patches apply in the correct place
and don't introduce duplicate lines (which can, and does happen
when some of the context is ignored). Further information:
http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450
Details:
Applying patch 0001-Remove-EGL-dependency.patch
patching file CMakeLists.txt
patching file host_applications/linux/CMakeLists.txt
patching file interface/vmcs_host/CMakeLists.txt
patching file makefiles/cmake/vmcs.cmake
Hunk #1 succeeded at 74 with fuzz 1 (offset 1 line).
patching file middleware/openmaxil/CMakeLists.txt
patching file pkgconfig/openmaxil.pc.in

Now at patch 0001-Remove-EGL-dependency.patch

:Testing Performed:
Only build tested.

:QA Notes:
No change to image.

:Issues Addressed:
[PLAT-52479] Upgrade to Yocto 2.5 Sumo
[PLAT-78511] [OSE] CCC: Upgrade to Yocto 2.5 Sumo

Change-Id: I9092222060c35d6091f2300533ab4c791144d0ee
  • Loading branch information
shr-project authored and Minjae Kim committed Jun 24, 2019
1 parent d3cfc89 commit 16db970
Show file tree
Hide file tree
Showing 2 changed files with 5 additions and 8 deletions.
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
From 961b1cec9296b070b7a6f2fc5e9766d2c2e53d4c Mon Sep 17 00:00:00 2001
From 24b67015c46c2cf6d608628141aa18b47677b8d7 Mon Sep 17 00:00:00 2001
From: Changhyeok Bae <[email protected]>
Date: Tue, 27 Jun 2017 21:22:05 +0900
Subject: [PATCH] Remove EGL dependency
Expand Down Expand Up @@ -144,11 +144,11 @@ index fde18da..e0cd3ef 100755
# vchostif needs ilcore as well (vmcs_main pulls it in)
target_link_libraries(vchostif vchiq_arm vcos vcfiled_check)
diff --git a/makefiles/cmake/vmcs.cmake b/makefiles/cmake/vmcs.cmake
index 718cd3b..90a3ec7 100644
index 7c97463..4a3b348 100644
--- a/makefiles/cmake/vmcs.cmake
+++ b/makefiles/cmake/vmcs.cmake
@@ -73,8 +73,8 @@ install(DIRECTORY ${vmcs_root}/interface/vctypes DESTINATION ${VMCS_INSTALL_PR
install(DIRECTORY ${vmcs_root}/vcinclude DESTINATION ${VMCS_INSTALL_PREFIX}/include FILES_MATCHING PATTERN "*.h")
@@ -74,8 +74,8 @@ install(DIRECTORY ${vmcs_root}/vcinclude DESTINATION ${VMCS_INSTALL_PR
install(DIRECTORY ${vmcs_root}/interface/peer DESTINATION ${VMCS_INSTALL_PREFIX}/include/interface FILES_MATCHING PATTERN "*.h")
install(DIRECTORY ${vmcs_root}/interface/vmcs_host DESTINATION ${VMCS_INSTALL_PREFIX}/include/interface FILES_MATCHING PATTERN "*.h" PATTERN "${vmcs_root}/interface/vmcs_host/khronos" EXCLUDE)

-install(DIRECTORY ${vmcs_root}/interface/khronos/include DESTINATION ${VMCS_INSTALL_PREFIX} FILES_MATCHING PATTERN "*.h")
Expand Down Expand Up @@ -185,6 +185,3 @@ index 0000000..8793a61
+Version: 1
+Libs: -L${libdir} -lopenmaxil -lvcos -lvchiq_arm -pthread
+Cflags: -I${includedir} -I${includedir}/IL -I${includedir}/interface/vmcs_host/linux -I${includedir}/interface/vcos/pthreads -DUSE_VCHIQ_ARM
--
1.9.1

Original file line number Diff line number Diff line change
Expand Up @@ -35,7 +35,7 @@ SRC_URI_remove = "\
# file://0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch
# file://0015-EGL-glplatform.h-define-EGL_CAST.patch

FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
SRC_URI_append = " file://0001-Remove-EGL-dependency.patch"

VIRTUAL-RUNTIME_bash ?= "bash"
Expand Down

0 comments on commit 16db970

Please sign in to comment.