forked from jsonn/pkgsrc
-
Notifications
You must be signed in to change notification settings - Fork 62
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
(and add gtk3, gdk3, gtksourceview3 and gobject-introspection binding). based on PR 47529. == Ruby-GNOME2 1.2.1: 2013-01-30 GTK+ 3 support on Mac OS X release! === Changes ==== Ruby/GLib2 * Improvements * Supported custom sudo prompt on auto native package install. [GitHub:126] [Suggested by Yorick Peterse] * Started to support JRuby. (It is not completed yet.) [GitHub:125] [Reported by vpereira] * Accepted unsigned long int size GType. * Removed DL support. * Don't call deprecated g_type_init() for GLib >= 2.35.1. ==== Ruby/GTK2 * Fixes * Fixed a memory leak related Gtk::TreeIter. [GitHub:128] [Patch by Toshiaki Asai] ==== Ruby/GTK3 * Fixes * Fixed a memory leak related Gtk::TreeIter. [GitHub:128] [Patch by Toshiaki Asai] * Fixed a crash bug caused by symbol conflict with Ruby/GDK3 on Mac OS X. [GitHub:127] [Reported by Sergio Campama] [Helped by Watson] ==== Ruby/GDK3 * Improvements * [windows] Bundled Greybird theme. [Suggested by Regis d'Aubarede] ==== Ruby/GooCanvas * Improvements * Added Goo::Canvas#get_items_at [GitHub:124] [Patch by David Maciejak] ==== Ruby/WebKitGTK * Added ==== Ruby/GtkSourceView3 * Improvements * Supported Windows. === Thanks * David Maciejak * Yorick Peterse * vpereira * Toshiaki Asai * Sergio Campama * Watson * Regis d'Aubarede == Ruby-GNOME2 1.2.0: 2013-01-24 GTK+ 3 support release! === Changes ==== All * Added ruby-gtk3 package. Here is a list: * Ruby/GLib2 * Ruby/ATK * Ruby/Pango * Ruby/GdkPixbuf2 * Ruby/GDK3 * Ruby/GTK3 ==== Ruby/GLib2 * Improvements * Supported custom VALUE <-> GBoxed conversion * Supported VALUE <-> GBoxed conversion by RVAL2GOBJ * Added GLib::Source::REMOVE * Added GLib::Source::CONTINUE * Added rbgobj_make_boxed_raw() * Added GLib::Value for internal use * [windows] Updated to the latest GLib: 2.28.8-1 -> 2.34.3 * Changes * Removed deprecated GLib::Win32.get_package_installation_directory * Removed deprecated GLib::Win32.get_package_installation_subdirectory * Added user_data to RGConvertTable callbacks * rbgobj_convert_define() copies passed RGConvertTable * Removed deprecated G_DEF_FUNDAMENTAL. Use RG_DEF_CONVERSION instead ==== Ruby/GIO2 * Improvements * Installed headers ==== Ruby/ATK * Improvements * [windows] Updated to the latest ATK: 1.32.0 -> 2.6.0 ==== Ruby/Pango * Improvements * [windows] Updated to the latest Pango: 1.28.3 -> 1.32.6 ==== Ruby/GdkPixbuf2 * Improvements * [windows] Updated to the latest gdk-pixbuf: 2.24.0 -> 2.26.5 ==== Ruby/GTK2 * Improvements * Removed needless not copy flag from Allocation * [windows] Updated to the latest GTK+ 2: 2.24.8 -> 2.24.14 ==== Ruby/GDK3 * Improvements * [windows] Supported: 3.6.4 ==== Ruby/GTK3 * Improvements * Removed needless not copy flag from Allocation * [windows] Supported: 3.6.4 ==== Ruby/GObjectIntrospection * Improvements * Supported over loaded method * Supported over loaded constructor * Supported GBoxed object * Supported char * * Supported GInterface * Supported CallableInfo * Supported may be null * Supported union object * Supported not GBoxed struct * Supported out parameter * Supported C array * Added "?" suffix to predicate method name * Supported SourceFunc callback * Supported GValue * Added GObjectIntrospection::Loader.register_boxed_class_converter * Supported inout parameter * Supported binary data array * Changes * ArgInfo#[] -> ArgInfo#get_arg ==== Ruby/CairoGObject * Added ==== Ruby/Clutter * Added ==== Ruby/ClutterGtk * Added == Ruby-GNOME2 1.1.9: 2012-12-29 This is a experimental GObjectIntrospection support release. === Changes ==== Ruby/GLib2 * Improvements * Renamed G_DEF_CLASS4 to G_DEF_CLASS_WITH_PARENT. G_DEF_CLASS4 is still usable but it is deprecated. ==== Ruby/GObjectIntrospection * Added. It is still experimental. == Ruby-GNOME2 1.1.8: 2012-12-19 This is a bug fix release for Ruby 2.0.0. === Changes ==== All * Fixes * Fixed a bug that *.so isn't installed with Ruby 2.0.0. == Ruby-GNOME2 1.1.7: 2012-12-10 This is a package for Windows fix release. === Changes ==== Ruby/GTK2 * Fixes * Bundled GTK+ 2.24.8-1 instead of GTK+ 2.24.10-1. [Reported by Mahoro Shimura] === Thanks * Mahoro Shimura == Ruby-GNOME2 1.1.6: 2012-12-02 This is Ruby 2.0.0 support release! === Changes ==== All * Fixes * Fixed install error on Ruby 2.0.0. [ruby-gnome2-devel-en] Recent Ruby: 'depend' files must be changed [Reported by Carlo E. Prelz] ==== Ruby/GLib2 * Improvements * Improved portability a bit. '$,' is used instead of rb_output_fs. [GktHub:#117] [Reported by Marvin Gülker] ==== Ruby/GIO2 * Fixes * Fixed a crash bug on i386. [Reported by TAKATSU Tomonari] ==== Ruby/GTK2 * Improvements * Added Gtk::TreeModel#iter_root. [GitHub:121] [Patch by dmaciejak] * Added Gtk::TreeModel#iter_next. [GitHub:121] [Patch by dmaciejak] ==== Ruby/GdkPixbuf2 * Fixes * Fixed build errors with old gdk-pixbuf. ==== Ruby/Poppler * Improvements * Added missing required Poppler version. [Suggested by Grant Schoep] [ruby-gnome2-devel-en] poppler, build fails, incorrect required_pkg_config_package? * Fixes * Fixed a wrong package name on Red Hat and Fedora. [Reported by Grant Schoep] [ruby-gnome2-devel-en] poppler, build fails, incorrect required_pkg_config_package? * Changes * Disabled auto Poppler install for Homebrew. It requires --with-glib option but auto install with --with-glib option isn't supported yet. ==== Ruby/GooCanvas * Improvements * Added Goo::Canvas#update. [GitHub:119] [Patch by dmaciejak] * Added Goo::Canvas#request_update. [GitHub:119] [Patch by dmaciejak] * Added Goo::Canvas#convert_from_pixels. [GitHub:123] [Patch by dmaciejak] * Added Goo::Canvas#convert_to_pixels. [GitHub:123] [Patch by dmaciejak] * Added Goo::Canvas#get_item_at. [GitHub:123] [Patch by dmaciejak] * Added Goo::Canvas#bounds. [GitHub:123] [Patch by dmaciejak] ==== Ruby/GStreamer * Improvements * Don't pass -h and --help to GStreamer. [GitHub:#118] [Reported by dmaciejak] === Thanks * TAKATSU Tomonari * dmaciejak * Grant Schoep * Carlo E. Prelz * Marvin Gülker
- Loading branch information
obache
committed
Feb 7, 2013
1 parent
95aed17
commit 7252e2b
Showing
34 changed files
with
291 additions
and
33 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,7 @@ | ||
@comment $NetBSD: PLIST,v 1.2 2012/01/11 13:47:30 obache Exp $ | ||
@comment $NetBSD: PLIST,v 1.3 2013/02/07 13:41:55 obache Exp $ | ||
lib/pkgconfig/ruby-gio2.pc | ||
${RUBY_VENDORLIB}/gio2.rb | ||
${RUBY_VENDORLIB}/gio2/deprecated.rb | ||
${RUBY_VENDORARCHLIB}/gio2.${RUBY_DLEXT} | ||
${RUBY_VENDORARCHLIB}/rbgio2.h | ||
${RUBY_VENDORARCHLIB}/rbgio2conversions.h |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
# $NetBSD: buildlink3.mk,v 1.1 2013/02/07 13:41:55 obache Exp $ | ||
|
||
BUILDLINK_TREE+= ruby-gnome2-gio | ||
|
||
.if !defined(RUBY_GNOME2_GIO_BUILDLINK3_MK) | ||
RUBY_GNOME2_GIO_BUILDLINK3_MK:= | ||
|
||
BUILDLINK_API_DEPENDS.ruby-gnome2-gio+= ${RUBY_PKGPREFIX}-gnome2-gio>=1.2.0 | ||
BUILDLINK_PKGSRCDIR.ruby-gnome2-gio?= ../../devel/ruby-gnome2-gio | ||
|
||
.include "../../devel/glib2/buildlink3.mk" | ||
.include "../../lang/ruby/buildlink3.mk" | ||
.endif # RUBY_GNOME2_GIO_BUILDLINK3_MK | ||
|
||
BUILDLINK_TREE+= -ruby-gnome2-gio |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
Ruby-GNOME 2 is a set of Ruby language bindings for the various | ||
application development libraries included with the GNOME/GTK+ | ||
environment. | ||
|
||
Ruby/GObjectIntrospection is a Ruby binding of GObject Introspection. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
# $NetBSD: Makefile,v 1.1 2013/02/07 13:41:55 obache Exp $ | ||
# | ||
|
||
PKGNAME= ${RUBY_PKGPREFIX}-gnome2-gobject-introspection-${VERSION} | ||
COMMENT= Ruby binding of Gobject Introspection | ||
CATEGORIES= devel | ||
|
||
CONFLICTS+= ruby-gnome2-gobject-introspection-[0-9]* | ||
CONFLICTS+= ruby[0-9][0-9]-gnome2-gobject-introspection-[0-9]* | ||
|
||
RUBY_EXTCONF_SUBDIRS= gobject-introspection | ||
|
||
do-test: | ||
${RUN} cd ${WRKSRC}/gobject-introspection/test; ${SETENV} ${TEST_ENV} ${RUBY} run-test.rb | ||
|
||
BUILDLINK_API_DEPENDS.gobject-introspection+= gobject-introspection>=1.32.1 | ||
.include "../../devel/gobject-introspection/buildlink3.mk" | ||
BUILDLINK_API_DEPENDS.ruby-gnome2-glib+= ${RUBY_PKGPREFIX}-gnome2-glib>=${VERSION} | ||
.include "../../devel/ruby-gnome2-glib/buildlink3.mk" | ||
.include "../../devel/ruby-pkg-config/tool.mk" | ||
.include "../../meta-pkgs/ruby-gnome2/Makefile.common" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
@comment $NetBSD: PLIST,v 1.1 2013/02/07 13:41:55 obache Exp $ | ||
${RUBY_VENDORLIB}/gobject-introspection.rb | ||
${RUBY_VENDORLIB}/gobject-introspection/callable-info.rb | ||
${RUBY_VENDORLIB}/gobject-introspection/collection-reader.rb | ||
${RUBY_VENDORLIB}/gobject-introspection/interface-info.rb | ||
${RUBY_VENDORLIB}/gobject-introspection/loader.rb | ||
${RUBY_VENDORLIB}/gobject-introspection/object-info.rb | ||
${RUBY_VENDORLIB}/gobject-introspection/repository.rb | ||
${RUBY_VENDORLIB}/gobject-introspection/struct-info.rb | ||
${RUBY_VENDORLIB}/gobject-introspection/union-info.rb | ||
${RUBY_VENDORARCHLIB}/gobject_introspection.${RUBY_DLEXT} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
# $NetBSD: buildlink3.mk,v 1.1 2013/02/07 13:41:55 obache Exp $ | ||
|
||
BUILDLINK_TREE+= ruby-gnome2-gobject-introspection | ||
|
||
.if !defined(RUBY_GNOME2_GOBJECT_INTROSPECTION_BUILDLINK3_MK) | ||
RUBY_GNOME2_GOBJECT_INTROSPECTION_BUILDLINK3_MK:= | ||
|
||
BUILDLINK_API_DEPENDS.ruby-gnome2-gobject-introspection+= ${RUBY_PKGPREFIX}-gnome2-gobject-introspection>=1.2.0 | ||
BUILDLINK_PKGSRCDIR.ruby-gnome2-gobject-introspection?= ../../devel/ruby-gnome2-gobject-introspection | ||
|
||
.include "../../devel/gobject-introspection/buildlink3.mk" | ||
.include "../../lang/ruby/buildlink3.mk" | ||
.endif # RUBY_GNOME2_GOBJECT_INTROSPECTION_BUILDLINK3_MK | ||
|
||
BUILDLINK_TREE+= -ruby-gnome2-gobject-introspection |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
Ruby-GNOME 2 is a set of Ruby language bindings for the various | ||
application development libraries included with the GNOME/GTK+ | ||
environment. | ||
|
||
Ruby/GDK3 is a Ruby binding of GDK3. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
# $NetBSD: Makefile,v 1.1 2013/02/07 13:41:55 obache Exp $ | ||
# | ||
|
||
PKGNAME= ${RUBY_PKGPREFIX}-gnome2-gdk3-${VERSION} | ||
COMMENT= Ruby binding of GDK3 | ||
CATEGORIES= graphics | ||
|
||
CONFLICTS+= ruby[0-9][0-9]-gnome2-gdk3-[0-9]* | ||
|
||
RUBY_EXTCONF_SUBDIRS= gdk3 | ||
|
||
DEPENDS+= ${RUBY_PKGPREFIX}-gnome2-atk>=${VERSION}:../../devel/ruby-gnome2-atk | ||
DEPENDS+= ${RUBY_PKGPREFIX}-gnome2-gdkpixbuf>=${VERSION}:../../graphics/ruby-gnome2-gdkpixbuf | ||
|
||
RUBY_VERSION_SUPPORTED= 193 | ||
|
||
do-test: | ||
${RUN} cd ${WRKSRC}/gtk2/test; ${SETENV} ${TEST_ENV} ${RUBY} run-test.rb | ||
|
||
BUILDLINK_API_DEPENDS.ruby-gnome2-glib+= ${RUBY_PKGPREFIX}-gnome2-glib>=${VERSION} | ||
.include "../../devel/ruby-gnome2-glib/buildlink3.mk" | ||
BUILDLINK_API_DEPENDS.ruby-gnome2-pango+= ${RUBY_PKGPREFIX}-gnome2-pango>=${VERSION} | ||
.include "../../devel/ruby-gnome2-pango/buildlink3.mk" | ||
.include "../../graphics/ruby-rcairo/buildlink3.mk" | ||
BUILDLINK_API_DEPENDS.gtk3+= gtk3+>=3.4.2 | ||
.include "../../x11/gtk3/buildlink3.mk" | ||
.include "../../devel/ruby-pkg-config/tool.mk" | ||
.include "../../meta-pkgs/ruby-gnome2/Makefile.common" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
@comment $NetBSD: PLIST,v 1.1 2013/02/07 13:41:55 obache Exp $ | ||
lib/pkgconfig/ruby-gdk3.pc | ||
${RUBY_VENDORLIB}/gdk3.rb | ||
${RUBY_VENDORLIB}/gdk3/base.rb | ||
${RUBY_VENDORLIB}/gdk3/deprecated.rb | ||
${RUBY_VENDORARCHLIB}/gdk3.${RUBY_DLEXT} | ||
${RUBY_VENDORARCHLIB}/rbgdk3.h | ||
${RUBY_VENDORARCHLIB}/rbgdk3conversions.h |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
# $NetBSD: buildlink3.mk,v 1.1 2013/02/07 13:41:55 obache Exp $ | ||
|
||
BUILDLINK_TREE+= ruby-gnome2-gdk3 | ||
|
||
.if !defined(RUBY_GNOME2_GDK3_BUILDLINK3_MK) | ||
RUBY_GNOME2_GDK3_BUILDLINK3_MK:= | ||
|
||
BUILDLINK_API_DEPENDS.ruby-gnome2-gdk3+= ${RUBY_PKGPREFIX}-gnome2-gtk3>=2.0.0 | ||
BUILDLINK_PKGSRCDIR.ruby-gnome2-gdk3?= ../../graphics/ruby-gnome2-gdk3 | ||
|
||
.include "../../x11/gtk3/buildlink3.mk" | ||
.endif # RUBY_GNOME2_GDK3_BUILDLINK3_MK | ||
|
||
BUILDLINK_TREE+= -ruby-gnome2-gdk3 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,16 +1,20 @@ | ||
# $NetBSD: Makefile.common,v 1.26 2012/08/30 13:36:32 obache Exp $ | ||
# $NetBSD: Makefile.common,v 1.27 2013/02/07 13:41:54 obache Exp $ | ||
# | ||
# used by devel/ruby-gnome2-atk/Makefile | ||
# used by devel/ruby-gnome2-gio/Makefile | ||
# used by devel/ruby-gnome2-glib/Makefile | ||
# used by devel/ruby-gnome2-gobject-introspection/Makefile | ||
# used by devel/ruby-gnome2-pango/Makefile | ||
# used by graphics/ruby-gnome2-gdk3/Makefile | ||
# used by graphics/ruby-gnome2-gdkpixbuf/Makefile | ||
# used by graphics/ruby-gnome2-goocanvas/Makefile | ||
# used by graphics/ruby-gnome2-rsvg/Makefile | ||
# used by multimedia/ruby-gnome2-gstreamer/Makefile | ||
# used by print/ruby-gnome2-poppler/Makefile | ||
# used by x11/ruby-gnome2-gtk/Makefile | ||
# used by x11/ruby-gnome2-gtk3/Makefile | ||
# used by x11/ruby-gnome2-gtksourceview2/Makefile | ||
# used by x11/ruby-gnome2-gtksourceview3/Makefile | ||
# used by x11/ruby-gnome2-vte/Makefile | ||
|
||
DISTNAME= ruby-gnome2-all-${VERSION} | ||
|
@@ -24,13 +28,15 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://ruby-gnome2.sourceforge.jp/ | ||
LICENSE= gnu-lgpl-v2.1 | ||
|
||
VERSION= 1.1.5 | ||
USE_RUBY_EXTCONF= yes | ||
VERSION= 1.2.1 | ||
USE_RUBY_EXTCONF?= yes | ||
CONFIGURE_ENV+= RUBYOPT="-Ku" | ||
|
||
INSTALL_TARGET= install | ||
|
||
.if defined(USE_RUBY_EXTCONF) && empty(USE_RUBY_EXTCONF:M[Nn][Oo]) | ||
CONFIGURE_ARGS+= --with-pkg-config-dir=${DESTDIR:Q}${PREFIX:Q}/lib/pkgconfig | ||
.endif | ||
|
||
.include "../../lang/ruby/modules.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,8 @@ | ||
$NetBSD: distinfo,v 1.30 2012/08/30 13:36:32 obache Exp $ | ||
$NetBSD: distinfo,v 1.31 2013/02/07 13:41:54 obache Exp $ | ||
|
||
SHA1 (ruby-gnome2-all-1.1.5.tar.gz) = 2b47dea62101aa5116ad94e29465bdaaf45f2f49 | ||
RMD160 (ruby-gnome2-all-1.1.5.tar.gz) = 0cdf62b69ba67f4da552c5ef2a5a16d7fff4c0ac | ||
Size (ruby-gnome2-all-1.1.5.tar.gz) = 1016680 bytes | ||
SHA1 (ruby-gnome2-all-1.2.1.tar.gz) = cbf6cbe574f27582acdb93c9ebed828b0126f553 | ||
RMD160 (ruby-gnome2-all-1.2.1.tar.gz) = 76091e8dfdceb889ff75c6076f665d118765d908 | ||
Size (ruby-gnome2-all-1.2.1.tar.gz) = 1680458 bytes | ||
SHA1 (patch-glib2_ext_glib2_rbglib.h) = 1a504f24e09acb6e962bde5fd8eace5696572ae4 | ||
SHA1 (patch-glib2_ext_glib2_rbgprivate.h) = 73ce03f3a64c3e2f54247012211fac359eb6ccf2 | ||
SHA1 (patch-glib2_lib_mkmf-gnome2.rb) = 7ea9f2066aae905e64d8477f500245e3e3b5df9e |
20 changes: 20 additions & 0 deletions
20
meta-pkgs/ruby-gnome2/patches/patch-glib2_ext_glib2_rbglib.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
$NetBSD: patch-glib2_ext_glib2_rbglib.h,v 1.1 2013/02/07 13:41:54 obache Exp $ | ||
|
||
* Move rb_str_new_cstr() compatible macro to private header | ||
Because all rbglib.h users should check rb_str_new_cstr() check when | ||
it exists in rbglib.h. | ||
https://github.com/ruby-gnome2/ruby-gnome2/commit/97e6965c4b4463c5aa687b4827f3ef52e7054571 | ||
|
||
--- glib2/ext/glib2/rbglib.h.orig 2013-01-30 14:00:35.000000000 +0000 | ||
+++ glib2/ext/glib2/rbglib.h | ||
@@ -63,10 +63,6 @@ typedef int GPid; | ||
# define G_SOURCE_CONTINUE TRUE | ||
#endif | ||
|
||
-#ifndef HAVE_RB_STR_NEW_CSTR | ||
-# define rb_str_new_cstr(c_string) rb_str_new2(c_string) | ||
-#endif | ||
- | ||
#define RBG_INSPECT(object) (rbg_rval_inspect(object)) | ||
|
||
#define RVAL2CSTR(v) (rbg_rval2cstr(&(v))) |
28 changes: 28 additions & 0 deletions
28
meta-pkgs/ruby-gnome2/patches/patch-glib2_ext_glib2_rbgprivate.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
$NetBSD: patch-glib2_ext_glib2_rbgprivate.h,v 1.1 2013/02/07 13:41:54 obache Exp $ | ||
|
||
* Move rb_str_new_cstr() compatible macro to private header | ||
Because all rbglib.h users should check rb_str_new_cstr() check when | ||
it exists in rbglib.h. | ||
https://github.com/ruby-gnome2/ruby-gnome2/commit/97e6965c4b4463c5aa687b4827f3ef52e7054571 | ||
|
||
--- glib2/ext/glib2/rbgprivate.h.orig 2012-07-21 14:29:19.000000000 +0000 | ||
+++ glib2/ext/glib2/rbgprivate.h | ||
@@ -1,6 +1,6 @@ | ||
/* -*- c-file-style: "ruby"; indent-tabs-mode: nil -*- */ | ||
/* | ||
- * Copyright (C) 2011 Ruby-GNOME2 Project Team | ||
+ * Copyright (C) 2011-2013 Ruby-GNOME2 Project Team | ||
* Copyright (C) 2007 Ruby-GNOME2 Project Team | ||
* | ||
* This library is free software; you can redistribute it and/or | ||
@@ -29,6 +29,10 @@ | ||
# define rb_errinfo() (ruby_errinfo) | ||
#endif | ||
|
||
+#ifndef HAVE_RB_STR_NEW_CSTR | ||
+# define rb_str_new_cstr(c_string) rb_str_new2(c_string) | ||
+#endif | ||
+ | ||
#ifndef G_VALUE_INIT | ||
# define G_VALUE_INIT { 0, { { 0 } } } | ||
#endif |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
Ruby-GNOME 2 is a set of Ruby language bindings for the various | ||
application development libraries included with the GNOME/GTK+ | ||
environment. | ||
|
||
Ruby/GTK3 is a Ruby binding of GTK+-3.0.x. |
Oops, something went wrong.