Skip to content

Commit

Permalink
kde-frameworks/purpose-kaccounts-services: 6.10.0 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jan 8, 2025
1 parent 7802bb7 commit aa25b1d
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions kde-frameworks/purpose-kaccounts-services/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST purpose-6.10.0.tar.xz 188940 BLAKE2B a51200beca1dad78b164f276b1b4333455cc8af8f805fb9be4873789879e1f3edd2cbb69614ca4b192e036fa1bd4746bd7f4114e12cc1751e0877e4914dd6b6f SHA512 b6d847e4715a5779c10da92179db9d0a858c62582b729bcc25fc1d2e9796cfa634d4cb1cf49283c3d0364f96f97fc3420895ab4aad526920d65fcf2518e4b39f
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# this is purely for service file creation
ECM_I18N="false"
ECM_HANDBOOK="false"
KDE_ORG_NAME="${PN/-kaccounts-services/}"
inherit ecm-common frameworks.kde.org

DESCRIPTION="KAccounts generated service files for nextcloud and google services"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE=""

RDEPEND="
!<kde-frameworks/purpose-5.116.0-r2:5
!<kde-frameworks/purpose-6.5.0-r1:6
"
BDEPEND="kde-apps/kaccounts-integration:6"

ecm-common_inject_heredoc() {
cat >> CMakeLists.txt <<- _EOF_ || die
find_package(KAccounts6 REQUIRED)
kaccounts_add_service(\${CMAKE_CURRENT_SOURCE_DIR}/src/plugins/nextcloud/nextcloud-upload.service.in)
kaccounts_add_service(\${CMAKE_CURRENT_SOURCE_DIR}/src/plugins/youtube/google-youtube.service.in)
_EOF_
}

src_prepare() {
ecm-common_src_prepare

# Safety measure in case new services are added in the future
local known_num_of_services=2
local found_num_of_services=$(find . -iname "*service.in" | wc -l)
if [[ ${found_num_of_services} != ${known_num_of_services} ]]; then
eerror "Number of service files mismatch!"
eerror "Expected: ${known_num_of_services}"
eerror "Found: ${found_num_of_services}"
die
fi
}

0 comments on commit aa25b1d

Please sign in to comment.