Skip to content

Commit

Permalink
Update py-werkzeug (and thus -docs) to 0.10.4.
Browse files Browse the repository at this point in the history
Due to a change in packaging the docs themes are currently excluded from
the pypi distribution, breaking the -docs package.  Issue ``#761`` should
address this upstream; we'll being using GitHub as the master site for the
time being.


Version 0.10.4
--------------

(bugfix release, released on March 26th 2015)

- Re-release of 0.10.3 with packaging artifacts manually removed.

Version 0.10.3
--------------

(bugfix release, released on March 26th 2015)

- Re-release of 0.10.2 without packaging artifacts.

Version 0.10.2
--------------

(bugfix release, released on March 26th 2015)

- Fixed issue where ``empty`` could break third-party libraries that relied on
  keyword arguments (pull request ``#675``)
- Improved ``Rule.empty`` by providing a ```get_empty_kwargs`` to allow setting
  custom kwargs without having to override entire ``empty`` method. (pull
  request ``#675``)
- Fixed ```extra_files``` parameter for reloader to not cause startup
  to crash when included in server params
- Using `MultiDict` when building URLs is now not supported again. The behavior
  introduced several regressions.
- Fix performance problems with stat-reloader (pull request ``#715``).

Version 0.10.1
--------------

(bugfix release, released on February 3rd 2015)

- Fixed regression with multiple query values for URLs (pull request ``#667``).
- Fix issues with eventlet's monkeypatching and the builtin server (pull
  request ``#663``).

Version 0.10
------------

Released on January 30th 2015, codename Bagger.

- Changed the error handling of and improved testsuite for the caches in
  ``contrib.cache``.
- Fixed a bug on Python 3 when creating adhoc ssl contexts, due to `sys.maxint`
  not being defined.
- Fixed a bug on Python 3, that caused
  :func:`~werkzeug.serving.make_ssl_devcert` to fail with an exception.
- Added exceptions for 504 and 505.
- Added support for ChromeOS detection.
- Added UUID converter to the routing system.
- Added message that explains how to quit the server.
- Fixed a bug on Python 2, that caused ``len`` for
  :class:`werkzeug.datastructures.CombinedMultiDict` to crash.
- Added support for stdlib pbkdf2 hmac if a compatible digest
  is found.
- Ported testsuite to use ``py.test``.
- Minor optimizations to various middlewares (pull requests ``#496`` and
  ``#571``).
- Use stdlib ``ssl`` module instead of ``OpenSSL`` for the builtin server
  (issue ``#434``). This means that OpenSSL contexts are not supported anymore,
  but instead ``ssl.SSLContext`` from the stdlib.
- Allow protocol-relative URLs when building external URLs.
- Fixed Atom syndication to print time zone offset for tz-aware datetime
  objects (pull request ``#254``).
- Improved reloader to track added files and to recover from broken
  sys.modules setups with syntax errors in packages.
- ``cache.RedisCache`` now supports arbitrary ``**kwargs`` for the redis
  object.
- ``werkzeug.test.Client`` now uses the original request method when resolving
  307 redirects (pull request ``#556``).
- ``werkzeug.datastructures.MIMEAccept`` now properly deals with mimetype
  parameters (pull request ``#205``).
- ``werkzeug.datastructures.Accept`` now handles a quality of ``0`` as
  intolerable, as per RFC 2616 (pull request ``#536``).
- ``werkzeug.urls.url_fix`` now properly encodes hostnames with ``idna``
  encoding (issue ``#559``). It also doesn't crash on malformed URLs anymore
  (issue ``#582``).
- ``werkzeug.routing.MapAdapter.match`` now recognizes the difference between
  the path ``/`` and an empty one (issue ``#360``).
- The interactive debugger now tries to decode non-ascii filenames (issue
  ``#469``).
- Increased default key size of generated SSL certificates to 1024 bits (issue
  ``#611``).
- Added support for specifying a ``Response`` subclass to use when calling
  :func:`~werkzeug.utils.redirect`\ .
- ``werkzeug.test.EnvironBuilder`` now doesn't use the request method anymore
  to guess the content type, and purely relies on the ``form``, ``files`` and
  ``input_stream`` properties (issue ``#620``).
- Added Symbian to the user agent platform list.
- Fixed make_conditional to respect automatically_set_content_length
- Unset ``Content-Length`` when writing to response.stream (issue ``#451``)
- ``wrappers.Request.method`` is now always uppercase, eliminating
  inconsistencies of the WSGI environment (issue ``647``).
- ``routing.Rule.empty`` now works correctly with subclasses of ``Rule`` (pull
  request ``#645``).
- Made map updating safe in light of concurrent updates.
- Allow multiple values for the same field for url building (issue ``#658``).

Version 0.9.7
-------------

(bugfix release, release date to be decided)

- Fix unicode problems in ``werkzeug.debug.tbtools``.
- Fix Python 3-compatibility problems in ``werkzeug.posixemulation``.
- Backport fix of fatal typo for ``ImmutableList`` (issue ``#492``).
- Make creation of the cache dir for ``FileSystemCache`` atomic (issue
  ``#468``).
- Use native strings for memcached keys to work with Python 3 client (issue
  ``#539``).
- Fix charset detection for ``werkzeug.debug.tbtools.Frame`` objects (issues
  ``#547`` and ``#532``).
- Fix ``AttributeError`` masking in ``werkzeug.utils.import_string`` (issue
  ``#182``).
- Explicitly shut down server (issue ``#519``).
- Fix timeouts greater than 2592000 being misinterpreted as UNIX timestamps in
  ``werkzeug.contrib.cache.MemcachedCache`` (issue ``#533``).
- Fix bug where ``werkzeug.exceptions.abort`` would raise an arbitrary subclass
  of the expected class (issue ``#422``).
- Fix broken ``jsrouting`` (due to removal of ``werkzeug.templates``)
- ``werkzeug.urls.url_fix`` now doesn't crash on malformed URLs anymore, but
  returns them unmodified. This is a cheap workaround for ``#582``, the proper
  fix is included in version 0.10.
- The repr of ``werkzeug.wrappers.Request`` doesn't crash on non-ASCII-values
  anymore (pull request ``#466``).
- Fix bug in ``cache.RedisCache`` when combined with ``redis.StrictRedis``
  object (pull request ``#583``).
- The ``qop`` parameter for ``WWW-Authenticate`` headers is now always quoted,
  as required by RFC 2617 (issue ``#633``).
- Fix bug in ``werkzeug.contrib.cache.SimpleCache`` with Python 3 where add/set
  may throw an exception when pruning old entries from the cache (pull request
  ``#651``).
  • Loading branch information
kleink committed Aug 16, 2015
1 parent 3e5a8b6 commit eb9b8d6
Show file tree
Hide file tree
Showing 5 changed files with 39 additions and 107 deletions.
10 changes: 8 additions & 2 deletions www/py-werkzeug/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2014/01/25 10:30:30 wiz Exp $
# $NetBSD: Makefile,v 1.8 2015/08/16 16:18:24 kleink Exp $

PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}

Expand All @@ -18,7 +18,7 @@ REPLACE_PYTHON+= examples/manage-simplewiki.py
REPLACE_PYTHON+= examples/manage-webpylike.py
REPLACE_PYTHON+= examples/upload.py
REPLACE_PYTHON+= examples/contrib/sessions.py
REPLACE_PYTHON+= werkzeug/testsuite/multipart/collect.py
REPLACE_PYTHON+= tests/multipart/test_collect.py

DOCFILES= AUTHORS CHANGES

Expand All @@ -38,6 +38,12 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${i} ${DESTDIR}${PREFIX}/${DOCDIR}
.endfor
cd ${WRKSRC}/examples && pax -rwppm . ${DESTDIR}${PREFIX}/${EGDIR}
.for i in manage-coolmagic.py manage-couchy.py manage-cupoftee.py \
manage-i18nurls.py manage-plnt.py manage-shorty.py manage-simplewiki.py \
manage-webpylike.py
${CHMOD} ${SHAREMODE} \
${DESTDIR}${PREFIX}/${EGDIR}/${i}
.endfor
.for i in down.png up.png
${CHMOD} ${SHAREMODE} \
${DESTDIR}${PREFIX}/${EGDIR}/cupoftee/shared/${i}
Expand Down
10 changes: 7 additions & 3 deletions www/py-werkzeug/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,18 +1,22 @@
# $NetBSD: Makefile.common,v 1.7 2014/06/13 15:40:42 kleink Exp $
# $NetBSD: Makefile.common,v 1.8 2015/08/16 16:18:24 kleink Exp $

# used by www/py-werkzeug/Makefile
# used by www/py-werkzeug-docs/Makefile

DISTNAME= Werkzeug-0.9.6
DISTNAME= Werkzeug-0.10.4
CATEGORIES= www python
MASTER_SITES= http://pypi.python.org/packages/source/W/Werkzeug/
MASTER_SITES= ${MASTER_SITE_GITHUB:=mitsuhiko/}
GITHUB_PROJECT= ${DISTNAME:tl:C/-[^-]*$//}

DISTINFO_FILE= ${.CURDIR}/../../www/py-werkzeug/distinfo
PATCHDIR= ${.CURDIR}/../../www/py-werkzeug/patches

MAINTAINER= [email protected]
HOMEPAGE= http://werkzeug.pocoo.org/
LICENSE= modified-bsd

WRKSRC= ${WRKDIR}/${DISTNAME:tl}

DOCDIR= share/doc/${PYPKGPREFIX}-${DISTNAME:tl:C/-[^-]*$//}

PLIST_SUBST+= DOCDIR=${DOCDIR}
102 changes: 4 additions & 98 deletions www/py-werkzeug/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2013/07/09 17:11:42 kleink Exp $
@comment $NetBSD: PLIST,v 1.4 2015/08/16 16:18:24 kleink Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
Expand All @@ -13,6 +13,9 @@ ${PYSITELIB}/werkzeug/_compat.pyo
${PYSITELIB}/werkzeug/_internal.py
${PYSITELIB}/werkzeug/_internal.pyc
${PYSITELIB}/werkzeug/_internal.pyo
${PYSITELIB}/werkzeug/_reloader.py
${PYSITELIB}/werkzeug/_reloader.pyc
${PYSITELIB}/werkzeug/_reloader.pyo
${PYSITELIB}/werkzeug/contrib/__init__.py
${PYSITELIB}/werkzeug/contrib/__init__.pyc
${PYSITELIB}/werkzeug/contrib/__init__.pyo
Expand Down Expand Up @@ -109,103 +112,6 @@ ${PYSITELIB}/werkzeug/test.pyo
${PYSITELIB}/werkzeug/testapp.py
${PYSITELIB}/werkzeug/testapp.pyc
${PYSITELIB}/werkzeug/testapp.pyo
${PYSITELIB}/werkzeug/testsuite/__init__.py
${PYSITELIB}/werkzeug/testsuite/__init__.pyc
${PYSITELIB}/werkzeug/testsuite/__init__.pyo
${PYSITELIB}/werkzeug/testsuite/compat.py
${PYSITELIB}/werkzeug/testsuite/compat.pyc
${PYSITELIB}/werkzeug/testsuite/compat.pyo
${PYSITELIB}/werkzeug/testsuite/contrib/__init__.py
${PYSITELIB}/werkzeug/testsuite/contrib/__init__.pyc
${PYSITELIB}/werkzeug/testsuite/contrib/__init__.pyo
${PYSITELIB}/werkzeug/testsuite/contrib/cache.py
${PYSITELIB}/werkzeug/testsuite/contrib/cache.pyc
${PYSITELIB}/werkzeug/testsuite/contrib/cache.pyo
${PYSITELIB}/werkzeug/testsuite/contrib/fixers.py
${PYSITELIB}/werkzeug/testsuite/contrib/fixers.pyc
${PYSITELIB}/werkzeug/testsuite/contrib/fixers.pyo
${PYSITELIB}/werkzeug/testsuite/contrib/iterio.py
${PYSITELIB}/werkzeug/testsuite/contrib/iterio.pyc
${PYSITELIB}/werkzeug/testsuite/contrib/iterio.pyo
${PYSITELIB}/werkzeug/testsuite/contrib/securecookie.py
${PYSITELIB}/werkzeug/testsuite/contrib/securecookie.pyc
${PYSITELIB}/werkzeug/testsuite/contrib/securecookie.pyo
${PYSITELIB}/werkzeug/testsuite/contrib/sessions.py
${PYSITELIB}/werkzeug/testsuite/contrib/sessions.pyc
${PYSITELIB}/werkzeug/testsuite/contrib/sessions.pyo
${PYSITELIB}/werkzeug/testsuite/contrib/wrappers.py
${PYSITELIB}/werkzeug/testsuite/contrib/wrappers.pyc
${PYSITELIB}/werkzeug/testsuite/contrib/wrappers.pyo
${PYSITELIB}/werkzeug/testsuite/datastructures.py
${PYSITELIB}/werkzeug/testsuite/datastructures.pyc
${PYSITELIB}/werkzeug/testsuite/datastructures.pyo
${PYSITELIB}/werkzeug/testsuite/debug.py
${PYSITELIB}/werkzeug/testsuite/debug.pyc
${PYSITELIB}/werkzeug/testsuite/debug.pyo
${PYSITELIB}/werkzeug/testsuite/exceptions.py
${PYSITELIB}/werkzeug/testsuite/exceptions.pyc
${PYSITELIB}/werkzeug/testsuite/exceptions.pyo
${PYSITELIB}/werkzeug/testsuite/formparser.py
${PYSITELIB}/werkzeug/testsuite/formparser.pyc
${PYSITELIB}/werkzeug/testsuite/formparser.pyo
${PYSITELIB}/werkzeug/testsuite/http.py
${PYSITELIB}/werkzeug/testsuite/http.pyc
${PYSITELIB}/werkzeug/testsuite/http.pyo
${PYSITELIB}/werkzeug/testsuite/internal.py
${PYSITELIB}/werkzeug/testsuite/internal.pyc
${PYSITELIB}/werkzeug/testsuite/internal.pyo
${PYSITELIB}/werkzeug/testsuite/local.py
${PYSITELIB}/werkzeug/testsuite/local.pyc
${PYSITELIB}/werkzeug/testsuite/local.pyo
${PYSITELIB}/werkzeug/testsuite/multipart/collect.py
${PYSITELIB}/werkzeug/testsuite/multipart/collect.pyc
${PYSITELIB}/werkzeug/testsuite/multipart/collect.pyo
${PYSITELIB}/werkzeug/testsuite/multipart/firefox3-2png1txt/file1.png
${PYSITELIB}/werkzeug/testsuite/multipart/firefox3-2png1txt/file2.png
${PYSITELIB}/werkzeug/testsuite/multipart/firefox3-2png1txt/request.txt
${PYSITELIB}/werkzeug/testsuite/multipart/firefox3-2png1txt/text.txt
${PYSITELIB}/werkzeug/testsuite/multipart/firefox3-2pnglongtext/file1.png
${PYSITELIB}/werkzeug/testsuite/multipart/firefox3-2pnglongtext/file2.png
${PYSITELIB}/werkzeug/testsuite/multipart/firefox3-2pnglongtext/request.txt
${PYSITELIB}/werkzeug/testsuite/multipart/firefox3-2pnglongtext/text.txt
${PYSITELIB}/werkzeug/testsuite/multipart/ie6-2png1txt/file1.png
${PYSITELIB}/werkzeug/testsuite/multipart/ie6-2png1txt/file2.png
${PYSITELIB}/werkzeug/testsuite/multipart/ie6-2png1txt/request.txt
${PYSITELIB}/werkzeug/testsuite/multipart/ie6-2png1txt/text.txt
${PYSITELIB}/werkzeug/testsuite/multipart/ie7_full_path_request.txt
${PYSITELIB}/werkzeug/testsuite/multipart/opera8-2png1txt/file1.png
${PYSITELIB}/werkzeug/testsuite/multipart/opera8-2png1txt/file2.png
${PYSITELIB}/werkzeug/testsuite/multipart/opera8-2png1txt/request.txt
${PYSITELIB}/werkzeug/testsuite/multipart/opera8-2png1txt/text.txt
${PYSITELIB}/werkzeug/testsuite/multipart/webkit3-2png1txt/file1.png
${PYSITELIB}/werkzeug/testsuite/multipart/webkit3-2png1txt/file2.png
${PYSITELIB}/werkzeug/testsuite/multipart/webkit3-2png1txt/request.txt
${PYSITELIB}/werkzeug/testsuite/multipart/webkit3-2png1txt/text.txt
${PYSITELIB}/werkzeug/testsuite/res/test.txt
${PYSITELIB}/werkzeug/testsuite/routing.py
${PYSITELIB}/werkzeug/testsuite/routing.pyc
${PYSITELIB}/werkzeug/testsuite/routing.pyo
${PYSITELIB}/werkzeug/testsuite/security.py
${PYSITELIB}/werkzeug/testsuite/security.pyc
${PYSITELIB}/werkzeug/testsuite/security.pyo
${PYSITELIB}/werkzeug/testsuite/serving.py
${PYSITELIB}/werkzeug/testsuite/serving.pyc
${PYSITELIB}/werkzeug/testsuite/serving.pyo
${PYSITELIB}/werkzeug/testsuite/test.py
${PYSITELIB}/werkzeug/testsuite/test.pyc
${PYSITELIB}/werkzeug/testsuite/test.pyo
${PYSITELIB}/werkzeug/testsuite/urls.py
${PYSITELIB}/werkzeug/testsuite/urls.pyc
${PYSITELIB}/werkzeug/testsuite/urls.pyo
${PYSITELIB}/werkzeug/testsuite/utils.py
${PYSITELIB}/werkzeug/testsuite/utils.pyc
${PYSITELIB}/werkzeug/testsuite/utils.pyo
${PYSITELIB}/werkzeug/testsuite/wrappers.py
${PYSITELIB}/werkzeug/testsuite/wrappers.pyc
${PYSITELIB}/werkzeug/testsuite/wrappers.pyo
${PYSITELIB}/werkzeug/testsuite/wsgi.py
${PYSITELIB}/werkzeug/testsuite/wsgi.pyc
${PYSITELIB}/werkzeug/testsuite/wsgi.pyo
${PYSITELIB}/werkzeug/urls.py
${PYSITELIB}/werkzeug/urls.pyc
${PYSITELIB}/werkzeug/urls.pyo
Expand Down
9 changes: 5 additions & 4 deletions www/py-werkzeug/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.6 2014/06/13 15:40:42 kleink Exp $
$NetBSD: distinfo,v 1.7 2015/08/16 16:18:24 kleink Exp $

SHA1 (Werkzeug-0.9.6.tar.gz) = d1bc1153ea45c6951845338a8499d94bad46e316
RMD160 (Werkzeug-0.9.6.tar.gz) = a678e4ea4b2a80c333a5cac5e899f80006883dc6
Size (Werkzeug-0.9.6.tar.gz) = 1128428 bytes
SHA1 (Werkzeug-0.10.4.tar.gz) = aa0c13e3c2a59f53e857f5bf33dc5aea282550cb
RMD160 (Werkzeug-0.10.4.tar.gz) = e12d6b8b2c2df2674b0c09cb906c476fcfda6b98
Size (Werkzeug-0.10.4.tar.gz) = 1152998 bytes
SHA1 (patch-setup.cfg) = 3430a820f2eaa545e72c97e07b0be3c6e7718b1b
15 changes: 15 additions & 0 deletions www/py-werkzeug/patches/patch-setup.cfg
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
$NetBSD: patch-setup.cfg,v 1.1 2015/08/16 16:18:24 kleink Exp $

Do not include (dev) tag or date in egg name.

--- setup.cfg.orig 2015-03-26 15:49:54.000000000 +0000
+++ setup.cfg
@@ -1,6 +1,6 @@
[egg_info]
-tag_build = dev
-tag_date = true
+tag_build =
+tag_date = 0

[aliases]
release = egg_info -RDb ''

0 comments on commit eb9b8d6

Please sign in to comment.